nm-applet leaks memory when connected to cdma connection

Bug #939802 reported by Omer Akram on 2012-02-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre

Bug Description

If I get online with wifi I don't see the leak. but when I use the evdo usb stick to connect to the internet its like 1m/10sec of memory lost. attached valgrind logs

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager-gnome 0.9.2.0+git.20120126t000800.5151959-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
Date: Fri Feb 24 01:25:43 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120210)
IpRoute:
 default via 172.16.33.41 dev ppp0 proto static
 169.254.0.0/16 dev ppp0 scope link metric 1000
 172.16.33.41 dev ppp0 proto kernel scope link src 111.88.7.41
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=false
 WWANEnabled=false
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 World Call connection 003e2bf3-9212-435e-80d5-80afcbe05eca cdma 1330028554 Fri 24 Feb 2012 01:22:34 AM PKT no no /org/freedesktop/NetworkManager/Settings/2
 TP-LINK a76360b3-2c08-4192-9b83-3bdd5ac50e1f 802-11-wireless 1330028467 Fri 24 Feb 2012 01:21:07 AM PKT yes no /org/freedesktop/NetworkManager/Settings/1
 Hotspot 465c08e1-ee8f-4a75-b19f-d4d8f7384a54 802-11-wireless 0 never no no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 ttyUSB0 cdma connected /org/freedesktop/NetworkManager/Devices/2
 wlan0 802-11-wireless unavailable /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.0 connected enabled enabled disabled enabled disabled

Omer Akram (om26er) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Paul (i41bktob-launchpad-net) wrote :

I am seeing a similar rate of leakage, 2.1GB after 7 hours. Relevant Valgrind output:

==00:07:07:21.961 8039== 2,271,992,832 bytes in 246,527 blocks are possibly lost in loss record 8,235 of 8,235
==00:07:07:21.961 8039== at 0x4C2B6CD: malloc (in /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
==00:07:07:21.961 8039== by 0x5FE1F44: gdk_pixbuf_new (in /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0.2502.0)
==00:07:07:21.961 8039== by 0x42EFC1: mobile_helper_get_status_pixbuf (mobile-helpers.c:45)
==00:07:07:21.961 8039== by 0x429E82: gsm_get_icon (applet-device-gsm.c:577)
==00:07:07:21.961 8039== by 0x41B9DC: applet_update_icon (applet.c:2836)
==00:07:07:21.961 8039== by 0x71C1DD9: g_main_context_dispatch (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3118.0)
==00:07:07:21.961 8039== by 0x71C219F: ??? (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3118.0)
==00:07:07:21.961 8039== by 0x71C2599: g_main_loop_run (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3118.0)
==00:07:07:21.961 8039== by 0x4143A6: main (main.c:106)

This was previously the case when using Wi-Fi, but version 0.9.2.0+git.20120126t000800.5151959-0ubuntu2 fixed that issue (described in bug 933711). Now with version 0.9.2.0+git.20120126t000800.5151959-0ubuntu4 the problem only occurs when mobile broadband is used.

Omer Akram (om26er) on 2012-02-28
Changed in network-manager-applet (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
milestone: none → ubuntu-12.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.3.995+git.20120313t141231.c89224f-0ubuntu2

---------------
network-manager-applet (0.9.3.995+git.20120313t141231.c89224f-0ubuntu2) precise; urgency=low

  * debian/patches/lp939802_fix_mobile_icon_leak.patch: avoid leaking memory
    due to badly keeping track of references to device icons. (LP: #939802)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 19 Mar 2012 20:11:38 -0400

Changed in network-manager-applet (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers