Ubuntu

NM Applet menu entries not responding

Reported by Thomas Bechtold on 2012-02-11
502
This bug affects 109 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Low
Unassigned

Bug Description

When i click on the NM applet, the menu appears correct but when i click eg on "disconnect" or "edit connection", nothing happens.
This is the behavior for all menu entries.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager-gnome 0.9.2.0+git.20120126t000800.5151959-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic-pae 3.2.5
Uname: Linux 3.2.0-15-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Feb 11 09:04:44 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
IpRoute:
 default via 192.168.178.1 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
 192.168.178.0/24 dev wlan0 proto kernel scope link src 192.168.178.20 metric 2
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager-applet
UpgradeStatus: Upgraded to precise on 2012-02-03 (8 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.0 connected enabled enabled enabled enabled disabled

Thomas Bechtold (toabctl) wrote :

I'm almost certain this is a side-effect of nm-applet running long enough and leaking enough memory to be in a bad state when you try to click these items.

Are you still able to reproduce the issue? I think this was likely be have been fixed in a recent upload of nm-applet; and if not is possibly an issue at a different level (libdbusmenu?)

Changed in network-manager-applet (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Kapil Thangavelu (hazmat) wrote :

for me this looks similiar to bug:933300 .. effectively nm-applet reports status correctly but won't process any inputs, hardware for me is x220, intel b/g/n via iwlwifi. running a second nm-applet responds to inputs, and the original still updates to show correct status.

Eloy Paris (peloy-chapus) wrote :

Agreed, this could be a duplicate of bug #933300 (or the other way around since this bug [bug #930563] is newer).

Hadrien Titeux (hadware) wrote :

Exactly same here, I filed another bug report, then marked it as duplicate of this one.
Weirdly enough, my hardware is very close to comment #3:
- x200 with Intel Corporation PRO/Wireless 5100 AGN on g/n wifi
- amd64 installation

Thomas (thomasl) wrote :

On my laptop, this appears to be a consequence of suspend/resume process.
No action is possible from within the applet after a resume (I've not noticed if it's since the first one, I'll check that point)
Result is :
- selection of an item is just not taken in account
- submenus are empty (WiFi networks, VPN connections for me)

But networking is OK (thanks to network-manager) and the applet icon is OK (i.e. the icon change from connecting to connected in notification area).

Regards

Thomas (thomasl) on 2012-07-30
Changed in network-manager-applet (Ubuntu):
status: Incomplete → Confirmed
Hadrien Titeux (hadware) wrote :

#6 Describes it very well, it's pretty accurate. I experience exactly the same problem with nm-applet.

As a temporary fix, i just kill it and restart with the following alias:

alias nmrestart='pkill nm-applet && nm-applet &'

Ben Gamari (bgamari) wrote :

I also have observed this problem. `dbus-monitor --session` shows the following when I click on a menu item,

    signal sender=:1.74 -> dest=com.canonical.Unity.Panel.Service serial=207627 path=/com/canonical/Unity/Panel/Service; interface=com.canonical.Unity.Panel.Service; member=EntryActivated
       string ""
       struct {
          int32 0
          int32 0
          uint32 0
          uint32 0
       }
    method call sender=:1.74 -> dest=:1.1485 serial=207628 path=/org/ayatana/NotificationItem/nm_applet/Menu; interface=com.canonical.dbusmenu; member=EventGroup
       array [
          struct {
             int32 43153
             string "clicked"
             variant int32 0
             uint32 636178867
          }
       ]
    error sender=:1.1485 -> dest=:1.74 error_name=org.gtk.GDBus.UnmappedGError.Quark._LIBDBUSMENU_2dGLIB.Code0 reply_serial=207628
       string "The IDs supplied '[43153]' do not refer to any menu items we have"

affects: network-manager-applet (Ubuntu) → libdbusmenu (Ubuntu)
Cedric (cedric-nannan) wrote :

I have this problem since i updated from ubuntu 11.04 to 12.04.
I use ubuntu 12.04 on my incar-pc with wireless connection set to automatic connection. As i drive around my pc is reconnecting on several networks ( home, work, clients, and other ( non-secured) available networks ).
When i have no wireless network in range i want to get my mobile 3G network activated but the nm applet does not respond.

At start up the nm responds but after losing connection ( out of range as i drive away) and reconnecting on another wireless network the nm menu can open but does not respond anymore. Every mouse click just closes the nm menu.
Restart ubuntu or restart nm service resolves the problem.

John (camelzip) wrote :

Full installation of 12.04 months ago. Same problem here, but different hardware from others.
- Atheros AR9285 wireless card
- Intel i5-M480 CPU

Receiving the D-Bus error:
error sender=:1.16 -> dest=:1.53 error_name=org.gtk.GDBus.UnmappedGError.Quark._LIBDBUSMENU_2dGLIB.Code0 reply_serial=365093
   string "The IDs supplied '[62313]' do not refer to any menu items we have"

I can confirm that the workaround mentioned above (pkill nm-applet && nm-applet &) works for me.

Thought I'd noticed the problem without suspend, but will confirm on next boot.

Ben Gamari (bgamari) wrote :

I still see this on 12.10.

I would strongly suggest that the importance of this bug be raised. This is a highly visible bug that renders network-manager largely unusable for those without the knowledge to restart nm-applet.

Agree with Ben. This, and a handful of other bugs that make internet connectivity in Ubuntu remember that of a Commodore 64.

Øyvind Stegard (oyvinst) wrote :

Confirming still a problem in 12.10. I always suspend my laptop and have long running sessions. Eventually the nm-applet menu will stop responding to clicks. Kill+restart required.

Henrik Holmboe (holmboe) wrote :

This is a metoo.

Also seeing the same error message on the DBUS as comment #8.

Henrik Holmboe (holmboe) wrote :

Err, forgot to mention that I am on 12.04 LTS x64, fully updated. And have had this problem for a long time now.

Janne Snabb (snabb) wrote :

Please increase the importance of this bug!

It is really embarrassing to go to a customer meeting, open my laptop and notice that I can not connect to a network because network-manager does not respond. I have to start by apologizing that I need to reboot my computer. It is a major PITA.

While I am rebooting, they ask me what OS do I run...

I seriously can not recommend Linux/Ubuntu to my customers when they see this episode every other time I have a meeting with them! It is just ridiculous.

I am using Xubuntu 12.10 x86_64 on Dell Inspiron 3420 laptop (which was sold with Ubuntu pre-installed, older version though). I had this problem with my old laptop on 12.04 as well.

joshyg6 (josheg) wrote :

Same here.. With xubuntu 12.04..

joshyg6 (josheg) wrote :

Seems to be something with nmbd.. Can't even kill it with "sudo killall -9 nmbd" ..

joshyg6 (josheg) wrote :

"message bus security policy blocked reply"... could this have something to do with why it can't be reached and won't respond to the system??

Thomas (thomasl) wrote :

Hi,
It seems that since some time after upgrade to 12.10 I'm not facing this problem anymore, even with dozen of suspend/resume cycles (in a time window of a week).
Regards

ScottMarlowe (scott-marlowe) wrote :

Here's the workaround for now: Alt-F2 and run:

pkill -9 nm-applet
nm-applet

Sucks but at least you won't have t reboot like a Windows ME user.

Sebastien Bacher (seb128) wrote :

the recents comments are from xubuntu users, is anyone having the problem with unity?

Benjamin Kraus (ben-benkraus) wrote :

I believe I'm still experiencing this problem, running standard Ubuntu 12.10. I'm pretty sure I've seen this since updating from 12.04 to 12.10, but I'm not 100% certain. I'll report back next time it happens. The problem I'm having is perfectly described (in the screenshot) by bug 1011073, which is likely a duplicate of this bug, and has several people reporting the problem on 12.10.

Eloy Paris (peloy-chapus) wrote :

Hi Sebastien,

Absolutely, I have been having this problem since I upgraded to 12.04 (now I am on 12.10) and I have always run Unity. It happens to me all the time. It's so bad that I stopped using the NM applet a long time ago. Now I just use nmcli, e.g. "nmcli con up id <wireless SSID>", every time I need to switch to a different wireless network.

Cheers,

Eloy Paris.-

@Sebastien: me too with Unity (Ubuntu 12.04 fully updated)

@snabb: I have this bash script in my home directory:
    killall nm-applet
    nm-applet </dev/null &>/dev/null &
    disown "%nm-applet"
I usually run it from a terminal, but you may create a keyboard shortcut for it.
So you could use at meetings without your customers noticing, and still recommend them Linux/Ubuntu (but that would be immoral). LOL

Steve Kroon (kroon) wrote :

I also get this on Unity - the nmrestart alias suggested by Hadrien solves the problem for me, usually.

Hadrien Titeux (hadware) wrote :

Apparently this problem only appears after an upgrade.It seems I never got this kind of problem with fresh installs, and people here appear to be in the same situation...

On 2013-01-08 23:21, Hadrien Titeux wrote:
> Apparently this problem only appears after an upgrade.It seems I never
> got this kind of problem with fresh installs, and people here appear to
> be in the same situation...

I have a fresh install of Ubuntu 12.10 and I have this problem.

Matthew Paul Thomas (mpt) wrote :

 😌 10:04:18@~> dbus-monitor --session | grep nm_applet
method call sender=:1.70 -> dest=:1.14 serial=2917953 path=/org/ayatana/NotificationItem/nm_applet/Menu; interface=com.canonical.dbusmenu; member=AboutToShowGroup
method call sender=:1.70 -> dest=:1.14 serial=2918012 path=/org/ayatana/NotificationItem/nm_applet/Menu; interface=com.canonical.dbusmenu; member=EventGroup

The first line is when the menu is opened. The second line is when I choose "Disconnect", which does nothing. This demonstrates that the bug is in nm-applet, not in libdbusmenu. (Thanks to Lars Uebernickel for telling me how to test this.)

affects: libdbusmenu (Ubuntu) → network-manager-applet (Ubuntu)
Neal McBurnett (nealmcb) wrote :

Based on the comments both here and in bug 780602 that this bug still exists in quantal 12.10 despite a fix for the memory leak problem, I marked this as no longer a "duplicate" of 780602.

Martin Spacek (mspacek) wrote :

@hadware, #27:

"Apparently this problem only appears after an upgrade.It seems I never got this kind of problem with fresh installs, and people here appear to be in the same situation..."

Not true. I have this bug, with the very same dbus-monitor reports as in #8, on my fresh Xubuntu 12.10 install on a Thinkpad W510. As others have mentioned, this seems to happen after one (or maybe several) suspend-resume cycles. In fact, I've had this bug for years, I think starting from a fresh install of Ubuntu 11.04. Sad really...

Moritz Winter (winter-moritz) wrote :

See also #780602 which has priority 'high' and a few more affected...

Zoubidoo (zoubidoo) wrote :

Bug over 14 months old. At least 83 people affected.

Can we please increase the bug priority accordingly?

Zoubidoo (zoubidoo) wrote :

Related to this bug #1117730 ?

PS It sucks that nm-applet which has been working fine for many years suddenly becomes unusable and it takes years to fix the bugs. Not cool.

DavidW617 (davidw617) wrote :

@Zoubidoo: If you look at bug #845660, you will see that it was filed even longer ago with a "fix released" that did nothing.

This bug is still present in the latest 13.04 beta that I am running.

Sergey Listopad (psychosensor) wrote :

My fresh 12.04 installen on ThinkPad T430 has this issue

Sergey Listopad (psychosensor) wrote :

I am not using Unity. gnome classic is used.

Zisu Andrei (matzipan) wrote :

Updated to Raring for about 2 months now. The bug only started manifesting these days. It should be raised in priority.

Øyvind Stegard (oyvinst) wrote :

Confirming that this is still an issue in 13.04. I usually just suspend/resume my laptop and rarely reboot.

Sergey Gipsy (sergey-gipsy) wrote :

I am affected by this bug both in Xubuntu 12.10 and 13.04.

Kyle Morgan (kyle-n-morgan) wrote :

I have observed this bug in Ubuntu 12.04 (Unity), Xubuntu 12.10, and Arch running GNOME 3.

apienk (andrzej-pienkowski) wrote :

The bug started manifesting just a few days ago. Ubuntu 12.04 amd64.

skierpage (skierpage) wrote :

(The importance of this is "Low"?!)

What's described in comment #6 happens all the time for me with 64-bit 13.04 on a MacBookAir 5.2. It definitely occurs after a suspend, possibly in other circumstances.

I'll attempt marking this a duplicate of bug 1011073 since the description is the more or less the same and because bug 1117730 has exactly the same "error_name=org.gtk.GDBus.UnmappedGError.Quark._LIBDBUSMENU_2dGLIB.Code0 reply_serial=207628" and is a dupe of that. I apologize if this is in error.

The good news is bug 1011073 has a fix proposed and in testing!

Ivan (ivan-zderadicka) wrote :

I'm still impacted on 13.04 - it seems to have some connection to suspend/resume.
Killing and restarting nm-applet hepls

Philippe Coval (rzr) wrote :

Since #1011073 is Released , let me comment over there ,

If it helps I just installed ubuntu-gnome-13.10-desktop-i386.iso (and tuned a bit the system so my test can not be reproducible 100%) ...

I observed that despite the wifi SSIDs are listed in nm-applet , if user click on one of them (open or not) the whole nm-applet windows disappear this means that it does respond to action but what I would expect is to have that settings window ...

I think I saw it once but now I cant see anything and restarting the applet does not help ... so may this be an other (new) bug ? but please can you check if you have a different behavior or not ?

I dont know where to search now , I have some suspicion on gnome-settings-deamon gnome-keyring or just dbus ... any tracks welcome...

I am also considering switching to connman to compare..

Philippe Coval (rzr) wrote :

If it helps others let me answer to myself

I had to reinstall all installed packages from a to m (stopped before the end) and it went working , so I guess this was a file chmod issue...

Before I had in my logs :

  " Failed to add and activate connection '32': Saving connection failed: (-1) (unknown)"

--
http://rzr.online.fr/q/connectivity

David Rajaratnam (daver-cse) wrote :

Just confirming that I am also been having this problem (Xubuntu 12.10 on X220 laptop) and, like others, wondering why it is still marked as low importance.

Martin Spacek (mspacek) wrote :

David, I would hazard it's marked as low importance because fixing it wouldn't be as sexy and controversial as, say, Ubuntu Edge, or Mir, or Unity. It would, however, be damned well useful.

Please use the "master bug" https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1011073 to comment, otherwise we may miss things.

As far as I know and can tell, the problem really is fixed in 12.04, 13.04, 13.10...

If you're still having the issue, make sure you apply all updates and re-test. If that still doesn't help, please file a new bug report, just for yourself, and comment with the link in bug 1011073 so I can take a look, because the probability of being the same issue is vanishingly small.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers