New Mobile Broadband Connection "select your provider from a list" disabled

Bug #894249 reported by yoursunny on 2011-11-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Low
network-manager-applet (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce:
1. right click on network-manager-applet, select Edit Connections
2. switch to Mobile Broadband tab, click Add
3. on "Set up a Mobile Broadband Connection" step, click Continue
4. on "Choose your Provider's Country or Region" step, select "my country is not listed" then click Continue
5. on "Choose your Provider" step, notice "Select your provider from a list" is disabled (as expected), click Go Back
6. on "Choose your Provider's Country or Region" step, select "United States" then click Continue

Expected result:
"Select your provider from a list" is enabled

Actual result:
"Select your provider from a list" is populated with some US providers, but is disabled
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 11.10
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 10.0.2.2 dev eth0 proto static
 10.0.2.0/24 dev eth0 proto kernel scope link src 10.0.2.15 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Keyfiles: Error: [Errno 2] No such file or directory
Package: network-manager 0.9.1.90-0ubuntu5.1
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
RfKill:

Tags: oneiric
Uname: Linux 3.0.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2011-11-23T22:39:25.166358

I can't reproduce this bug. Could you please add extra ifnormation to your bug report? It would be especially helpful if you could run 'apport-collect 894249' to add debug logs and package version information to this bug automatically.

Changed in network-manager (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

yoursunny (yoursunny) on 2012-01-19
Changed in network-manager (Ubuntu):
status: Incomplete → New

Confirming and setting to Triaged. This should be a fairly simple thing to fix in the wizard code in network-manager-gnome, so I'll also add the "bitesize" tag.

Changed in network-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
tags: added: bitesize
Vadim Rutkovsky (roignac) wrote :
Changed in network-manager-applet:
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager-applet:
importance: Unknown → Low
status: Unknown → New
Vadim Rutkovsky (roignac) wrote :

Fix commited upstream and will be available in next release

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Committed
Changed in network-manager-applet:
status: New → Fix Released

That's not what Fix Committed is for, so resetting this to Triaged. The fix is in a later upstream commit, which will either need to get included in a new snapshot of nm-applet or in a formal release.

Ideally I'd rather get a formal release from upstream, I think it's due very soon, too.

Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.3.995+git.20120313t141231.c89224f-0ubuntu1

---------------
network-manager-applet (0.9.3.995+git.20120313t141231.c89224f-0ubuntu1) precise; urgency=low

  * upstream snapshot 2012-03-13 14:12:31 (GMT)
    + c89224f42f7cee4fca7369a890011a67350d8ff6
    - Freeze Exception: (LP: #953123)
    - Adding EAP-FAST support in UI.
    - mobile-wizard: fix sensitizing providers' list (LP: #894249)
  * debian/patches/lp912150_lazy_notify_init.patch: dropped, applied upstream.
  * debian/patches/lp330571_dxteam_wired_connect_text.patch: refreshed.
  * debian/patches/lp330608_dxteam_gsm_connect_text.patch: refreshed.
  * debian/patches/nm-applet-use-indicator.patch: refreshed.
  * debian/patches/no_Werror.patch: dropped, applied upstream.
  * debian/rules: pass --enable-more-warnings=no to retain the same behavior as
    with the no_Werror.patch.
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 14 Mar 2012 16:03:22 -0400

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.