nm-applet is wrongly started with Gnome Shell

Bug #852961 reported by Dylan McCall on 2011-09-18
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Medium
gnome-shell (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

When I log in to Gnome Shell, nm-applet is wrongly autostarted as if I am running a session with Unity or gnome-panel. The application conflicts with Gnome Shell's own network notifications, resulting in a very broken experience.

Related branches

Sebastien Bacher (seb128) wrote :

that's an nm-applet autostart issue, it should start only in unity, what Ubuntu version do you use?

affects: gnome-session (Ubuntu) → network-manager-applet (Ubuntu)

I'm seeing this issue in Oneiric. Thanks for pointing it in the right
direction :)

Please make sure you have the latest version of Gnome Shell.

I can't reproduce this yet, and unbreaking this would need changes that would break other session types.

Changed in network-manager-applet (Ubuntu):
status: New → Incomplete
Jeremy Bicha (jbicha) wrote :

It took me a bit to figure out what you meant since I didn't see nm-applet but you're right: notifications do appear twice and the second time is in an uglier style. I'm going to add gnome-shell to this bug report also.

Changed in network-manager-applet (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed

It's probably really an issue with nm-applet, but to find out:

If you're seeing these notifications, are they both showing the exact same text? If so, it should be possible to track down what sends the notification that looks "wrong" with dbus-monitor --monitor .

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Incomplete
Dylan McCall (dylanmccall) wrote :

Yes, I have confirmed that the unwanted notifications come from nm-applet. Removing nm-applet from startup applications works around the problem, but it is not a good workaround because Unity and Gnome Classic's panel don't start nm-applet on their own; they're stuck with whatever is set in gnome-session-properties, because everyone uses the same gnome-session. (It's also problematic because gnome-session-properties has been tweaked so removing a startup application specified by the system is difficult).

Dylan McCall (dylanmccall) wrote :

So, I was reminded that gnome-session supports a really excellent AutostartCondition key now. All we need to do is use that with nm-applet's .desktop file. I'm submitting a patch that does just that. It should work for our purposes for this release :)

Changed in network-manager-applet (Ubuntu):
status: Incomplete → In Progress
Jeremy Bicha (jbicha) wrote :

Yes, the autostart line appears to do the right thing here: nm-applet runs in Unity or GNOME Fallback but not in GNOME Shell and it looks like GNOME Shell networking works fine without nm-applet running. Thank you!

I approved the changes, everything looks good; I'll merge this in shortly.

Jeremy Bicha (jbicha) on 2011-09-25
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.1.90-0ubuntu1

---------------
network-manager-applet (0.9.1.90-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Split wireless/mobile dialogs into a new libnm-gtk library.

  [ Dylan McCall ]
  * debian/patches/04-autostart.patch:
    - disable autostart when using gnome-shell (LP: #852961)

  [ Mathieu Trudel-Lapierre ]
  * debian/control: add libnm-gtk0 and libnm-gtk-dev binary packages.
  * debian/control: bump network-manager-dev, libnm-*-dev Build-Depends
    to (>= 0.9.1).
  * debian/control: add iso-codes to Build-Depends.
  * debian/network-manager-gnome.install,
    debian/libnm-gtk0.install,
    debian/libnm-gtk-dev.install: install files to the right packages now that
    we have multiple binary packages.
  * debian/patches/nm-applet-use-indicator.patch: refresh.
  * debian/control, debian/rules: add network-manager-gnome-dbg. (LP: #415394)
  * debian/patches/vpn-import-export-dir.patch: fix default path for importing
    or exporting VPN connections. (LP: #634913)
  * debian/patches/mobile-wizard.patch: clear up the mobile wizard intro page
    buttons and titles. (LP: #856785)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 23 Sep 2011 15:25:35 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager-applet:
status: New → Incomplete
Changed in network-manager-applet:
status: Incomplete → New
Anders Kaseorg (andersk) wrote :

I don’t think this fix is correct. Without nm-applet running, gnome-shell is incapable of connecting to a VPN on its own. See https://bugzilla.gnome.org/show_bug.cgi?id=658484 .

Jeremy Bicha (jbicha) wrote :

Anders, yes, bug 863120 is the Ubuntu bug to undo this.

Changed in network-manager-applet:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.