network indicator flickers when opened(leaks unity-panel-service)

Bug #823955 reported by Omer Akram on 2011-08-10
138
This bug affects 27 people
Affects Status Importance Assigned to Milestone
libappindicator
Invalid
Undecided
Unassigned
libappindicator (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

happens on two systems in Oneiric. When the network icon is clicked it blinks.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: network-manager-gnome 0.8.9997+git.20110726t113022.cc3d423-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Wed Aug 10 18:56:53 2011
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110806)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.5
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed on Oneiric.

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Omer Akram (om26er) wrote :

Assigned Mathieu so the bug is on his radar, please feel free to remove assignee

Changed in network-manager-applet (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Omer Akram (om26er) wrote :

Opening and closing network indicator also causes a memory leak in unity-panel-service this does not happen with any other indicator, I believe this flicker is somehow related to the leak.

summary: - network indicator flickers when opened
+ network indicator flickers when opened(leaks unity-panel-service)
Changed in network-manager-applet (Ubuntu):
importance: Low → Medium
milestone: none → ubuntu-11.10-beta-2
Dave Walker (davewalker) on 2011-09-23
Changed in network-manager-applet (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
pablomme (pablomme) wrote :

Temporarily no flicker due to bug #862895 emptying most of the NM indicator menu..

Still flickering on my netbook. Moreover, the first time I open it, it overlaps with the edge of the screen. I'll attach a screenshot.

Manu Varkey (manuvarkey-gmail) wrote :

Firefox history menu is also showing similar flicker

Manu Varkey (manuvarkey-gmail) wrote :

Firefox Bookmark menu also. To reproduce add a new bookmark ( Bookmark->Bookmark this page). Next time when the menu is accessed it flickers. Flicker is not seen when menu is accessed after the first time.

Bilal Shahid (s9iper1) wrote :

still ths issue is present with latest updated oneiric.i think as written in should fixed in beta 2.but still it is present.

So, I guess the problem concerns all unity panel indicators

Matthew Woerly (nattgew) wrote :

I have Last.fm, Dropbox, indicator-sysmonitor, my-weather-indicator, keyboard layout, messaging, battery, Bluetooth, sound, time, user switch, and power menus in my panel, and NM is the only one that has this issue.
I haven't tested the Firefox one, but I would guess that it and NM are doing something different to cause this.

From playing around with it, I've noticed that sometimes it doesn't flicker the first time, but clicking it again causes the flicker. I can't find any pattern.

Bilal Shahid (s9iper1) wrote :

yes matthew woerly i have also seen this issue that
 sometimes it doesn't flicker the first time, but clicking it again causes the flicker.

Jacques (jacques-eavr) wrote :

Same bug on my OO 64 bits EEEPC 1015PX with the latest updates.

I have Dropbox installed.

Reading the comments, I'm not 100% sure what people mean by "flickering". On my system, when I click on the network icon, the menu is shown quickly, then it disappears and immediately after it reappears. The whole process duration is less than 1s.

Same behavior on Unity 3D and Unity 2D. Same phenomenon when clicking on the Skype icon. I looked for a similitude in the menu items but found none.

Best,
Jacques

Jacques (jacques-eavr) wrote :

From comment #8, could it be inferred that this bug is triggered when a menu has variable items in it ? Indeed, adding a bookmark modifies the content of Firefox's bookmark menu. The network menu is constantly modified when new access points are discovered by the WiFi driver. The Skype menu is updated when the status changes. Maybe a hint ?

Manu Varkey (manuvarkey-gmail) wrote :

Seems so Jacques. May be a bug report should be filed against libappindicator.

Omer Akram (om26er) wrote :

From my memory I believe both Ted and Mathieu are quite aware of the problem but were not able to find a good/easy solution last cycle. Hope its fixed in the LTS.

Changed in network-manager-applet (Ubuntu):
milestone: ubuntu-11.10 → none

Correct, this is going to be fixed for Precise. I have a solution in mind, just haven't quite finished fixing up the code yet.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libappindicator (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.2.0+git.20120126t000800.5151959-0ubuntu1

---------------
network-manager-applet (0.9.2.0+git.20120126t000800.5151959-0ubuntu1) precise; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * upstream snapshot 2012-01-26 00:08:00 (GMT)
    + 515195990c5b36171d30cdd9e62c76f117f25c7e
  * debian/rules, debian/control: use dh-translations to make sure we get an
    updated translation template. Thanks to Gabor Kelemen for the patch.
    (LP: #879017)
  * debian/patches/vpn-import-export-dir.patch: dropped, applied upstream.
  * debian/patches/lp337960_dxteam_notification_icon_names.diff: refreshed.
  * debian/patches/lp912150_lazy_notify_init.patch: refreshed.
  * debian/patches/no_Werror.patch: drop changes to configure, which aren't
    needed since we use autoreconf.
  * debian/patches/nm-applet-use-indicator.patch: rework to avoid "flashing"
    every time the menu is opened. We're back to updating when AP, devices,
    etc. change and when new VPN connections are added, which should cover
    most cases. (LP: #823955)

  [ Luke Yelavich ]
  * Present wireless network strength and security status for wireless networks
    to screen reader users.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 06 Feb 2012 12:08:33 -0500

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Ted Gould (ted) wrote :

Marking as Invalid for libappindicator as it was fixed in nm-applet

Changed in libappindicator:
status: New → Invalid
Changed in libappindicator (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers