Animation displayed when connecting to a VPN is confusing

Bug #746674 reported by Marcel Stimberg on 2011-03-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Low
Unassigned
ubuntu-mono (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

In Maverick: The animation when you started connecting to a VPN consisted of a steady wireless connection symbol in the background and a blinking padlock on top. Now, in Natty, the animation consists of five stages of the "wireless search" animation followed by a padlock without any wireless symbol in the background.
This is visually very unpleasant and gives the impression of a broken network connection.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: network-manager-gnome 0.8.4~git.20110318t152954.9c4c9a0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
CheckboxSubmission: 476acdb7217a83354f628beaa5c14f06
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Thu Mar 31 21:42:59 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100114)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager-applet
UpgradeStatus: Upgraded to natty on 2011-03-27 (3 days ago)

Related branches

Confirming. That was actually working well for a short while. but a further upload of ubuntu-mono seem to have borked it (unless it was some other change). Assigning to myself to look back into the issue.

Changed in network-manager-applet (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

I can somewhat change this by carefully modifying the icons used in ubuntu-mono -- I think there are some extra icons under status/*/ for nm-vpn-connecting icons; which should instead be under animations (especially nm-vpn-connecting-14.svg). I also don't think it needs to display the padlock at all, just "processing" e.g. the moving waves and showing the padlock once the connection is actually open should be sufficient.

Changed in network-manager-applet (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Changed in ubuntu-mono (Ubuntu):
status: New → Triaged
importance: Undecided → High

Not a bug in nm-applet, the overall logic for it hasn't changed; I can definitely see that there are padlocks missing from the icons we use, so I'd fix that directly in ubuntu-mono or whatever theme is used.

Changed in network-manager-applet (Ubuntu):
status: Triaged → Invalid
Changed in ubuntu-mono (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.30

---------------
ubuntu-mono (0.0.30) natty; urgency=low

  * Drop extra nm-vpn-connecting* animation icons from status/ directories,
    they don't belong in there anyway.
  * Reinstate vpn padlock composited in VPN connecting animation. (LP: #746674)
  * Resize/rescale nm-applet's 16px signal level icons. (LP: #767186)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 21 Apr 2011 11:14:39 -0400

Changed in ubuntu-mono (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers