Ubuntu

No signal strength icons in list of available wireless connections

Reported by Luke on 2010-12-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libdbusmenu (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Low
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: network-manager

In network-manager-gnome_0.8.2+git.20101123t161608.f143e76-0ubuntu1, there are no icons for signal strength in the list of available wifi connections. The connections themselves are listed, and can be connected or disconnected as before, but there are no indications of the strength of the signal-a real nuisance for selecting open access points when names are cryptic and many are available in an urban environment.

The panel icon displays OK in gnome-shell and also in unity-compiz, and will show the strength of the signal that has been connected to, or icons for disconnection or a wired connection. It won't always show up until the network has been scanned, though, and disappears if you switch from gnome-shell to unity-compiz and then back to gnome-shell.

I'm not certain yet why it disappears and won't get embedded back into the systray or indicator list as you switch back and forth, but the fact that there is no signal strength is a known issue with the indicator patch to nm-applet.

I'm adding a bug task to libdbusmenu, which is what we use through libappindicator, in hope we can get better tracking on when the required features to display icons in the menus like we do will work (requires supporting GtkImageMenuItem's or some workaround, I guess).

tags: added: nm-indicator
Changed in network-manager (Ubuntu):
status: New → Confirmed
affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
importance: Undecided → Low

Due to how I use wireless, I am going to have to use either the old version of network-manager-gnome it works fine in gnome-shell or the old panel), or another app altogether for wireless mangement. I will test each subsequent version though, rolling back if it doesn't work. This is something that has to be fixed by the final release, though it is an acceptable hassle in an alpha. Without signal strength indication, some forms of urban wireless use become quite impractical.

> Date: Thu, 2 Dec 2010 13:43:15 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 683896] Re: No signal strength icons in list of available wireless connections
>
> I'm not certain yet why it disappears and won't get embedded back into
> the systray or indicator list as you switch back and forth, but the fact
> that there is no signal strength is a known issue with the indicator
> patch to nm-applet.
>
> I'm adding a bug task to libdbusmenu, which is what we use through
> libappindicator, in hope we can get better tracking on when the required
> features to display icons in the menus like we do will work (requires
> supporting GtkImageMenuItem's or some workaround, I guess).
>
> ** Tags added: nm-indicator
>
> ** Also affects: libdbusmenu (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: network-manager (Ubuntu)
> Status: New => Confirmed
>
> ** Package changed: network-manager (Ubuntu) => network-manager-applet
> (Ubuntu)
>
> ** Changed in: network-manager-applet (Ubuntu)
> Importance: Undecided => Low
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/683896
>
> Title:
> No signal strength icons in list of available wireless connections

tags: added: natty regression-release

Turns out it's fixable directly in nm-applet by doing this the Right Way. Marking the dbusmenu task invalid.

Marking as in progress since I already have code ready that turns the icons back on: http://twitpic.com/3n0a95.

Changed in libdbusmenu (Ubuntu):
status: New → Invalid
Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.8.3+git.20101209t081952.0330eca-0ubuntu3

---------------
network-manager-applet (0.8.3+git.20101209t081952.0330eca-0ubuntu3) natty; urgency=low

  * Re-instate animations while processing network association phases, it tends
    to be annoying and confusing without them. (LP: #694534)
  * Provide and use premade theme icons for wireless strength *with security*,
    which include the padlock already composited.
    - Enable icons in menus for wireless strength and security. (LP: #683896)
    - Re-use the same icons to notify the user that they are connected to a
      VPN-secured connection. (LP: #696442)
  * Clean up code paths for GSM and CDMA devices which still tried to create
    a custom widget to add to the menu -- replaced it with a simple image
    menu item.
  * Escape underscores in SSID names so they display with the correct name
    rather than underlining the next character (as a mnemonic).
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 07 Jan 2011 12:52:06 -0500

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
Anders Kaseorg (anders-kaseorg) wrote :

The new secure icons don’t work for any icon theme other than ubuntu-mono-dark and ubuntu-mono-light.

Shouldn’t the network-manager-gnome package provide /usr/share/icons/hicolor/*/apps/nm-signal-*-secure.png, like it currently provides /usr/share/icons/hicolor/*/apps/nm-signal-*.png?

Anders Kaseorg (anders-kaseorg) wrote :

By the way, the new escape_mnemonics function has a memory leak:
    clean_ssid = g_strdup_printf ("%s__%s", clean_ssid, ssid_part);
The old value of clean_ssid is never freed.

(Perhaps you were looking for g_strjoinv?)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers