network manager key-entry dialog appears below all windows (minimised)

Bug #67239 reported by zdzichu
16
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

When Network Manager need a key to connect to wireless networks, it displays dialog asking for it.
From unknown reason this dialog is displayed below all other windows.
I think that this dialog should be displayed on foreground (above all other windows) AND should NOT get focus by default.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the application is probably not using the right timestamp, reassigning

Revision history for this message
robrichard (robrichard87) wrote :

I experience this too, in both edgy and upgraded feisty and a clean install of feisty. When the window appears below the other windows it is not immediately apparent that the network key is required and users may think nm is attempting to connect to a network unsuccessfully.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

confirming this. the strange thing is that the window flashes in the taskbar, but is not in foreground!

Changed in network-manager:
status: Unconfirmed → Confirmed
Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

Confirmed in Gutsy Tribe 5.

Changed in network-manager:
importance: Undecided → Low
Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote : Re: [Bug 67239] Re: network manager key-entry dialog appears below all windows (minimised)

In Gutsy, it can be quite difficult to get the window to stop being minimised.

When I start up, I have nothing else open and the prompt appears and
then minimises. Is this the same bug?

Clicking on it does not bring it back up and I often have to
right-click and deselect "always on top" before I can get it to
display.

Revision history for this message
Alexander Sack (asac) wrote :

does this still happen to you in intrepid? If so, the fix should be quite simple. so please let me know.

Changed in network-manager:
assignee: nobody → asac
status: Confirmed → Incomplete
Revision history for this message
robrichard (robrichard87) wrote :

Honestly I can't remember the last time a saw this happen. I'm not running
Intrepid, but I haven't seen it happen in Hardy.

On Wed, Sep 10, 2008 at 8:37 PM, Alexander Sack <email address hidden> wrote:

> does this still happen to you in intrepid? If so, the fix should be
> quite simple. so please let me know.
>
> ** Changed in: network-manager (Ubuntu)
> Assignee: (unassigned) => Alexander Sack (asac)
> Status: Confirmed => Incomplete
>
> ** Changed in: network-manager-applet (Ubuntu)
> Sourcepackagename: network-manager => network-manager-applet
>
> --
> network manager key-entry dialog appears below all windows (minimised)
> https://bugs.launchpad.net/bugs/67239
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac)
Changed in network-manager-applet:
status: Incomplete → Fix Released
assignee: asac → nobody
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.