Maverick: Wireless is disabled until network-manager restart

Bug #637930 reported by harvest316 on 2010-09-14
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: network-manager

Since upgrading to Maverick, when I boot up and right click on my network-manager icon in the notification area, there is no "Enable Wireless" option, as if it cannot detect the presence of my wireless card. This is resolved by issuing the command:

 sudo service network-manager restart

But of course it needs a more permanent fix.

$ apt-cache policy network-manager
network-manager:
  Installed: 0.8.1+git.20100810t184654.ab580f4-0ubuntu2
  Candidate: 0.8.1+git.20100810t184654.ab580f4-0ubuntu2
  Version table:
 *** 0.8.1+git.20100810t184654.ab580f4-0ubuntu2 0
        500 http://au.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
     0.8.1+git.20100810t184654.ab580f4-0ubuntu2~nmt2 0
        500 http://ppa.launchpad.net/network-manager/trunk/ubuntu/ maverick/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: network-manager 0.8.1+git.20100810t184654.ab580f4-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Tue Sep 14 17:54:01 2010
EcryptfsInUse: Yes
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
IpRoute:
 192.168.0.0/24 dev eth2 proto kernel scope link src 192.168.0.102 metric 1
 169.254.0.0/16 dev eth2 scope link metric 1000
 default via 192.168.0.1 dev eth2 proto static
Keyfiles: Error: [Errno 2] No such file or directory
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager

harvest316 (harvest316) wrote :

Hi!

In your bug report, there appears to be the result of start NM missing, up to when it gets restarted and detects your eth1 device.

In order to add the information, could you:

1) reboot, let NM start
2) restart NetworkManager
3) attach the full contents of /var/log/syslog to this bug.

Ideally we should then see the first NM startup logs, along with the logs from the second start, and how it detects the device.

Thanks in advance!

Changed in network-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
harvest316 (harvest316) wrote :

I've attached the syslog as requested, but bizarrely, the
network-manager restart doesnt fix it now, like it did before. I cant
remember but I might have run update-manager last night so that could
have changed things. Nothing in synaptic's history though. (Does
update-manager keep a different history file?)

But the problem is different than I originally understood. It's
actually just the "Enable Wireless" option on the right-click menu
that's disabled. The wireless still works just fine.

When I use dbus-send to turn it on and off by hand I can see wireless
networks on the left-click menu of the network-manager icon when its on,
and of course none when it's off, but the "Enable Wireless" option is
still greyed out on the right-click menu:

dbus-send --system --type=method_call
--dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager
org.freedesktop.DBus.Properties.Set
string:org.freedesktop.NetworkManager string:WirelessEnabled
variant:boolean:false

What more can I provide you with?

PaulH

harvest316 (harvest316) wrote :

Thanks Paul, I think you've given all the relevant information (and I was able to reproduce the issue).

Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
Changed in network-manager (Ubuntu Maverick):
importance: Low → High
assignee: nobody → Mathieu Trudel (mathieu-tl)

Paul,

Please attach the contents of your file /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy. I suspect it may be installed wrong or not at all, which could explain why the items are disabled in the menu.

Changed in network-manager (Ubuntu Maverick):
status: Triaged → Incomplete

I can reproduce this both on a full upgrade with NetworkManager in Networking disabled state, and by upgrading just NM and nm-applet to the maverick versions on a fresh Lucid install. Just editing the polkit policy file is enough for NM to wake up and enable the menu entry, so I suspect there is a trick that can be done to let policykit or NetworkManager know that there has been changes to policy files during the install, and that the issue comes from the order in which NM and policykit are being upgraded.

Looks like the bug is really in the applet (or the libnm parts called by it). Just touching /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy after starting nm-applet is enough to enable the menu items. As soon as nm-applet is killed the file needs to be touched again for the authorization to pass.

harvest316 (harvest316) wrote :

Ok so it appears this is really an issue in nm-applet, already fixed in an upstream git commit:

http://git.gnome.org/browse/network-manager-applet/patch/?id=c7b531250e7417cf51d088c21f91e4a6ef410ac3

affects: network-manager (Ubuntu Maverick) → network-manager-applet (Ubuntu Maverick)
Changed in network-manager-applet (Ubuntu Maverick):
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.8.1+git.20100809t190028.290dc70-0ubuntu3

---------------
network-manager-applet (0.8.1+git.20100809t190028.290dc70-0ubuntu3) maverick; urgency=low

  * Cherry-pick upstream commit c7b5312 to fix greyed-out Enable Networking items in
    context menu (LP: #637930)
    - added debian/patches/lp637930_fix_race_in_permissions-changed.patch
    - modified debian/patches/series
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 16 Sep 2010 10:23:15 -0400

Changed in network-manager-applet (Ubuntu Maverick):
status: In Progress → Fix Released
Changed in network-manager-applet (Ubuntu Maverick):
assignee: Mathieu Trudel (mathieu-tl) → nobody
Jacky Alciné (jackyalcine) wrote :

Fantastic; can this patch be reported to the head developers of NetworkManager so that they can release this new, repaired code immediately?

Jacky Alciné (jackyalcine) wrote :

Also, I'm experienced with programming.
But NOT with patching; how would I go about using the two patches shown above?

This patch is specific to the packaging of NM. The fix itself is coming from
upstream already.

To use this, you would need to get the packaging code (apt-get source) and
apply this patch on top and rebuild the package. To make things simpler you
may wish to use the experimental packages from the network-manager team PPA.

To post a comment you must log in.