Ubuntu

nm-applet does not show in indicator applet after reboot

Reported by samoanbiscuit on 2010-05-09
This bug report is a duplicate of:  Bug #589362: NM-applet doesn't start. Edit Remove
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

I've just installed Ubuntu 10.04, and I use a pppoe connection over a wireless LAN, after setting the pppoe up using pppoeconf, when I reboot the machine, the nm-applet cannot be seen in the indicator applet. Also when using ifconfig, wlan0 and eth0 are not listed, only l0.
This is the fourth time I'm reinstalling 10.04, because I lack the skills to change the settings using the command line. When I used the "sudo lshw -C network" command, it said that the wlan0 and eth0 interfaces are DISABLED, what that means, I wish I knew. The problem is I can't report very well when the bug shows itself, because I dont have an internet connection to read up on it. It's enabled in windows however (the wireless)... I use a HP 6710b laptop with a an intel wireless chip here is the output from the command "sudo lshw -C network" when the nm-applet is visible

  *-network
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:10:00.0
       logical name: wlan0
       version: 02
       serial: 00:1f:3c:99:78:c2
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 ip=10.10.1.69 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:30 memory:e4100000-e4100fff
  *-network
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:18:00.0
       logical name: eth0
       version: 02
       serial: 00:1f:29:96:b1:1f
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.102 firmware=sb v2.09 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:31 memory:e4000000-e400ffff

Also, FWIW, I've never had this problem with previous versions of Ubuntu, and I guess, nm-applet. Please help, this is a showstopper for me...

Enrico Sardi (enricoss) wrote :

Hi,

Try this:

sudo gedit /etc/network/interfaces

then check that the file has only this 2 lines:

auto lo
iface lo inet loopback

Delete all the others then reboot...

samoanbiscuit (samoanbiscuit) wrote :

Hi I'm going to do that tonight, got this assignment due, but yes I'll use a pppoe connection,
then reboot, then delete everything in /etc/network/interfaces except for the two you mentioned...
Also, the nm-applet doesn't always reflect things well, like the little bar that tells you how long ago you last connected, this thing is often wildly innacurate, just saying..

Kay (noiq) wrote :

Thanks Enrico, your suggestion solved the problem for me.

I use pppoeconf to connect to my ADSL connection using the ethernet port. And I lost my panel applet after I configured my ADSL connection (this is also the case with other people on the forum thread I linked below). Before that, on a clean lucid install, the applet was appearing normally and I could connect to my University's wireless networks.
Here's what I get when I type "nm-applet" in the terminal:
** (nm-applet:2271): WARNING **: <WARN> constructor(): Couldn't initialize the D-Bus manager.

This forum post gives a method for restoring the nm-applet:
http://ubuntuforums.org/showpost.php?p=9236722&postcount=16
This can be used as a workaround until they get it fixed. This method is explained in the file
/usr/share/doc/network-manager/README.Debian. Read that to get an idea of what is actually being done there. This is just an alternate approach to the one as described by miked1981 in this bug report: https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/456468 (https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/456468/comments/12). This method somewhat like the one complementary of the one given above by Enrico Sardi.

And this is what my .xsession-errors has to say:
** (nm-applet:1832): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:1832): DEBUG: old state indicates that this was not a disconnect 0

And I got the above outputs when I was not using the workaround described in the thread.

There's a similar bug over here: https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/589362

kanub (gwd0fqy02) wrote :

i'm having the same issue: no indicator applet for network

when i start System -> Preferences -> Network Connections i don't see any connections even though i'm connected. i did the steps mentioned in: http://ubuntuforums.org/showthread.php?t=1469625&highlight=network+connections+network+manager&page=4

 "in the terminal type "sudo edit /etc/NetworkManager/nm-system-settings.conf" change the "managed=false" to "managed=true" and then save it."

i then get a "wired connection" in "Network Connections" called "ifupdown (eth0)" which i can't edit

kanub (gwd0fqy02) wrote :

when i do Enrico Sardi steps then "ifupdown (eth0)" is called "Auto eth0", i can edit it and have to set the addresses again (of course). the connections are also listed as "Used: never"(?).
still no indicator applet.

Peter B P (peterbp) wrote :

nm-indicator-applet disappeared from my notification area some time back. I don't know exactly when, but I do remember it was initially present when I started using 10.04.

Attempt to solve by editing "/etc/NetworkManager/nm-system-settings.conf" as discussed on forum has not worked for me.

Note that this coincides with other indicator panel icons missing, fx. Parcellite, Gnome Do...

bol1 (mb2215) wrote :

I'm also getting problems of this sort after clean installs of lucid. Two separate machines.

1. Compaq Presario notebook.
Part of nm applet blacked out in upper panel (vertical missing strip over applet). Eventually resolved itself (posibly due to updates? However, a dotted line surrounds the edge of the applet on after boot up. Also same dotted box around Windows List applet in lower panel. Both dissapear after launching nm or lgging on to WiFi.

2 Acer Aspire One mini notebook.
Several fresh installs, all works fine except nm applet disappears from notification area after shutdown. Upon boot up is not present and I reinstall it to get access. Remains but gone when rebooted. Also the Battery icon keeps disapperring from notification area as well. Also similar dotted lines around edge as described above.

I'll be happy to provide more specific information if you tell me what to run/post

Mike

Peter B P:
Did you try the solution given by Enrico Sardi in the first comment to this report (https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/577678/comments/1). Are you also using an ADSL/DSL connection configured with pppoeconf? This bug is specific to the using the said connections.

bol1:
Are you also using an ADSL/DSL connection configured with pppoeconf? This bug is specific to the using the said connections. I also get the dotted lines around the applets and I guess they are normal and don't cause any problems.

papukaija (papukaija) wrote :

This bug is affecting 9 people and is still marked as new?!

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
papukaija (papukaija) wrote :

This bug is a dupplicate of bug 589362 (yes, that bug is newer than thig bug but that bug is reported with apport eg with extra technical information).

tags: added: lucid
PMOverfield (peter-overfield) wrote :

Got this problem when building RAID array on 10.04.1....
No problem when creating and configuring the array with Live CD for AMD64: nm-applet present and correct, fully functioning.
To install Linux have to switch to ALTERNATE CD, in which I entered fixed-IP (I prefer not to use DHCP) via the CD's text-based interface. When all finished and finally booted, no nm-applet in Notification Area. Likewise" System > Preferences > Network Connections" reported that there was no known configuration for eth0. ifconfig, however, reported eth0 fully configured (with the values entered via the Alternate CD), and Firefox could access anything I wanted.
Removing and re-installing nm-applet didn't fix it, neither did removing and re-installing network-manager-gnome. Removing and re-installing the Notification Area and/or the Indicator Applet made no difference either. The final solution was quite simple, thus:
Edit /etc/network/interfaces to remove all but the lo configuration (as recommended by Enrico Sardi, above) then reboot. Nm-applet now re-appears in Notification are, and" System > preferences > Network Connections" now recognises and reports an eth0 configuration that has never been used. Configure eth0 via either nm-applet or "Sys > Pref > Net Conn" and all is well.
Conclusion: the IP-configuration mechanism on the Alternate CD interferes with (and possibly corrupts) the operation of network-manager-gnome, or similar. Perhaps the developers might like to investigate?

jahmbahwahnn (jahmbahwahnn) wrote :

This is a note of thanks for the solution by :

"Enrico Sadi wrote on 2010-06-04: #1

Hi,

Try this:
sudo gedit /etc/network/interfaces
then check that the file has only this 2 lines:
auto lo
iface lo inet loopback
Delete all the others then reboot..."
I faced the problem of the indicator applet disappearing from the area. I had ubuntu 10.04 with auto eth0 using WA3002G4 modem and subsequently added dsl connection for UT300R2U modem and was connecting it manually when I go to office. Subsequently I had tried configuring it to StartAX MT800 modem and did what all it was possible to go wrong. then the problem of disappearance of the applet happened. now after the above solution by Enrico Sadi and further after deleting all the other connections which I added I could get to connect to the internet with auto eth0. Thanks to you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers