stops during karmic->lucid upgrade, shows error message

Bug #518760 reported by Michael Vogt on 2010-02-08
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Michael Vogt
Lucid
High
Michael Vogt

Bug Description

Binary package hint: network-manager

During a test gui upgrade from karmic to lucid network-manager-applet shows a
error dialog "Missing resources" and claims that it can not continue. It looks like
network-manager stops during the upgrade (and takes the network down).

Michael Vogt (mvo) on 2010-02-08
Changed in network-manager (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
Alexander Sack (asac) wrote :

this is again a icon name change most likely :/

affects: network-manager (Ubuntu Lucid) → network-manager-applet (Ubuntu Lucid)
Changed in network-manager-applet (Ubuntu Lucid):
status: New → Confirmed
Michael Vogt (mvo) on 2010-02-09
Changed in network-manager-applet (Ubuntu Lucid):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.8-0ubuntu1

---------------
network-manager-applet (0.8-0ubuntu1) lucid; urgency=low

  [ Tony Espy <email address hidden> ]
  * drop string change revert_* patches, as full SRU for Karmic
    was rejected.
    - remove debian/patches/revert_more_networks.patch
    - remove debian/patches/revert_disable_notifications.patch
    - remove debian/patches/revert_country_not_listed.patch
    - remove debian/patches/revert_cleartext_priv_keys.patch
    - remove debian/patches/revert_enable_broadband.patch
    - update debian/series

  [ Mathieu Trudel <email address hidden> ]
  * upstream release 0.8
    - core: add --help to explain what nm-applet is/does (rh #494641)
    - core: clearer failure message when an applet is already running
    - wired: don't crash when getting 802.1x settings from the user (rh #556763)
    - info: don't crash on various D-Bus property errors (rh #557007)
    - core: fix clearing secrets when updating connections
    - build: link nm-connection-editor with libm for ceil() (rh #541353)
    - gsm: fix secret requests when connection has multiple secrets
  * bump build-depends to >= 0.8 to build with 0.8 final.
    - update debian/control

  [ Michael Vogt <email address hidden> ]
  * debian/rules, debian/icons/22/nm-active-device.png.uue:
    - install icon so that on upgrade the old applet can
      still find it and not error out (LP: #518760)

  [ Sebastien Bacher <email address hidden> ]
  * lazily load icons for using less cpu on login
    - add debian/patches/bgo609134_lazy_icons.patch
    - update debian/patches/series
 -- Mathieu Trudel <email address hidden> Fri, 19 Feb 2010 08:34:28 -0500

Changed in network-manager-applet (Ubuntu Lucid):
status: In Progress → Fix Released
Colin Keenan (colinkeenan) wrote :

This happened to me just now, Thursday May 6, 2010, and this is not the test release. I'm using wubi.exe. After today's recommended upgrades to packages I had on Ubuntu 9.10, I noticed there was a link to upgrade to Ubuntu 10.04, so I clicked on it. Came back much later to see the error message described in this bug report. It looks like the fix either didn't work or wasn't applied to the wubi.exe upgrade from 9.10 to 10.04.

Leandro (leandromartinez98) wrote :

I haad this problem today (may 8), but the upgrade proceeded smoothly. Not a big issue for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers