Ubuntu

The nm-applet icon is missing or the sound icon is duplicated and the second one is dead

Reported by miguelangeldavila on 2009-11-14
220
This bug affects 47 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

After the last system update, the nm-applet icon is replaced by a dead sound icon or sometimes is missing. This is solved removing and reenabling the notification area applet, but at the new boot the behaviour persists.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No existe el fichero ó directorio
CheckboxSubmission: 2c4bcecb9a89b6634dd4b667294c54bb
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Sat Nov 14 09:26:44 2009
DistroRelease: Ubuntu 9.10
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
IpRoute:
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.11 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 192.168.0.1 dev eth0 proto static
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
NonfreeKernelModules: nvidia
Package: network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1
PciNetwork:

ProcEnviron:
 PATH=(custom, user)
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RfKill:

SourcePackage: network-manager-applet
Uname: Linux 2.6.31-14-generic x86_64

tonyhawz (tonyhawz) wrote :

The same is happening to me
the nm-applet icon appeared after I ran nm-applet --sm-disable

~$ nm-applet --sm-disable

** (nm-applet:2699): WARNING **: <WARN> request_name(): Could not acquire the session service as it is already taken. Return: 3

** (nm-applet:2699): WARNING **: <WARN> constructor(): Couldn't initialize the D-Bus manager.

~$

let me know if I can provide any log that may help you

Happens on lucid, too.
I just booted the fresh daily live lucid iso 20091216 with grub2 loopback.
I had a second sound icon which was dead and the nm-applet was missing.

On a second boot the icons where o.k. (I could still not connect, see bug 496093)
(for sake of completeness: on second boot I used clocksource=jiffies to try out something unrelated. I doubt that was what made the difference)

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
tags: added: lucid
Henning Moll (drscott) wrote :

This one hits me today for the first time. I attach a screenshot.

Jase (jase-king) wrote :

I had the same thing, fixed it by getting rid of the fast user switcher applet (the Ubuntu one that has the IM status as an icon) and using the default gnome user applet (the one that has you're .face file as the icon).

Matt T (matt-fender) wrote :

Having the same problem my end on Karmic, can only use the temporary solution (remove notification area and re-add) struggling to reproduce the problem, tried just about everything, new ISO and fresh install, still losing my net icon after each reboot and gaining an extra sound icon.

markb (mark-blakeney) wrote :

I get the same bug. Very occasionally the nm-applet icon will appear after boot but it usually doesn't. Will reappear if I kill and restart it. As above, I also often get 2 sound icons. Seems timing related as I have a fairly fast PC. Never happens on my slower laptop which is otherwise nearly identically configured with Karmic.

markb (mark-blakeney) wrote :

I eliminated this problem as Jase says above in comment #6.

I was using the gnome "Shut Down" applet beside my notification area. I swapped this to the "Indicator Applet Session" and I have not seen the problem since. Those 2 applets give similar functionality.

Note maintainers, as I said above in comment #8. I was using exactly the same applets on my slower laptop but never saw the problem there. So I contend this is a timing/speed related problem.

Peter M. Clausen (pclausen) wrote :

I had the same problem installing Lucid on an older latop, dell lattitude D505. The strange thing was that I succesedded getting I-net (wireless, WPA2) this first boot after fresh installation. Then ubuntu crashed as I tried waking it up from "sleep" and after this I did not have any applet, and I was not able to connect to the internet !

I will try the solutions above, but I was quite amazed that I could not get the I-net running again. I tried killing NetworkManager itself, but that did not do the trick.

This bug will be quite problematic for "non-techies" !

Peter M. Clausen (pclausen) wrote :

Well, it seems that it was the "Notification Area" which has disappeared (probably during a bad crash on wake from sleep).

Solution for me: Add to Panel... --> "Notification Area"

berk (berkulsoy) wrote :

Hi,
It certainly happens on Lucid sporadically. This morning I lost my network manager applet too. The difference is, none of the proposed methods work. (restarting nm-applet, reinstalling the package, or readding the indicator applet)

That makes me wonder about gconf settings which turns out to be true.

My very quick and dirty solution is:

- backup your .gconf folder to .gconf-bak and logout
- login. now you have clean desktop with a working network applet
- To restore your old settings, move your new .gconf to .gconf-fresh
- rename .gconf-bak to .gconf
- delete .gconf/apps/panels and copy the working panels from .gconf-fresh/apps/panels

This should work if everything else fails. Unfortunately I did not have time to investigate deeper to find the exact cause. I hope this helps

Cheers

rudy1210 (rudy1210) wrote :

Applet is active again by changing theme to clearlooks and back to radiance (for me...) but with the clearlooks icon

Also confirming like Peter M. Clausen that removing and putting back "Notification Area" make the right icon showing again...

Flo Ebnet (silanea) wrote :

Another affected Lucid user here. This bug is really annoying. Neither removing and re-adding the notification area nor #13 did anything for me on the affected user account. I created a new account and there the nm was present.

Brandon Thomson (gravix) wrote :

My user account also lost the applet from 9.10-10.04. I tried most of the fixes here to no avail.

Thinking about just doing a fresh install, the upgrade seems to have broken a lot of things.

Brandon Thomson (gravix) wrote :

Spoke too soon. Clearing .gconf folder solved it, at least for now. Thanks #13.

Kay (noiq) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers