upgrade triggers nm-applet "resource not found" ... missing icon "nm-applet-device"

Bug #456468 reported by Alexander Sack on 2009-10-20
146
This bug affects 25 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned
Lucid
Medium
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Michael Vogt

Bug Description

Binary package hint: humanity-icon-theme

upgraded to latest theme i guess and got a "Resource not available" ... like:

** (nm-applet:3496): WARNING **: Icon nm-active-device missing: Icon 'nm-active-device' not present in theme

8:49 < asac> only explain i have is that you guys shipped nm-active-device ... linked it maybe as nm-device-wired ... and now moved the nm-device-wired
              link somewhere else

Alexander Sack (asac) wrote :

turned out to be a applet bug.

affects: humanity-icon-theme (Ubuntu) → network-manager-applet (Ubuntu)
Alexander Sack (asac) wrote :

this is an upgrade glitch that happened because daily nm-applet dropped a previously not used icon. we should keep this on radar for the SRU we plan to do after final karmic is released so we can workaround to provide a perfect upgrade experience.

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
milestone: none → karmic-updates
status: New → Triaged
Alexander Sack (asac) wrote :

got a few more reports from daily users that this also blows up the applet ... setting importance High and taking it to my plate for now.

Changed in network-manager-applet (Ubuntu):
assignee: nobody → Alexander Sack (asac)
importance: Medium → High
Michael Vogt (mvo) wrote :

I get this error during a karmic->lucid upgrade too.

Changed in network-manager-applet (Ubuntu Karmic):
milestone: none → karmic-updates
Changed in network-manager-applet (Ubuntu Lucid):
milestone: karmic-updates → ubuntu-10.04-beta-1
tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Chris, could you look at this issue?

Changed in network-manager-applet (Ubuntu Lucid):
assignee: Alexander Sack (asac) → Chris Coulson (chrisccoulson)
Sebastien Bacher (seb128) wrote :

still an issue for upgrades to beta1 lucid

Steve Langasek (vorlon) on 2010-03-19
Changed in network-manager-applet (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Martin Pitt (pitti) wrote :

This is really tricky to fix, and it does not really break upgrades entirely, so lowering priority. What we should do, though, is to ensure that we fix the lucid package to autorestart, so that similar problems won't bite any more in future upgrades from lucid.

Changed in network-manager-applet (Ubuntu Karmic):
status: New → Invalid
milestone: karmic-updates → none
Changed in network-manager-applet (Ubuntu Lucid):
importance: High → Medium
milestone: ubuntu-10.04-beta-2 → none
Michael Vogt (mvo) wrote :

Here is the error in .xsession-errors:

** (nm-applet:1345): WARNING **: Icon nm-active-device missing: Unable to load image-loading module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so)

Michael Vogt (mvo) wrote :

libgtk2.0-0 is updated in line 1130 of my upgrade log. Icon themes are replaced in 1772pp (gnome and hicolor). I looked at the n-m-a source and on icon theme change first all icons are unrefed, then the new ones are loaded. The unref of the icons has the effect that the pixbuf loader gets unreferenced as well and loading it again does no longer work because the old libc/libgtk in memory will not work with the new pixbuf-loader-png

Chris Coulson (chrisccoulson) wrote :

This issue is mitigated against in the current Lucid version of nm-applet, but obviously that doesn't help upgrades at all. I'm not sure how else I can progress this one at the moment

This caused flashplugin-nonfree to not get upgraded correctly for me. Users can work around this problem with flash by removing and then reinstalling Flash Nonfree from the software-center.

miked1981 (miked1981) wrote :

I had this issue in Lucid and the fix for me was to comment out the last line "iface eth0 inet dhcp" in /etc/network/interfaces and then reboot. After that the nm-applet started to manage the wired interface and this allowed the icon to be displayed. The way I found this was I miss the sound icon by a pixel and the hidden network manager icon said "Wired Network not managed".

Mattias Eriksson (snaggen) wrote :

I just did a clean install of Lucid Beta2 and it put the lines

auto eth0
iface eth0 inet dhcp

in /etc/network/interfaces causing my wired network not to work. I had to manually run dhclient to get a network.
If I comment these lines out thing work and network-manager manages the network again.

Charlie Kravetz (charlie-tca) wrote :

This is still a valid issue in the final xubuntu hardy to lucid upgrade testing. NM-applet disappears from the panel.

semacore (surerank) wrote :

I have the same issue that occurred right after I upgraded from the beta.

At one point some of the icons were doubled and the network manager icon next to the clock were missing.

How do we go about restoring it to the panel. It seems to be one of the few things missing from the list of things you can add to the panels.

Filiprino (filiprino) wrote :

I'm suffering this bug. I upgraded from Ubuntu 9.10 to Ubuntu 10.04 LTS and I can't see nm-applet icon.

Igor Kovach (89135077777-mail) wrote :

Upgraded from 9.10 to 10.04 lost icon nm-applet.
But apparently he applet is active. Menu of nm-applet can be found by clicking to the place where he is. At one of the blank pixels to open a menu manager network.

kovach@book:~$ nm-applet
** (nm-applet:4001): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:4001): DEBUG: old state indicates that this was not a disconnect 0

rocking_benny (rockingbenny) wrote :

I'm experiencing the same problem while upgrading from Ubuntu 8.04 LTS to Ubuntu 10.04 LTS and can't see nm-applet icon.

rahduke (rahduke) wrote :

same here, someone fix it please...

Accepted update-manager into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

For lucid we'll use the workaround in update-manager.

Changed in network-manager-applet (Ubuntu Lucid):
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Won't Fix
Changed in update-manager (Ubuntu):
status: New → Invalid
Changed in update-manager (Ubuntu Lucid):
assignee: nobody → Michael Vogt (mvo)
Paul Elliott (omahn) wrote :

Can anyone clarify what the test case is for this proposed update?

Abhishek (bhadotia) wrote :

This forum post gives another method for restoring the nm-applet:
http://ubuntuforums.org/showpost.php?p=9236722&postcount=16
This can be used as a workaround until they get it fixed. This method is explained in the file
/usr/share/doc/network-manager/README.Debian. Read that to get an idea of what is actually being done there. This is just an alternate approach to the one as described by miked1981 above.

@Martin Pitt
Can you explain how the update to update-manager would fix this problem with nm-applet.
I use pppoeconf to connect to my ADSL connection. And I lost my panel applet after I configured my ADSL connection (this is also the case with other people on the forum thread I linked above). Before that, on a clean lucid install, the applet was appearing normally and I could connect to my University's wireless networks.
Here's what I get when I type "nm-applet" in the terminal:
** (nm-applet:2271): WARNING **: <WARN> constructor(): Couldn't initialize the D-Bus manager.

And this is what my .xsession-errors has to say:
** (nm-applet:1832): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:1832): DEBUG: old state indicates that this was not a disconnect 0

And I got the above outputs when I was not using the workaround described in the thread.

Charlie Kravetz (charlie-tca) wrote :

Abhishek: This bug was a direct result of upgrading. When upgrading from one version to another, the network-manager applet disappears. If it disappears at any other time, that is a different bug and if not already done, should be filed as such.

Abhishek (bhadotia) wrote :

Charlie Kravetz :
In any case, how is it that an update to update-manager is going to resolve the problem- that's the question?

And the solution mentioned here to get around this bug is pretty similar to the one we've used to get around on new installs. So I guess this bug refers to the same problem (whether an upgrade or a new install).

And if I am posting on the wrong bug report, can some one guide me to the right one. Or should I create a new bug report for the problem I mentioned in my previous post?

Abhishek (bhadotia) wrote :

Charlie Kravetz : Just took a look at the change log for the proposed update and think you are right. I guess I should open another bug report for the issue we are facing on clean installs.

Steve Beattie (sbeattie) wrote :

I have reproduced the problem with update-manager 1:0.134.8 and have verified that the version of update-manager in proposed, 1:0.134.9, fixes the issue. I do not see any regressions when performing upgrades or updating packages with the version of update-manager in -proposed.

Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.134.9

---------------
update-manager (1:0.134.9) lucid-proposed; urgency=low

  * DistUpgrade/DistUpgrade.cfg:
    - add ubuntu-netbook-remix and ubuntu-netbook to valid
      meta-packages to ensure clean transition for the rename
      of ubuntu-netbook-remix to ubuntu-netbook (LP: #574279)
  * DistUpgrade/DistUpgradeCache.py:
    - Check if the metapkg is actually upgradable. This covers
      the case of ubuntu-netbook-remix that may no longer be
      available to a user if "universe" is disabled (LP: #574279)
  * DistUpgrade/DistUpgradeQuirks.py:
    - Add workaround for nm-applet dying during the upgrade. At
      the start up of the update we take it down in a controlled
      way (LP: #456468)
    - add workaround for wine upgrade failure (LP: #571999)
    - help the upgrade if both ubuntu-desktop and xubuntu-desktop
      are installed (LP: #571743)
 -- Michael Vogt <email address hidden> Fri, 21 May 2010 09:49:43 +0200

Changed in update-manager (Ubuntu Lucid):
status: Fix Committed → Fix Released
Jean-Luc (lacroix-jean-luc) wrote :

This bug also affects fresh installations. I just installed Lucid and only the first user who logs in have the nm-applet icon.

The fix mentioned here doesn't work either.
http://ubuntuforums.org/showpost.php?p=9236722&postcount=16

Eric Hazen (hazen) wrote :

This bug affects me on a fresh installation. If I run "nm-applet" from a command line the applet appears fine. The fix mentioned in the comment #29 above does not help, nor does adding the notification area.

surprisingly, i ran nm-applet from a command line and return this message:

root@douglas-desktop:#nm-applet

** (nm-applet:2560): WARNING **: <WARN> bus_init(): Could not get the session bus. Make sure the message bus daemon is running! Message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Falló en GConf: Falló al contactar con el servidor de configuraciones; algunas de las posibles causas son que necesite activar TCP/IP en ORBit, o que tiene bloqueos de NFS debidos a una caída de sistema. Consulte http://www.gnome.org/projects/gconf/ para más información. (Detalles - 1: Falló al obtener la conexión con la sesión: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
Ya existe una instancia de nm-applet en ejecución.

(nm-applet:2560): GConf-WARNING **: Directory `/system/networking/connections' was not being monitored by GConfClient 0x99626a8

and then run this command: "service network-manager"

root@douglas-desktop:#service network-manager
network-manager start/running, process 2566

and the network-manager icon appeared on panel...

I hope someone can help with this information

Martin Pitt (pitti) on 2011-02-15
Changed in network-manager-applet (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Invalid
Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in update-manager (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers