Ethernet icon looks wrong in Default theme

Bug #423167 reported by Alan Pope 🍺🐧🐱 🦄 on 2009-09-02
952
This bug affects 230 people
Affects Status Importance Assigned to Milestone
Humanity
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
human-icon-theme (Ubuntu)
Low
Unassigned
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

The icon for an ethernet connection in network manager looks 'wrong'. It looks too fat and short, not square enough.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Wed Sep 2 14:09:16 2009
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 10.10.10.0/24 dev eth0 proto kernel scope link src 10.10.10.100 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 10.10.10.1 dev eth0 proto static
NonfreeKernelModules: nvidia
Package: network-manager-gnome 0.8~a~git.20090818t151413.a8b7eed-0ubuntu2
PciNetwork:

ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RfKill:

SourcePackage: network-manager-applet
Uname: Linux 2.6.31-9-generic x86_64
WpaSupplicantLog:

Pauli Virtanen (pauli-virtanen) wrote :

It was very difficult for me to associate this icon with anything network-related. Recognizing the RJ45 socket from this icon is quite difficult as it's drawn in a heads-on 2D view, with a rather bad color choice. IMHO, it's quite ugly and uninformative.

(Rather than a RJ45 socket, it looks more like something out of Super Mario Bros...)

File name: /usr/share/icons/hicolor/scalable/apps/notification-network-ethernet-connected.svg

Neil Wilson (neil-aldur) wrote :

Bug is confirmed. The 'Wired Network' graphic has changed since alpha-3

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Neil Wilson (neil-aldur) wrote :

Graphic was correct in network-manager version 0.7.1-0ubuntu1

tags: added: bitesize
Neil Wilson (neil-aldur) wrote :

This looks like a fault with the Human theme rather than the applet itself. Switching to Tangerine or HighContrast icons changes the icon.

Changed in human-icon-theme (Ubuntu):
status: New → Confirmed
Changed in network-manager-applet (Ubuntu):
status: Confirmed → Invalid
summary: - Ethernet icon looks wrong
+ Ethernet icon looks wrong in Human theme

The Tangerine icon definitely makes more sense to me than the Human icon. The Human icon looks like a piano seen from above. The Tangerine one is instantly recognisable as a network or telephone cable and corresponding socket.

As this is an icon that will be displayed prominently on all newly installed Karmic desktops, a better, less ambiguous icon should be used.

Neil Wilson (neil-aldur) on 2009-09-19
tags: added: needs-artwork
Olaf (tholap) wrote :

Terrible regression. Like others I didn't even recognize it as new wired icon - I thought there was a display bug on my panel.
Proposed quick fix: Bring the old icon back.

wedderburn (andrew-wedderburn) wrote :

ok quick question, how many average users actually look at the back of their computers, none.

so how many average users are going to know that this thing is meant to mean wired network, none.

Tom Harris (tom-harris) on 2009-09-22
affects: human-icon-theme → hundredpapercuts
pjpc90@gmail.com (pjpc90) wrote :

Please change this ridicule icon it's the baddest.

Changed in network-manager-applet (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → Invalid
Kenneth Wimer (kwwii) wrote :

I have reverted this icon to the version from Jaunty (actually, Jaunty used the wrong sized icon so I improved upon it). This change will be in the next upload of the human icon theme, already in bzr.

Changed in human-icon-theme (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: New → Fix Committed
robert wheel3r (wheel3r6) wrote :

Glad to hear its been changed, it looked out of place.

ok thx

2009/9/23 robert wheel3r <email address hidden>

> Glad to hear its been changed, it looked out of place.
>
> --
> Ethernet icon looks wrong in Human theme
> https://bugs.launchpad.net/bugs/423167
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Fix Committed
> Status in “human-icon-theme” package in Ubuntu: Fix Committed
> Status in “network-manager-applet” package in Ubuntu: Invalid
>
> Bug description:
> The icon for an ethernet connection in network manager looks 'wrong'. It
> looks too fat and short, not square enough.
>
> ProblemType: Bug
> Architecture: amd64
> CRDA: Error: [Errno 2] No such file or directory
> Date: Wed Sep 2 14:09:16 2009
> DistroRelease: Ubuntu 9.10
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> IpRoute:
> 10.10.10.0/24 dev eth0 proto kernel scope link src 10.10.10.100
> metric 1
> 169.254.0.0/16 dev eth0 scope link metric 1000
> default via 10.10.10.1 dev eth0 proto static
> NonfreeKernelModules: nvidia
> Package: network-manager-gnome 0.8~a~git.20090818t151413.a8b7eed-0ubuntu2
> PciNetwork:
>
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
> RfKill:
>
> SourcePackage: network-manager-applet
> Uname: Linux 2.6.31-9-generic x86_64
> WpaSupplicantLog:
>

I'm glad it's been fixed. The ethernet icon looked horrible. I switched icon themes immediately.

Nice and thx

2009/9/23 techwizrd <email address hidden>

> I'm glad it's been fixed. The ethernet icon looked horrible. I switched
> icon themes immediately.
>
> --
> Ethernet icon looks wrong in Human theme
> https://bugs.launchpad.net/bugs/423167
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Fix Committed
> Status in “human-icon-theme” package in Ubuntu: Fix Committed
> Status in “network-manager-applet” package in Ubuntu: Invalid
>
> Bug description:
> The icon for an ethernet connection in network manager looks 'wrong'. It
> looks too fat and short, not square enough.
>
> ProblemType: Bug
> Architecture: amd64
> CRDA: Error: [Errno 2] No such file or directory
> Date: Wed Sep 2 14:09:16 2009
> DistroRelease: Ubuntu 9.10
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> IpRoute:
> 10.10.10.0/24 dev eth0 proto kernel scope link src 10.10.10.100
> metric 1
> 169.254.0.0/16 dev eth0 scope link metric 1000
> default via 10.10.10.1 dev eth0 proto static
> NonfreeKernelModules: nvidia
> Package: network-manager-gnome 0.8~a~git.20090818t151413.a8b7eed-0ubuntu2
> PciNetwork:
>
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
> RfKill:
>
> SourcePackage: network-manager-applet
> Uname: Linux 2.6.31-9-generic x86_64
> WpaSupplicantLog:
>

I want to reopen this bug, but dare not. Now that you all seem to agree it's fixed and all. However, i do not agree.

The nm-applet "wired ethernet" icon is disproportionate to the volume icon.
If it could be made less thin and pointy, and more square, but retain a size in proportion to the volume icon, that would look much better. Let's get the very few panel icons that are default on a fresh installation, and matter the most, to have a consistent look and feel.

I'm attaching a .png to illustrate what i mean.
Please tell me if i should open up a new bug, or if it's appropriate to repoen this one.

That looks like a different bug.

2009/9/25 pelle.k <email address hidden>:
> I want to reopen this bug, but dare not. Now that you all seem to agree
> it's fixed and all. However, i do not agree.
>
> The nm-applet "wired ethernet" icon is disproportionate to the volume icon.
> If it could be made less thin and pointy, and more square, but retain a size in proportion to the volume icon, that would look much  better. Let's get the very few panel icons that are default on a fresh installation, and matter the most, to have a consistent look and feel.
>
> I'm attaching a .png to illustrate what i mean.
> Please tell me if i should open up a new bug, or if it's appropriate to repoen this one.
>
> ** Attachment added: "exmaple.png"
>   http://launchpadlibrarian.net/32436289/exmaple.png
>
> --
> Ethernet icon looks wrong in Human theme
> https://bugs.launchpad.net/bugs/423167
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Neil Wilson

This is a different bug. We switched to the humanity theme.

Changed in humanity:
status: New → Confirmed
assignee: nobody → Daniel Fore (daniel-p-fore)
Changed in human-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2009-09-25
Changed in humanity:
status: Confirmed → Invalid
pelle.k (pele2) wrote :

Daniel, excuse me for being "slow", but does that mean you don't agree with https://bugs.launchpad.net/humanity/+bug/423167/comments/15 , or did you mean i should open a bug against humanity icon theme instead?

Daniel Fore (danrabbit) wrote :

Pelle.K

Sorry, I didn't see that!!

Changed in humanity:
status: Invalid → Confirmed
Vish (vish) on 2009-09-26
Changed in humanity:
assignee: Daniel Fore (daniel-p-fore) → mac_v (drkvi-a)
status: Confirmed → In Progress
Vish (vish) wrote :

Fixed in rev 314

Pelle.K , could you test this and confirm the fix?
pull the icons from >
$bzr branch lp:humanity

Could you do a similar illustration even if fixed too? :)

Changed in humanity:
assignee: mac_v (drkvi-a) → nobody
status: In Progress → Fix Released
Changed in human-icon-theme (Ubuntu):
status: Fix Released → Fix Committed
Vish (vish) wrote :

Pelle.K , i dont use a ethernet connection hence i couldnt test it from my end. also the illustration was quite nice ,
good catch BTW ;)

Vish (vish) on 2009-09-26
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → round-10
summary: - Ethernet icon looks wrong in Human theme
+ Ethernet icon looks wrong in Default theme
pelle.k (pele2) wrote :

I've just tried the new humanity out from bzr, and i'm afraid it needs just a little bit more attention.
It's just two pixels or so larger than the volume icon, and one could just as well also argue that the volume icon is the one that need fixing (they are both smaller than the default bluetooth icon). The shape of the network-manager "wired network" also makes it seem larger than it really is, but thats's just an optical illusion.
Anyway, illustration attached. Thanks for fixing this btw :)

Vish (vish) on 2009-09-29
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Jeroen Hoek (mail-jeroenhoek) wrote :

The ethernet icon in the Human (Default) theme is still the faulty one reported in this bug in the current Karmic beta release. Shouldn't the fixed package have hit the repositories by now?

Steve Langasek (vorlon) wrote :

There appears not to have been any upload of the human-icon-theme package since this change was committed (last upload was September 11). Ken, was an upload of this still wanted for karmic? SInce human is no longer the default theme, we arguably don't need to treat that as a UI freeze exception since the documentation team should be working off the humanity theme instead.

Changed in human-icon-theme (Ubuntu):
importance: Undecided → Low
Kenneth Wimer (kwwii) wrote :

Human as been placed in Universe, and as such, has a lower priority than the default themes. As an ubuntu-only theme, when ubuntu changes, I am not sure if it is worthwhile to maintain it as we have in the past. In any case, since Human is not included in Main any more there is no reason to do any UI exceptions for it..perhaps after release an update.

tags: added: regression-release
removed: regression-potential
Johan Walles (walles) wrote :

Still broken in Karmic :-(.

Vish (vish) wrote :

@Johan Walles :
What you are using is *not* humanity-icon-theme. The problem has been fixed in humanity.

You are using the Human theme. Regarding which, Kindly read the comment above yours [comment 25]

Johan Walles (walles) wrote :

Actually, I *had* switched to Humanity, but the network icon didn't change until I logged out and then back in again.

Alex Lourie (alourie) wrote :

Is this still relevant after Natty and Oneiric have been released?

Adolfo Jayme (fitojb) wrote :

Closing, don't think this is still relevant.

Changed in human-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers