Wireless notification icon show full/no signal instead of the actual signal strength

Bug #387626 reported by callahan on 2009-06-16
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Omer Akram
network-manager-applet (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Omer Akram

Bug Description

The wireless notification[notify-osd] on wireless connection, always shows signal strength as full, while there are icons for all signal strengths > /usr/share/icons/Human/scalable/status/notification-network-wireless-*
This confuses users , who are used to the white as being no signal in the panel icon.
This confusion could be avoided if the signal strengths are shown appropriately, this needs to be corrected.

---------OLD DESCRIPTION----------
The new wireless notification connection message always uses the icon for a wireless signal strength of no signal. It would be nice if it showed the actual signal strength instead.

Can you please capture screenshots of the problem, and perhaps make a mockup of a proposed solution?

Changed in hundredpapercuts:
status: New → In Progress
Changed in hundredpapercuts:
status: In Progress → Incomplete
callahan (callahan) wrote :

Here is the before/after screenshot mockups for this bug. I've been trying to fix it myself in my spare time but I'm not certain where this icon is sent from yet.

callahan (callahan) wrote :
Vish (vish) wrote :

@callahan:
The grey signal color is actually the design.
It is to reinforce non-interactive element of the bubble.

the icons are > /usr/share/icons/Human/scalable/status/notification-network-wireless-*
The signal strengths are always shown as full, which needs to be looked into.

Changed in hundredpapercuts:
status: Incomplete → Confirmed
Vish (vish) on 2009-07-19
description: updated
callahan (callahan) wrote :

Two things:

First, I cannot tell the difference between the notification-network-wireless-* icons without looking at the names. Pull one up at random and see if you can tell which it is. They need to match brightness better if they are supposed to be grey.

Second, I tracked the setting of this icon to network-manager-applet-0.7.1~rc4.1 in src/applet-device-wifi.c. There is a patch to that called lp33796_dxteam_notification_icon_names.diff that changes the icon from nm-device-wireless to notification-network-wireless-full. I'm pretty sure that's what would change for setting the icon selectively. The code for doing so can be found in the same file where it sets up the status bar icon. Ideally it should probably go into it's own function rather than being cloned twice as it is full of magic constants.

Last comment, it would be super nice if "apt-get source" actually pulled up something under revision control rather than a dead copy of the code. It's a nuisance to create patches as is.

Vish (vish) wrote :

@callahan:
simple opening of the notify-osd icons in EOG , wont give you a good idea about the design.
They are designed to show on a black background.

To see them in action, use the following command: that will clearly show the bars.
$ notify-send "Wireless" "Check" -i notification-network-wireless-high
replace high , with each strength in the file name.

you can clearly see the difference in the icons, only in the bubble.

Vish (vish) wrote :

Regarding you second point,
I dont think there is any change done by notify-osd,
previously the icon [/usr/share/icons/gnome/scalable/status/nm-device-wireless ]was only a constant icon without showing any signal strength. now its more obvious, thats all i guess.

Alexander Sack (asac) wrote :

personally i think this is not really useful change. users are unlikely to be confused by this ....

10:53 < mac_v> asac: we have icons for all strengths why not use them , make the notification more useful?
11:02 < asac> mac_v: so checkout wireless_get_icon src/applet-device-wifi.c
11:02 < asac> mac_v: the notifications can try the same thing that is used there to decide which icon to use in tray
11:02 < asac> thats in wireless_device_state_changed
11:03 < asac> except that i dont thinkg its really useful

Vish (vish) wrote :

Seems a new patch for NetworkManager/applet is required

Changed in network-manager (Ubuntu):
status: New → Invalid
Changed in network-manager:
status: New → Invalid
Changed in notify-osd (Ubuntu):
status: New → Confirmed
Vish (vish) wrote :

@Alexander Sack :
It is actually an essential change, since we are using the wireless icon which shows a signal strength and showing the wrong signal strength , such a notification is redundant and misleading.

Either a generic icon needs to be used,as was previously[which didnt show a signal strength] ,
or the correct signal strength icon needs to be used.

Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in notify-osd (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Martin Erik Werner (arand) wrote :

Also, it needs to be noted that in Karmic, the icon used in the panel has changed, and the one in notify-osd has not, which makes the "click this icon" message even more faulty.

summary: - wireless notification icon is wrong signal strength
+ Wireless notification icon show full/no signal instead of the actual
+ signal strength
Marius B. Kotsbak (mariusko) wrote :

This is an upstream issue, so I registered such bug report.

Changed in network-manager:
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Changed in notify-osd (Ubuntu):
status: Triaged → Invalid
Changed in network-manager:
importance: Unknown → Low
status: Unknown → New
Omer Akram (om26er) on 2012-10-26
no longer affects: notify-osd (Ubuntu)
Marius B. Kotsbak (mariusko) wrote :

Is this still an issue? Looks like the upstream code has changed to separate icons for each signal strength for Wifi. Still the same for other types of connections.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Incomplete

Still an issue in 14.10

The attachment "0001-Modified-the-wifi-connected-notification-to-indicate.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in network-manager:
status: New → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.