Usability: too many wireless networks makes it hard to find and pick the one you want

Bug #367721 reported by Vinod on 2009-04-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

Near my apartment building, there are almost 50 wireless networks.

I have my own hidden SSID, but it sorts last. So any time I want to connect, or select one of the menu items at the bottom (Hidden networks, VPN, Create New ..) it's a slow process of trying to scroll through. This was more true when I was first setting up my new Ubuntu install and had some probs connecting (vs. now where things are working and I don't need to look at the menu often). I also plan to move between about 5 locations with different access points (home, work, friend's places, etc.) and will need to manage these easily.

I would suggest:

1. An option to connect to a new network you just defined (from the Network Connections popup reached by the Edit Connections Menu OR System-> Preferences -> Network Connections), or one that you had created before. I'm reminded of Vista where it seems it is worse, but stems from the same problem: the editing of network definitions is treated as completely separate from the act of trying to connect, yet that's typically the reason you're editing/defining it -- so you can connect to it.

2. An quick menu that shows all the nets you've defined, marking which ones are available and allowing you to pick one of them OR optionally to list all available networks you can see (which is the current behaviour).

Setting a network connection to "connect automatically" helps, but IMHO the above will make it even more intuitive.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
NonfreeKernelModules: nvidia
Package: network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
Uname: Linux 2.6.28-11-generic x86_64

Vinod (vinodkutty) wrote :
Paolo Sammicheli (xdatap1) wrote :

I just tried Karmic Beta Netbook Remix and I confirm this bug.

IMHO the main problem is that network list is sorted by name. Instead it should be sorted by signal strength because in a public area you want to connect to the nearest network. And also in previous example, when you are at home you want to connect to your network and it should be the best signal across the others, or at the least one of the first.

In attach what i got today, my network was under "More Networks..." but it has the best signal strength.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Lesmana Zimmer (lesmana) wrote :

i changed the package from network-manager to network-manager-applet because this bug is about the front-end. AFAIK network-manager is just the back-end and doesn't care about sorting anything. i don't know about the status so i left it at "confirmed".

also sort of related: bug #485041

affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)

The analysis there is correct, this is a bug in the front-end.

Bug 485041 contains discussion and explanation as to why networks won't be listed by strength and are listed in alphabetical order instead.

Note that your "favorite" networks, the ones that have been connected to before and are configured in the connection editor (or manually entered), would show in the "top 5" list that doesn't get folded over to "More networks" (up to five, of course). This should take care of the cases after first setting up your system; although the first time you would still need to select the network from the list (wherever it ends up in that list).

Since I think this is pretty much covered in later releases (Lucid and on), I'll mark this Fix Released. Don't hesitate to reopen or file a new bug for specific issues you might encounter. Thanks!

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers