nm-connection-editor does not save changes

Bug #278216 reported by jwishnie on 2008-10-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

Specially, in response to the following, the nm-commection-editor does nothing:
- Changing connection name
- Checking 'System Setting' checkbox

To reproduce:
1. Connect to a wireless network
2. Right-click tray icon and choose 'Edit Connections'
3. Select the connection that you just created and click 'Edit'
4. Change the Connection Name (first field in panel)
5. Click OK
6. NOTE: Connection name does not change
7. Edit connection
8. Check 'System Setting'
9. Click OK
10. NOTE: connection settings are NOT save in /etc/NetworkManager/system-connections

I suspect that the panel is not properly dirtying it's internal model so that when OK is clicked the panel does not think any settings have changed and does not persist the changes.

Evidence for this is that changing OTHER settings will cause both Name and System Settings to function properly

1. Edit a connection
2. Click 'system settings'
3. Change some IPv4 setting (e.g. switch it from DHCP to link-local)
4. Click OK
5. NOTE: system settings ARE saved to /etc/NetworkManager/system-connections

Ricardo Pérez López (ricardo) wrote :

I have a similar problem I reported on bug #281687.

jac0b (jacbrooks) wrote :

I have this same problem on 8.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers