nm-applet confused by icon name changes during hardy-intrepid upgrade

Bug #277084 reported by to be removed on 2008-10-02
8
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: network-manager-gnome

It seems that nm-applet can get confused when its icons disappear
during an upgrade. This happened while testing an upgrade from
Xubuntu hardy to intrepid beta candidate ISO, but is probably not
restricted to Xubuntu.

The problem: during the upgrade, nm-applet put up a number of error
dialogs complaining that it could not access some of its necessary
resources. Everything seemed to work, otherwise.

The diagnosis: some icons have changed names from the hardy version
to the intrepid version. While the system upgrade was running, it
unpacked the new version of nm-applet, removing the old files, and
as a result the old icons went away. Result: nm-applet complains.
It seems that this would not have happened if I had not started
the upgrade pretty much immediately after logging in. If I had used
the system first for a while, I might have triggered nm-applet to
load the old icon already, and so nothing would have been a problem.

The problematic icons are nm-vpn-lock and nm-device-wired-autoip

The IRC discussion:

<liw> asac, when testing an upgrade of xubuntu from hardy to intrepid, I
get (at least) four windows saying "The NetworkManager applet could not
find some required resources. It cannot continue". (Make that five,
another popped up just now)

<liw> asac, does that sound familiar?

<asac> liw: you tried to manually restart things? or did you reboot?

<liw> asac, the ugprade is still running (six windows now)

<liw> asac, I haven't touched anything, except to move the windows so I
can count them (seven)

<asac> liw: so was NM already unpacked?

<liw> asac, how do you mean? it was running in the system from which I
started the upgrade

<liw> asac, this is under kvm, if that matters (though it shouldn't)

<asac> liw: what i wonder about is whether this happens before or after
the NM bits have been unpacked during upgrade

<liw> asac, hmm, I don't think I can figure that out anymore

<liw> asac, unless there's some log file I can grep for you

<liw> asac, this is a guess, but based on the timestamps in dpkg.log, I
would guess the problems started happening approximately when
network-manager(,-gnome} were unpacked; I can't verify that that's true,
but my internal clock would indicate it is

<asac> liw: ok. strange that it happens in xubuntu.

<asac> liw: did the upgrade restart dbus or something?

<asac> liw: ok that error message comes from 0.7 applet

<asac> liw: this means that you restarted the applet

<asac> (if not you something else restarted it)

<asac> which must not happen

<asac> liw: maybe the xubuntu xsession does some magic to restart binaries?

<liw> asac, I don't know what xubuntu does, I just test this :)

<asac> cody-somerville: ^^

<cody-somerville> We don't do any magic

<asac> liw: can you see when the nm-applet process was started?

<liw> asac, long before the problems

<asac> liw: question is if it was started long before the unpack :)

<liw> (ps says it was started 14:26, problems started around 15:00)

<liw> unpack also approximately at 15:00

<asac> liw: so 14:26 is about the time you logged into xubuntu?

<liw> asac, yeah

<asac> liw: and you did nothing? e.g. not even tried to start the connection editor or something?

<liw> asac, nope, I only ran the upgrade command

<liw> (sudo update-manager -d -c)

<asac> mvo: does update-manager try to restart things?

<mvo> asac: restart what? firefox?

<asac> mvo: no restart nm-applet (which usually gets auto started by the
session)

<mvo> asac: no, it can't because the actual installation runs as root

<asac> mvo: myterious then. liw logged into xubuntu. ran upgrade and
without doing anything suddenly sees applet error dialogs from 0.7

<mvo> asac: however it seems that network manager kills the network when
it gets upgraded sometimes (or all th time?)

<asac> mvo: thats not done anymore

<asac> mvo: dbus restart could cause something though

<asac> but i dont see how it can restart the applet :(

<mvo> asac: we don't do that

<mvo> asac: it might be that the applet probably restarts itself (or
gets restarted by something like the session) because it crashes when
the new n-m gets installed

<liw> asac, if the applet has been running since I logged in and before
I started the upgrade, did it really get upgraded?

<asac> liw: yeah.

<asac> liw: my grep was bogus ... 0.6.6 applet will complain like that
too in some cases

<asac> liw: do you see if NM restarted was restarted?

<asac> (the daemon)

<liw> asac, it has also been running since 14:26, i.e., hasn't been
restarted, as far as I can see

<asac> liw: ok looks like it happens if NM tries to use icons that it
didnt use previously

<asac> liw: so most likely would just be the case if you have more or
less a fresh started session

<liw> asac, ok, that sounds reasonable; shall I continue with the
upgrade, then, or do you want me to grep for something more? also,
should I file a bug?

<asac> liw: you could strace -eopen -p PID

<asac> and tell me which file it tries to open when it complains

<liw> asac, the applet?

<asac> yeah

<asac> liw: we could consider to create compatibility links ... and then
see what other resources nm-applet would complain when the icons are
still available

<asac> maybe there would be a missing .glade resource too ... which
would be harder to fix

<liw> asac, I can't seem to be able to trigger the applet to open the
icon anymore, hmm

<liw> ah, no, got it now

<liw> asac, it's (at least)
/usr/share/icons/gnome/16x16/actions/gtk-edit.png and gtk-about.png

<liw> asac, though both now succeed, hmm

<asac> yeah those are not NM icons

<asac> liw: http://paste.ubuntu.com/53182/

<asac> those are the ones i suspect to be missing

<asac> liw: seems like the only one missing is vpn-lock

<asac> can you confirm that?

<asac> yeah thats vpn-active-lock now from what i can see

<liw> there is no file matching vpn-lock* under /usr/share/icons

<asac> liw: right

<asac> thats gone ... and thats why you get this

<asac> ln -s /usr/share/icons/hicolor/22x22/apps/nm-vpn-active-lock.png
/usr/share/icons/hicolor/22x22/apps/nm-vpn-lock.png

<asac> might be what we want

<liw> in fact, no icon matching vpn*

<liw> oh, nm-vpn*

<asac> liw: dpkg -L network-manager-gnome | grep vpn.*png$

<asac> liw: i will ask NM folks why that icon was renamed ;)

<asac> liw: everyother icon is there right?

<liw> asac, nm-device-wired-autoip seems to be missing, too

Adam Portier (aportier) wrote :

Hi, before I can move this up the pipeline, I need to get some more information so that the bug team can reproduce what happened. Do you have any logs from the install that you could put in this report. Also, what version of nm-applet does apt/Synaptic say you have?

Changed in network-manager-applet:
status: New → Incomplete
to be removed (liw) wrote :

To reproduce, just install Xubuntu hardy under kvm, upgrade to current hardy, reboot, and start the upgrade to intrepid.

 I have killed the image I had, since Alexander told me he doesn't need any other info from the system. The versions where whatever was current in hardy, and whatever is current in intrepid.

Furthermore, since Alexander already seems to have all the information needed to work on this, I'm going to reset the state to New.

Changed in network-manager-applet:
status: Incomplete → New
Jacqui (jacqui-russell) wrote :

I had the same happen, upgrading from Ubuntu Hardy. My wireless has also not worked since.

My Synaptic says I have version 0.7 if that helps.

Alexander Sack (asac) on 2008-10-07
Changed in network-manager-applet:
importance: Undecided → High
milestone: none → ubuntu-8.10
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.7~~svn20081015t194645-0ubuntu1

---------------
network-manager-applet (0.7~~svn20081015t194645-0ubuntu1) intrepid; urgency=low

  * new upstream snapshot Wed 2008-10-15 19:46:45 +0000 (rev 809)
  * fix LP: #277084 - nm-applet confused by icon name changes during
    hardy-intrepid upgrade; we ship icons used by NM 0.6 in the NM 0.7
    to prevent this behaviour
    - update debian/rules

 -- Alexander Sack <email address hidden> Thu, 16 Oct 2008 00:42:34 +0200

Changed in network-manager-applet:
status: Triaged → Fix Released
Alexander Sack (asac) wrote :

this should be fixed by now. If you still see this when testing hardy/intrepid upgrade, please ping me on irc to get a prompt reaction.

Thanks!

to be removed (liw) wrote :

Hmm. I did get the warning/error while upgrading, twice, but I hadn't read the e-mail asking you about it, so I didn't talk to you. I will be re-running the test anyway, so if it still happens, I'll talk to you.

Jamie Lokier (jamie-shareable) wrote :

I'm using Ubuntu - the GNOME version.

I did a Hardy->Intrepid upgrade today (2008-10-26).
During the upgrade, I didn't get any dialog windows from NetworkManager.

But upon rebooting, there was no Network Manager applet in the GNOME panel,
and also no network - the NetworkManager daemon didn't try connecting by itself.
Bit hard to search for bug reports without it :-)

Also under "Add to Panel" there is no Network Manager applet or equivalent. (There's a Network Monitor applet but that's different).

I ran nm-applet from a terminal window, then it appeared in the panel.
It spit out 5 messages like this:

    ** (nm-applet:10138): WARNING **: <WARN> constructor(): Invalid connection: 'NMSettingConnection' / 'type' invalid: 3

Clicking on the icon, I found it had decided to disable networking. (That explains why NetworkManager didn't connect by itself without needing the applet).

I re-enabled networking, then selected a wireless access point, and it was back to normal, i.e. before the upgrade.

Jamie Lokier (jamie-shareable) wrote :

(Well back to normal if you don't count discarding all my wireless connections or passphrases (eek!) from Hardy, so I have to re-enter all the passphrases again as I visit each site. Thank goodness they weren't lost from the "Passwords and Encryption keys" app!)

On Sun, Oct 26, 2008 at 11:02:26PM -0000, Jamie Lokier wrote:
> I'm using Ubuntu - the GNOME version.
>
> I did a Hardy->Intrepid upgrade today (2008-10-26).
> During the upgrade, I didn't get any dialog windows from NetworkManager.
>
> But upon rebooting, there was no Network Manager applet in the GNOME panel,
> and also no network - the NetworkManager daemon didn't try connecting by itself.
> Bit hard to search for bug reports without it :-)
>
> Also under "Add to Panel" there is no Network Manager applet or
> equivalent. (There's a Network Monitor applet but that's different).
>
> I ran nm-applet from a terminal window, then it appeared in the panel.
> It spit out 5 messages like this:
>
> ** (nm-applet:10138): WARNING **: <WARN> constructor(): Invalid
> connection: 'NMSettingConnection' / 'type' invalid: 3
>
> Clicking on the icon, I found it had decided to disable networking.
> (That explains why NetworkManager didn't connect by itself without
> needing the applet).
>
> I re-enabled networking, then selected a wireless access point, and it
> was back to normal, i.e. before the upgrade.
>

Hmm. Did you check whether a nm-applet process was running at all? Can
you reproduce this by disabling networking and rebooting and if you
see this check whether a nm-applet process and a NetworkManager
process is running?

 - Alexander

keneida (keneida) wrote :

Same for me. the icon is missing. Same with power-manager icon.
When you restart hal the power manager icon shows just for a second or two.
I just recalled that I had same problem with previous upgrade -> 7.4 i guess.
If you create new account on your computer (with empty home/newuser) and log into you will see the icon.
So it must be something broken with the configuration files.
I will try to find out which file is it - i guess one from gnome configuration. But unfortunately don't have lots of time.

Jojo (kuzniarpawel) wrote :

I confirm what keneida said. After upgrade from Hardy to Intrepid nm-applet, bluetooth and power-manager icon disappeared. Creating new user restores everything to normal.

Jojo (kuzniarpawel) wrote :

I'm using Ubuntu not Xubuntu.

G J (g-jarnot) wrote :

you just have to change your /etc/network/interfaces
put these 2 lines (delet the other lines):

auto lo
iface lo inet loopback

and your applet will appear again

Alexander Sack (asac) wrote :

On Mon, Nov 03, 2008 at 02:49:53PM -0000, Jojo wrote:
> I confirm what keneida said. After upgrade from Hardy to Intrepid nm-
> applet, bluetooth and power-manager icon disappeared. Creating new user
> restores everything to normal.
>

This isnt this bug. please open a new one. please post what you get
when killing nm-applet and running it from terminal after that.

 - Alexander

Germán Poo-Caamaño (gpoo) wrote :

I upgraded today (november 03), with the following information:

$ apt-cache policy network-manager
network-manager:
  Installed: 0.7~~svn20081018t105859-0ubuntu1
  Candidate: 0.7~~svn20081018t105859-0ubuntu1
  Version table:
 *** 0.7~~svn20081018t105859-0ubuntu1 0
        500 http://cl.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

After reboot, I couldn't get my wireless working. I had configured eth0 manually
in order to get network access.

If I kill nm-applet and try to run it again I get:

$ nm-applet --sm-disable

** (nm-applet:8013): WARNING **: <WARN> constructor(): Invalid connection: 'NMSettingConnection' / 'type' invalid: 3

Alexander Sack (asac) wrote :

all what you post here is not this bug. please open new bugs or search for better matches ;). Thanks! Remember that this particular bug is something that was fixed and thats still the case :).

nick (swcodfather) wrote :

See this bug for an exact match:

Bug #249404:

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers