Ubuntu

MASTER no wlan option for pppoe configuration

Reported by Vit Svarc on 2008-05-20
112
This bug affects 24 people
Affects Status Importance Assigned to Milestone
NetworkManager
Confirmed
Wishlist
Network Manager Applet
Confirmed
Wishlist
dillo (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Pedro Villavicencio
Declined for Jaunty by Pedro Villavicencio
network-manager (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Pedro Villavicencio
Declined for Jaunty by Pedro Villavicencio
network-manager-applet (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Pedro Villavicencio
Declined for Jaunty by Pedro Villavicencio

Bug Description

In Ubuntu 8.04, there is possibility to set up ppoe connection using gui in network settings.
But there is only possibility to use ethernet devices for setting the connection.
In my case, I am using pppoe over wlan device (quite common internet connection in Germany), it means, I have to connect to WLAN bridge and then use this wlan bridge for setting pppoe connection.
To do this, I have to set up it using command line tool pppoeconf.
So I think this is not feature request, this is a bug in present gui, that the wlan device can't be chosen.

Ralph Janke (txwikinger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in network-manager-applet.

Changed in dillo:
status: New → Invalid
Marlin Forbes (datashaman) wrote :

I second this wish. In our country running multiple internet connections is useful since we are capped on international access, but have cheap local access. I often run a PPPoE connection over my WLAN connection for local updates, mail delivery etc.
It should be a simple thing to add the WLAN interfaces into the drop down list as well.

Carolmtm (pichpich) wrote :

I'm having the same problem (and this kind of wireless connection is common also in Brazil) but I don't know how to use the pppoeconf to fix. (I tried but 'm very very very beginner user). Tell me how to do, please.

Gisli Ottarsson (gisli) wrote :

I also second.

I am a visitor in a home in Italy (Telecom Italia) where the name of the service is Alice ADSL.

I have a laptop and I was immediately connected to the household's WLAN but I would not get routed anywhere. As I have never experienced PPPoE, this was very mysterious to me. Information on the Telecome Italia website suggested that the connection was PPP related caused me to look at the Point to Point section of Network Manager, but only eth0 (the wired network) was offered as an option, which got me nowhere.

Only when I stumbled on this Ubuntu Bug, (thanks, original poster) did I try pppoeconf, after which everything was easy.

Small note for those having same problem:

1. Start the wlan connection.
2. Open a terminal and start pppoeconf. The tool will proceed to try all network interfaces and will likely be successful in making a connection over the wireless interface. I simply accepted all defaults (except in my case I did not want to make this a permanent connection at boot).

Please try to enhance Network Manager such that this becomes more discoverable.

Alexander Sack (asac) wrote :

this is a design issue atm. upstream knows about it.

Changed in network-manager:
importance: Undecided → Wishlist
status: New → Triaged
Changed in network-manager-applet:
status: New → Triaged
Changed in network-manager:
status: Unknown → New
Changed in network-manager-applet:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

This is an enhancement request and not a blocker for jaunty, rejecting the nomination.

Changed in network-manager:
status: New → Invalid
Changed in network-manager-applet:
status: New → Invalid
Julian Alarcon (alarconj) wrote :

Please, someone with an account in gnome tracker can change the status.. ?? This bug is not a duplicate from http://bugzilla.gnome.org/show_bug.cgi?id=559134
Maybe that is a blocker to this one.. but they are not the same.

Alexander Sack (asac) on 2009-05-05
summary: - no wlan option for pppoe configuration
+ MASTER no wlan option for pppoe configuration
Julian Alarcon (alarconj) wrote :

According to Dan:

Yes, PPPoE should be more like a VPN connection and be layered on top the
existing wired or wifi connection. This should be possible in a future update
of NM.

Changed in network-manager-applet:
status: Invalid → Unknown
Changed in network-manager:
status: Invalid → Unknown
Changed in network-manager:
status: Unknown → Confirmed
Changed in network-manager-applet:
status: Unknown → Confirmed

Wouldn't it be easier to have PPPoE as a IP configuration protocol, like
DHCP or ZeroConf ?
No ISP need a IP binded directly to the interface used for PPPoE
service, anyway.
The PPPoE connection is usually the only one needed on the WAN in such
cases.

The downside is that the PPPoE is binded to a specific interface, wich
may be confusing for systems using more than one interface to connect (
eg laptops using either wired and wireless connection).

The Windows implementation will try to connect to a Access Concentrator
on all interfaces ( sending PADI packets ) and completing handshaking on
the first one responding.

A posible solution will be to have PPPoE configured on all needed
interfaces, and a common panel with the configuration details.

A further refinement could be to allow both PPPoE and DHCP to be tried.
May be useful to allow laptops automatic connection to ISPs using PPPoE
or to free hotspots.

Mihai

Julián Alarcón wrote:
> According to Dan:
>
> Yes, PPPoE should be more like a VPN connection and be layered on top the
> existing wired or wifi connection. This should be possible in a future update
> of NM.
>
> ** Changed in: network-manager-applet
> Status: Invalid => Unknown
>
> ** Changed in: network-manager-applet
> Remote watch: GNOME Bug Tracker #561798 => GNOME Bug Tracker #559134
>
> ** Changed in: network-manager
> Status: Invalid => Unknown
>
> ** Changed in: network-manager
> Remote watch: GNOME Bug Tracker #561798 => GNOME Bug Tracker #559134
>
>

Zerlgi Theree (zerlgi3) wrote :

Just adding my request as well to this list.

PPPoE over wireless devices is definitely needed in NetworkManager / nm-applet

Since it is possible via command line.

another example is a virtual wireless device as provided by the iburst driver
ibdriver.sourceforge.net. It uses the wireless stack so as to provide signal strength to network tools like Network manager, Kwifimanager, etc.
However nm-applet doesn't allow pppoe over wireless even when setting
/etc/NetworkManager/nm-settings.conf to "managed"

http://ubuntuforums.org/showthread.php?p=7900716#post7900716

David Fraser (davidf) wrote :

Note that https://bugzilla.redhat.com/show_bug.cgi?id=446338 is another upstream bug with more recent information

Changed in network-manager:
importance: Unknown → Wishlist
Changed in network-manager-applet:
importance: Unknown → Wishlist
MaksimKa (netvin) wrote :

This feature is very usefull for me too.

Dražen Lučanin (kermit666) wrote :

Also a common network architecture in Croatia.

Currently, I have to use external programs (like pppoeconf) to get a working internet connection at some places. This causes problems because after setting up pppoeconf, NM stops working. It seems that both NM and pppoeconf edit the same conf files, but are not really consistent with each other.

Zerlgi Theree (zerlgi3) wrote :

If it is fedora: /etc/sysconfig/networ..... files get edited
if it is ubuntu /etc/network/interfaces gets edited

To get past that change the following line in
/etc/NetworkManager/nm-system-settings.conf

[ifupdown]
managed=false

from managed=false to managed=true.

2010/12/24 Dražen Lučanin <email address hidden>

> Also a common network architecture in Croatia.
>
> Currently, I have to use external programs (like pppoeconf) to get a
> working internet connection at some places. This causes problems because
> after setting up pppoeconf, NM stops working. It seems that both NM and
> pppoeconf edit the same conf files, but are not really consistent with
> each other.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/232172
>
> Title:
> MASTER no wlan option for pppoe configuration
>

--
There are two rules for success in life:
Rule 1: Don't tell people everything you know.

Dražen Lučanin (kermit666) wrote :

Thanks :)

Still, I think that this functionality should be an integral part of NM one day.

Zerlgi Theree (zerlgi3) wrote :

2010/12/27 Dražen Lučanin <email address hidden>

> Thanks :)
>
> Still, I think that this functionality should be an integral part of NM
> one day.
>
> absolutely.

Dražen Lučanin (kermit666) wrote :

Bump.

Two years later and I still have to struggle with setting up a PPP connection in Ubuntu. Is there any chance this might get fixed one day? It can be done very easily through a GUI in OS X and Windows, but in Ubuntu I have to go through the same *setup_using_pppoeconf-break_other_connections-happen_uppon_this_old_hack* loop every time I have to set up someboy's computer on this kind of access network.

I mean, I know this is a corner case, but it still counts towards building an image for Ubuntu. If you're trying to impress somebody to become a new user and he sees you have to do some terminal mumble-jumble to set up his/her net connection, it definitely doesn't seem as nice as simply doing 3 clicks in a GUI.

Surely it wouldn't be a big patch for somebody who has some insights about the inner workings of Network manager.

Cheers for nm stability other than that! This is the only major bug I noticed :)

Dražen

Dražen Lučanin (kermit666) wrote :

Still no answer? Isn't somebody maintaining network-manager monitoring these comments? Because there isn't a stable, supported method to establish a PPPoW connection in Ubuntu, I am unable to use it at all in certain locations, which is making my work difficult as Ubuntu is my main OS. Also, as I am trying to popularize Ubuntu with other people, I have to cope with pppd and its quirks on their machines as well.

pppd is behaving very unstable on my main laptop, breaking the ppp connection every couple of minutes and freezing, making me do this way too often:

sudo poff -a
sudo kill -9 `pidof pppd gpppon`
sudo /etc/init.d/networking restart
sudo restart network-manager

(otherwise I can't reestablish the connection and even like this I have to wait for some time for DNS to start treating me nicely again)

It's not up to the network, as on the same machine on OS X it works smoothly.

Having a functional internet connection is an **essential** part of an OS. I really think that one road to connecting to the internet shouldn't be marked as a "whishlist" for 4 years, basically making it unsupported and left to end users to meddle with low-level tools that are hard to understand. The process of controlling this daemon, redialing if it's not working etc. is something that (at least in my eyes) falls in the domain of network-manager.

I hope this will grab somebody's attention and help in advancing the bug past the whishlist state. If this starts making way towards a new feature, I'd be more than happy to test it and provide feedback.

Cheers,
Dražen

Dražen Lučanin (kermit666) wrote :

If it can maybe help anybody point me in the right direction, here are todays logs from my machine filtered using the "ppp" term.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.