label escaping warnings

Bug #1848186 reported by Sebastien Bacher on 2019-10-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact

When connecting to some access points warnings are printed in the log due to incorrect handling of special chars

* Test case
Connect to an AP with a '&' in its name, no warning should be displayed

* Regression potential
The code changes is the one building the label of APs, check that those are properly named in the applet

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Low
status: New → Fix Released

Hello Sebastien, or anyone else affected,

Accepted network-manager-applet into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.8.10-2ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager-applet (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
shasheene (shasheene) wrote :

I have no interest in this issue, but I have great interest in another fix within 1.8.10-2ubuntu3 bionic-proposed release, so I have verified this issue has been fixed.

Reproduction involved launching nm-applet, attempting to connect to an AP with & in the name and seeing the following get written to stdout:

> (nm-applet:2164): Gtk-WARNING **: 02:38:16.256: Failed to set text 'REDACTED&' from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &

Then bionic-proposed network-manager-gnome was installed, and the steps repeated. Now no error message gets printed.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: removed: verification-needed

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.8.10-2ubuntu3

---------------
network-manager-applet (1.8.10-2ubuntu3) bionic; urgency=medium

  * debian/patches/git_error_handling.patch:
    - don't segfault when gnome-keyring is missing (lp: #1806269)
  * debian/patches/git_editor_segfault.patch:
    - backport a segfault fix for the editor (lp: #1848185)
  * debian/patches/git_label_warning.patch:
    - backport fix for parsing error warnings being displayed when
      connecting to an ap with special chars (lp: #1848186)

 -- Sebastien Bacher <email address hidden> Tue, 15 Oct 2019 10:50:14 +0200

Changed in network-manager-applet (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers