Filenames with spaces not accepted when connecting to certificate-authenticated wifi

Bug #1807460 reported by Michael T on 2018-12-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
Using an authentification certificate with a filename in its name is not possible

* Test case
- connect to a wpa wifi needing a certificate
- name the certificate to include a space
- try to use that said certificate

it should be possible to use it

* Regression potential
the change is on the function dealing with the filename/uri for certificate, make sure those keep working on different locations with names including spaces or not

*******************

This bug was encountered on a fresh install of Ubuntu 18.04.1 LTS

When connecting to a certificate-authenticated wifi network (WPA/WPA2 Enterprise, authentication TLS) for the first time, the "Wi-Fi Network Authentication Required" dialogue is displayed, prompting the user to select their CA and user certificates.

Unexpected behaviour: If any of the files have spaces in their filenames, after choosing them in the file picker the field is highlighted by a red box, and the 'Connect' button is greyed out.

This is depicted in the attachment network-authentication-red-box-spaces-filename.png

There is also no explanation offered for why the red box highlight is present - no tooltip, no help from pressing F1, no popup, and as far as I can find no logs.

If you move/rename the file, so there are no spaces in the filename, the problem is worked around.

The problem is not present on the edit connection dialogue; filenames with spaces are acceptable there.

The problem was also not present on Ubuntu 16.04, and users who upgrade from 16.04 to 18.04 will find their connection keeps working. It is only when creating an entirely new connection (or after forgetting the connection and recreating it) that the problem dialog appears.

Michael T (michaeltandy) wrote :

Adding wpa2-tls-root-cert-no-spaces.png which shows settings are acceptable, the red box disappears and the connect button becomes available when file is renamed to remove spaces.

Michael T (michaeltandy) wrote :

Added spaces-fine-in-connection-edit-window.png showing that the edit connection window will accept spaces in filenames.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, there were some fixes around escaping upstream but unsure that specific issue is fixed (e.g https://gitlab.gnome.org/GNOME/network-manager-applet/commit/2a65e932)

affects: gnome-control-center (Ubuntu) → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
importance: Undecided → Critical
importance: Critical → Low
Sebastien Bacher (seb128) wrote :

The bug is fixed in 1.8.18 which is in cosmic/disco, let's SRU that to bionic

Changed in network-manager-applet (Ubuntu):
status: New → Fix Released
Brian Murray (brian-murray) wrote :

While the issue seems straight forward to recreate from the description the bug is still missing Regression Potential information which is required for the SRU process.

Changed in network-manager-applet (Ubuntu Bionic):
status: New → Incomplete
Michael T (michaeltandy) wrote :

Howdy! Apologies for the slow response.

I downloaded and installed the .deb files from #5 and found that it fixed the problem where I couldn't connect to the network.

Although the changed files fix the most important problem, filenames are still displayed URL-encoded in the applet window after a file with spaces is selected, as the attached screenshot shows.

Sebastien Bacher (seb128) wrote :

@Brian, description updated

Changed in network-manager-applet (Ubuntu Bionic):
status: Incomplete → Fix Committed
description: updated

Hello Michael, or anyone else affected,

Accepted network-manager-applet into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.8.10-2ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

@Michael, thx for testing, looks like the fix could be improved but if the functional issue is resolved it should be good enough as a first iteration

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers