.xsession-errors filled with entries

Bug #1755305 reported by Brian on 2018-03-12
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

I hope I am in the right place for this. My .xsession-errors file is filled with entries in the following format, in that order/sequence, over and over and continuously:

(nm-applet:1839): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:1839): Gtk-CRITICAL **: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:1839): Gtk-WARNING **: Can't set a parent on widget which has a parent

Ubuntu MATE 17.10

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Brian (thwaller) wrote :

I can understand how this may seem like nothing of concern to the devs / maintainers, but when you end up with log files of 15-20MB, and nearly all of it is due to this, it is problemsome. There is no need to see this a handful of times each minute as it just interferes with the actual intention of the xsession-errors file.

Khurshid Alam (khurshid-alam) wrote :

Please report it to upstream.

Brian (thwaller) wrote :

I do not know what that means.

Claudiux (claudiux) wrote :

This kind of message floods the .xsession-errors file:

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.839: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.839: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:12.847: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.852: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.852: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:12.857: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.939: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:12.939: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:12.947: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:14.977: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:14.977: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:14.989: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:15.003: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:15.003: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:15.015: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:15.035: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:15.036: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:15.042: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.454: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.454: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:34.461: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.473: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.473: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:34.480: Can't set a parent on widget which has a parent

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.496: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-CRITICAL **: 16:32:34.496: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:2661): Gtk-WARNING **: 16:32:34.502: Can't set a parent on widget which has a parent

Brian (thwaller) wrote :

@ Claudiux (claudiux) - If your comment was for me, I know the issue. I should be more clear, I do not know what this means, or how to do it:

> Khurshid Alam (khurshid-alam)
> Please report it to upstream.

However, it this particular issue still present in 18.04 or 18.10?

Brian (thwaller) wrote :

I can confirm the issue is still there on 18.04 as I am currently running 18.04.1 LTS (Bionic Beaver) 64-bit. I do not use 18.10, so I comment on that.

Gabor (gabor-z) wrote :

18.04.1 LTS (Bionic Beaver) 64-bit
Confirm

The first thing I did is to install unity-desktop (not sure the problem existed earlier)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers