[SRU]nm-applet not show wwan options on menu after logout/in

Bug #1651019 reported by Alex Tu on 2016-12-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Medium
OEM Priority Project
Status tracked in Xenial
Xenial
High
Aron Xu
network-manager-applet (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

[Impact]

With DW5811e(EM7455), mobile data connection not show on nm indicator after logout -> login.

packages which be used:
network-manager: network-manager_1.2.2-0ubuntu0.16.04.3_amd64
nm-applet: network-manager-gnome_1.2.0-0ubuntu0.16.04.4_amd64

Steps to reproduce:
1. boot device with 4G sim card + DW5811e(EM7455) wwan card
2. check nm-applet indicator then "Mobile Braodband" could be found in menu in normal cases.
3. logout then login
4. check nm-applet indicator then "Mobile Braodband" not shows in menu anymore.
5. but still could connect to wwan by nmcli, so looks device and networkmanager work fine.

[Test Case]

After upgrading to 1.2.6, using the previous "Steps to reproduce" should not be able to reproduce the bug any more

[Regression Potential]

Potential of causing regression is minimal as upstream fixes aren't significant enough.

Alex Tu (alextu) on 2016-12-19
summary: - nm-applet not show wwan options on menu after logout/int
+ nm-applet not show wwan options on menu after logout/in
Sebastien Bacher (seb128) wrote :

Upstream is having a branch that should fix the issue, you might want to give it a try?

Changed in network-manager-applet (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → Fix Released
Kent Lin (kent-jclin) on 2017-01-09
Changed in oem-priority:
importance: Undecided → High
Kent Lin (kent-jclin) wrote :

The issue is fixed in network-manager upstream bug status, the solution was be merged to nm-applet, ver 1.2.

cherry-peak the patches to ubuntu's nm-applet package and it works.

Need to include those fix to Ubuntu's nm-applet package

Aron Xu (happyaron) on 2017-01-12
summary: - nm-applet not show wwan options on menu after logout/in
+ [SRU]nm-applet not show wwan options on menu after logout/in
description: updated
Jeremy Bicha (jbicha) on 2017-01-18
Changed in network-manager-applet (Ubuntu Yakkety):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
Changed in network-manager-applet (Ubuntu Yakkety):
status: New → In Progress
Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.4.2-1ubuntu2

---------------
network-manager-applet (1.4.2-1ubuntu2) zesty; urgency=medium

  * Add patches for wwan options after logout/in (LP: #1651019):
     - device-broadband-use-define-for-devinfo-tag.patch
     - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
     - device-broadband-check-that-the-ModemManager-is-actu.patch
  * debian/rules: allow parallel building

 -- Aron Xu <email address hidden> Fri, 13 Jan 2017 17:32:28 +0800

Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Fix Released

Hello Alex, or anyone else affected,

Accepted network-manager-applet into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in oem-priority:
assignee: nobody → Alex Tu (alextu)
Alex Tu (alextu) wrote :

verified the proposed package in #5, it passed, mobile connection option still there after logout-> login.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu1

---------------
network-manager-applet (1.2.6-0ubuntu1) yakkety; urgency=medium

  * Rebase to upstream 1.2.6 release (LP: #1619354)
  * Refreshed patches. Merged upstream and dropped:
    - applet-fix-handling-of-802.1x-secrets-for-ethernet-c.patch
  * Add patches to fix showing wwan option after logout/in (LP: #1651019)
   - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
   - device-broadband-check-that-the-ModemManager-is-actu.patch
   - device-broadband-use-define-for-devinfo-tag.patch

 -- Aron Xu <email address hidden> Thu, 12 Jan 2017 19:18:13 +0800

Changed in network-manager-applet (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Alex, or anyone else affected,

Accepted network-manager-applet into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Alex Tu (alextu) wrote :

verified passed on xenial as well just like #6.

tags: added: verification-done
tags: removed: verification-needed
Changed in oem-priority:
status: New → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu0.16.04.1

---------------
network-manager-applet (1.2.6-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream bug fix release (LP: #1619354)
    - Import upstream release 1.2.6, bump n-m version to >= 1.2
    - Update VCS-* link to the current one
  * Update patches tracking yakkety, rename due to git-pq:
    - position_dialogs_to_center_of_the_screen.patch
      => Always-center-dialogs-on-the-screen.patch
    - make_menu_items_insensitive_based_on_permissions.patch
      => Make-sure-the-behavior-for-policykit-restricted-acti.patch
    - hide_policy_items_env_var.patch
      => Implement-support-for-hiding-rather-than-desensitizi.patch
    - applet_adhoc_use_wpa_rsn_part1.patch
      => Allow-to-create-and-connect-to-Ad-Hoc-RSN-networks.patch
    - indicator-by-default.patch
      => Have-the-appindicator-enabled-by-default.patch
    - ubuntu-vpn-icon-name.patch
      => On-Ubuntu-we-use-premade-icons-for-the-indicator-VPN.patch
    - lp1579246_fix_handling_8021x_secrets_for_eth.patch => dropped
    - wireless-security-fix-failed-assertion-in-default_fi.patch => dropped
    - wireless-security-return-error-on-eap_method_validat.patch => dropped
    - applet-remove-assert-s_con-from-applet_get_active_vp.patch => dropped
    - apple-set-out_icon_name-for-WWAN-connections-for-ind.patch => dropped
  * Add patches showing wwan options after logout/in (LP: #1651019):
    - device-broadband-use-define-for-devinfo-tag.patch
    - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
    - device-broadband-check-that-the-ModemManager-is-actu.patch

 -- Aron Xu <email address hidden> Thu, 12 Jan 2017 19:52:56 +0800

Changed in network-manager-applet (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.