[SRU] Upgrade network-manager-applet to latest point release

Bug #1619354 reported by Aron Xu on 2016-09-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Aron Xu
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

[Impact]

Several defects in network-manager-applet can lead to crashes under certain circumstance as tracked in errors.ubuntu.com, upstream stable bug fix release 1.2.6 should fix a big portion of the bugs while no feature is being added or changed.

[Test Case]

After upgrading to 1.2.6, crash cases should be lesser than previous, and no functional regression should be observed.

[Regression Potential]

Potential of causing regression is minimal as upstream fixes aren't significant in this small package during the stable branch maintenance.

Aron Xu (happyaron) on 2016-09-01
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
summary: - [SRU]network-manager-applet
+ [SRU] network-manager-applet 1.2.4
tags: added: xenial
summary: - [SRU] network-manager-applet 1.2.4
+ [SRU] network-manager-applet 1.2.4 in Xenial
Aron Xu (happyaron) on 2016-12-16
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → High
status: Confirmed → Triaged
description: updated
summary: - [SRU] network-manager-applet 1.2.4 in Xenial
+ [SRU] network-manager-applet
description: updated
tags: added: yakkety
Sebastien Bacher (seb128) wrote :

Thanks for the work, some comments:

- your did changes to debian/rules (and to debian/copyright in xenial), those need to be described in the changelog so the SRU team know that they are wanted and not an error

- is bug #1651019 fixed in zesty? SRU rules mandate that it should be fixed in the current serie first, so either we need an upload there or a comment on the bug stating that it's fixed and close the non-distro-specific line on the bug

- those launchpad bugs look like they are fixed in the new version and it might be good to list them in the changelog, it would give some extra testcase and testing for the update
bug #1570738 (or bug #1597151 from e.u.c which seems the same) and bug #776384

The xenial update is a bit less trivial due to the renames but I guess it makes maintainance work either over time so it's worth doing right?

Aron Xu (happyaron) wrote :

- d/rules: updated in changelog

- bug #1651019, for zesty there's a branch needs sponsor as well:
  https://code.launchpad.net/~network-manager/network-manager/+git/ubuntu-applet/+ref/master

- for #1597151 I think it's harmless to ignore since they got verified in yakkety for quite some time...

As for the rename, they would make diffs between yakkety and xenial trivial thus I believe it's worthwhile.

Jeremy Bicha (jbicha) on 2017-01-18
no longer affects: network-manager-applet (Ubuntu Zesty)
Changed in network-manager-applet (Ubuntu Yakkety):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu Xenial):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) wrote :

Thank you Aron.

I uploaded for you to xenial, yakkety and zesty.

I made one change: I reverted the parallel building. Although it probably would not have caused any issues, changing the way the package builds is generally not wanted in SRUs unless it's needed to fix a bug. But it's fine for zesty. (By the way debhelper compat 10 includes --parallel automatically.)

Changed in network-manager-applet (Ubuntu Xenial):
status: New → In Progress
Changed in network-manager-applet (Ubuntu Yakkety):
status: New → In Progress
Jeremy Bicha (jbicha) wrote :

I unsubscribed ~ubuntu-sponsors. Feel free to resubscribe if something else needs to be sponsored.

Hello Aron, or anyone else affected,

Accepted network-manager-applet into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed

@Brian, I wonder why only the upload to yakkety is accepted from queue, but not the xenial upload (still in "Unapproved")?

Amr Ibrahim (amribrahim1987) wrote :

Parallel building is allowed in network-manager (1.2.6-0ubuntu0.16.04.1) in Xenial Unapproved queue.

summary: - [SRU] network-manager-applet
+ [SRU] Upgrade network-manager-applet to latest point release
tags: added: upgrade-software-version
Aron Xu (happyaron) wrote :

I've verified this nm-applet works for yakkety, also when combined with 1.2.6 update of network-manger itself.

@amribrahim1987, I don't think allowing paralleling would be a very big deal that blocks this very wanted update, it only affects the building process but not the binaries. Would you mind re-consider accepting it?

tags: added: verification-done-yakkety
Jeremy Bicha (jbicha) on 2017-02-15
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu1

---------------
network-manager-applet (1.2.6-0ubuntu1) yakkety; urgency=medium

  * Rebase to upstream 1.2.6 release (LP: #1619354)
  * Refreshed patches. Merged upstream and dropped:
    - applet-fix-handling-of-802.1x-secrets-for-ethernet-c.patch
  * Add patches to fix showing wwan option after logout/in (LP: #1651019)
   - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
   - device-broadband-check-that-the-ModemManager-is-actu.patch
   - device-broadband-use-define-for-devinfo-tag.patch

 -- Aron Xu <email address hidden> Thu, 12 Jan 2017 19:18:13 +0800

Changed in network-manager-applet (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Brian Murray (brian-murray) wrote :

The Xenial upload has a bug number typo'ed in the changelog.

"Add patches showing wwan options after logout/in (LP: #165019)"

That's missing a 1 i.e. 1651019.

Hello Aron, or anyone else affected,

Accepted network-manager-applet into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Felipe Reyes (freyes) on 2017-02-20
tags: added: sts
Aron Xu (happyaron) wrote :

I've been running this version for several days, and went through the network-manager verification test cases I can conduct without seeing regression. Hence tagging verification-done-xenial.

tags: added: verification-done-xenial
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu0.16.04.1

---------------
network-manager-applet (1.2.6-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream bug fix release (LP: #1619354)
    - Import upstream release 1.2.6, bump n-m version to >= 1.2
    - Update VCS-* link to the current one
  * Update patches tracking yakkety, rename due to git-pq:
    - position_dialogs_to_center_of_the_screen.patch
      => Always-center-dialogs-on-the-screen.patch
    - make_menu_items_insensitive_based_on_permissions.patch
      => Make-sure-the-behavior-for-policykit-restricted-acti.patch
    - hide_policy_items_env_var.patch
      => Implement-support-for-hiding-rather-than-desensitizi.patch
    - applet_adhoc_use_wpa_rsn_part1.patch
      => Allow-to-create-and-connect-to-Ad-Hoc-RSN-networks.patch
    - indicator-by-default.patch
      => Have-the-appindicator-enabled-by-default.patch
    - ubuntu-vpn-icon-name.patch
      => On-Ubuntu-we-use-premade-icons-for-the-indicator-VPN.patch
    - lp1579246_fix_handling_8021x_secrets_for_eth.patch => dropped
    - wireless-security-fix-failed-assertion-in-default_fi.patch => dropped
    - wireless-security-return-error-on-eap_method_validat.patch => dropped
    - applet-remove-assert-s_con-from-applet_get_active_vp.patch => dropped
    - apple-set-out_icon_name-for-WWAN-connections-for-ind.patch => dropped
  * Add patches showing wwan options after logout/in (LP: #1651019):
    - device-broadband-use-define-for-devinfo-tag.patch
    - applet-re-add-broadband-devices-when-MM-becomes-avai.patch
    - device-broadband-check-that-the-ModemManager-is-actu.patch

 -- Aron Xu <email address hidden> Thu, 12 Jan 2017 19:52:56 +0800

Changed in network-manager-applet (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers