Connect to Hidden Wi-Fi Network, "Connect" grayed out

Bug #1542733 reported by bathynomusBLUE on 2016-02-06
284
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Confirmed
Medium
network-manager-applet (Ubuntu)
High
Unassigned

Bug Description

Reproduce:
1. Create a static, connection to hidden Wi-Fi connection using nm-connection-editor

2. click nm-applet icon
click "Connect to Hidden Wi-Fi Network"
click pre-existing connection
"Connect" is grayed out

Work around is using terminal.
nmcli c up id <WiFiSSID>

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: network-manager 1.0.4-0ubuntu9
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Feb 6 15:58:22 2016
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2016-02-06 (0 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160206)
IpRoute:
 default via 192.168.0.1 dev wlp2s0 proto static metric 600
 169.254.0.0/16 dev wlp2s0 scope link metric 1000
 192.168.0.0/24 dev wlp2s0 proto kernel scope link src 192.168.0.55 metric 600
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT AUTOCONNECT-PRIORITY READONLY DBUS-PATH ACTIVE DEVICE STATE ACTIVE-PATH
 Wired connection 1 7c22db8e-2026-413b-86cd-0c796f177dd5 802-3-ethernet 1454790964 Sat 06 Feb 2016 02:36:04 PM CST yes 0 no /org/freedesktop/NetworkManager/Settings/1 no -- -- --
 jjjGFQQZi0U43GQNlkbUFr0j8ZXA2A d57103a5-d3d7-4fb0-a2a0-469894e184ab 802-11-wireless 1454795858 Sat 06 Feb 2016 03:57:38 PM CST yes 0 no /org/freedesktop/NetworkManager/Settings/0 yes wlp2s0 activated /org/freedesktop/NetworkManager/ActiveConnection/4
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlp2s0 wifi connected /org/freedesktop/NetworkManager/Devices/1 jjjGFQQZi0U43GQNlkbUFr0j8ZXA2A d57103a5-d3d7-4fb0-a2a0-469894e184ab /org/freedesktop/NetworkManager/ActiveConnection/4
 enp1s0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/2 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

bathynomusBLUE (bathynomusblue) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
importance: Undecided → High

I'm also affected by this bug.

Started happening just after update to xenial.

Before that, I never had 'connect' button grayed out.

ian (ianjw1) wrote :

I'm also affected by this bug. After some (approx 5/6) disconnects and re-connects to wifi no problems but then later the wifi network name is not shown in network-manager applet. If I opt to connect to hidden network then the network name is available from the dropdown but after that is selected then the connect button is greyed out.

Ubuntu Mate 16.04 clean install i.e not an upgrade. Acer Aspire laptop. This same laptop was running Linux Mint Mate (on Ubuntu Precise base) and it did not have this problem.
I can run these as a manual workaround:

sudo killall nm-applet
sudo service network-manager stop
sudo service network-manager start
sudo nohup nm-applet -9

I also have a desktop running Linux Mint 14 Mate (Ubuntu base not Debian) which does not have this problem.

Manthis (manthis) wrote :

Unable to connect to any hidden network on Ubuntu 16.04. Workaround does not work either.

Jason Pell (jason-pellcorp) wrote :

Manthis, there are two workarounds available. The nmcli definately works, but you need to know your SSID, for instance I have a SSID for my phone access point which I can manually connect to when I encounter this issue:

nmcli c up id ThomasAp

florin (florin-arjocu) wrote :

There is another connected bug, not only for hidden wifi, but also for regular wifi connections, they simply don't appear in the applet list and the system does not auto connect as it should do.

This workaround I found yesterday works:

`sudo iwlist wlan0 scan`

where `wlan0` is the name of your wireless interface.

Doing this all wifi networks are back there and the system auto connects.

Glenn Moloney (g-moloney) wrote :

Hi there. Is there any updates on this bug or if there's an updated package is there anyway we can test / help? Cheers.

akhalfan (akhalfan) wrote :

is there any update regarding this bug ?I also get the same thing, and I work around it by deleting the connection and re-creating it.

Isn't this supposed to be nm-applet instead of nm itself?

smostafa (smaznet) wrote :

My problem solved by disable show username on topbar from system setting>user acconts

Glenn Moloney (g-moloney) wrote :

My show Username under Accounts isn't enabled or whether I tick / untick the fault still persists. It's when you try to connect to an existing hidden Wi-Fi network, the connect is always grayed out & never selectable.

Christopher (cwkeller) wrote :

This is the second major problem I've had with the Network Manager less than one year. Ubuntu again proving that it is not robust enough for the general public.

Anders Hall (a.hall) wrote :

Got this in 16.04 today, fully updated. Has happened in older releases as well.

Christopher (cwkeller) wrote :

Desc:
 Wifi connection being sporadically lost during period of inactivity. Resume is no problem, however.

 Initial error message: Oct 11 09:21:01 Ariadnex NetworkManager[727]: <warn> [1476170461.1053] supiface[0x2327590,wlan0]: connection disconnected (reason -4)

 Posted commands not working. Network manager showing connection active, even when not.

 Present workaround: ping localhost -i 9 -s 28 (60 seconds doesn't work)

hawran (hawran.diskuse) wrote :

Got the same problem in my Xubuntu, it is REALLY annoying.
What is the point of that "Connect to hidden wifi" then?

lsb_release -a:
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

uname -a:
Linux ... 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

dpkg -s network-manager-gnome:
Package: network-manager-gnome
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 2032
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Source: network-manager-applet
Version: 1.2.0-0ubuntu0.16.04.4

PS A tooltip over the dimmed "Connect" button reads as follows:
"Either a password is missing or the connection is invalid. In the latter case, you have to edit the connection with nm-connection-editor first."

What?

Charl le Roux (charl-leroux) wrote :

Confirmed this has been my most annoying bug.

lshw
*-network
                description: Wireless interface
                product: Wireless 7260
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:06:00.0
                logical name: wlp6s0
                version: 6b
                serial: e8:2a:ea:b3:75:72
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-53-generic firmware=17.352738.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
                resources: irq:35 memory:f7900000-f7901fff

lsb_release -a
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

uname -a
Linux hostname 4.4.0-53-generic #74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Micael Carvalho (mcoaky) wrote :

Same problem in a fresh install from yesterday (12/25/2016), and I fully updated the system by cable. This should be a high priority bug, and I doubt it would take more than 5 minutes of an experienced programmer to fix it, probably just a broken validation routine. It surprises me this bug is open for 6 months without even an assignment...

Christopher (cwkeller) wrote :

Agreed; having to open terminal every time I start up to enter this ping command is a rather primitive workaround (and this after 6 months): ping 91.189.89.115 -i 15 -s 28 .
The nmcli startup command does not always work successfully.

Glenn Moloney (g-moloney) wrote :

I just noticed today that on my Ubuntu 16.10 machine the problem doesn't exist... Might try installing the pre-release of 16.04.2 which has kernel 4.8 to see if that makes any difference. Or maybe installing the network manager from 16.10.

Glenn Moloney (g-moloney) wrote :

No change using kernel 4.8 for the up & coming 16.04.2 release. Has anyone tried installing the 16.10 network manager in 16.04? Can it be done?

Sebastien Bacher (seb128) wrote :

There is a similar report upstream on https://bugzilla.gnome.org/show_bug.cgi?id=772827 could be a good place to comment for those having the issue

affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Sebastien Bacher (seb128) wrote :

Could be the same as https://bugzilla.gnome.org/show_bug.cgi?id=597839 which should be fixed in newest versions (which are due as SRU update)

Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → Confirmed

A tooltip in this dialog says that the connection is invalid (either password or connection) on the connect button.

History:
I have booted from a 16.04.1 LTS Live CD and tried to connect to WLAN in order to save some data before installing.
In my case I typed a wrong password (due to wrong keybord layout). Then the network-manager asked me to enter the password again (I corrected it, but it was actually not saved despite of clicking on save -> this is a second bug?)

Problem:
Manually connecting to a hidden network brings up the dialog, but the dialog does not allow me to edit the password and editing in the connection view and trying again as suggested by the tooltip does not enable the connect button in this dialog.
Thus I was able to view and correct the password in the connection dialog, but I am still unable to connect.

even trying a "/etc/init.d/network-manager restart" at the command line didn't connect to WLAN.

Command line work around as mentioned above worked for me.
nmcli c up id <WiFiSSID>

But as configured the connection should be established automatically when the network is available -> See Bug #1407928 for that issue.

Christopher (cwkeller) wrote :

"There is a similar report upstream on https://bugzilla.gnome.org/show_bug.cgi?id=772827 could be a good place to comment for those having the issue" appears quite relevant; however workaround of changing password setting does not work for me (still pinging away).

Glenn Moloney (g-moloney) wrote :

From a layman's point of view, I don't understand if a newer network manager has fixed the issue in 16.10 (network-manager_1.2.4-0) which is short term release and the one that isn't working in 16.04 is a long term release I would have thought they would pushed this fix ASAP considering it's importance of the release??? Will mentioning this Gnome bugzilla help the situation? Just seems a strange situation to me. I myself are unsure how to go with this... I'm happy to create an account in bugzilla & mention this if it's going to help fix the bug.

Changed in network-manager-applet (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
Glenn Moloney (g-moloney) wrote :

Thank you Sebastien for assigning this to Aron to resolve!! Reading one of the URL's you supplied about the issue (https://bugzilla.gnome.org/show_bug.cgi?id=597839 ) where Beniamino Galvani has already created a patch / fix. Not being a developer is there any way we can test this patch that Beniamino created which may assist Aron if he can't look at the issue in the short term? Even directing to instructions on how to apply the patch? Was hoping to have the issue resolved before the 16.04.2 release scheduled this week. I realise this won't happen now but I'm sure most of us that have experienced the issue would like to have this issue fix this sooner rather than later. Cheers.

Frédéric Danis (fdanis) wrote :

I tested it building network-manager-applet packages with the 2 patches from Beniamino Galvani (https://bugzilla.gnome.org/show_bug.cgi?id=597839) and this fixed the problem.

Glenn Moloney (g-moloney) wrote :

Hi Frédéric. Thank you for applying both patches to confirm that it's fixed the issue! If possible are you able to assist on how you applied Beniamino's patches as I'd like to confirm as well?

Aron: How do we go about getting these patches applied into 16.04? Is more conformation required?

Frédéric Danis (fdanis) wrote :

Hello Glenn,

I did the following to create and install patched packets.

$ wget -O 0001-wifi-dialog-fix-enabling-of-Connect-button.patch https://bugzilla.gnome.org/attachment.cgi?id=328481
$ wget -O 0002-wifi-dialog-enable-Cancel-button-if-secrets-are-not-.patch https://bugzilla.gnome.org/attachment.cgi?id=328482
$ apt source network-manager-applet
$ cd network-manager-applet-1.2.0/
$ export QUILT_PATCHES=debian/patches
$ quilt import ../0001-wifi-dialog-fix-enabling-of-Connect-button.patch
$ quilt push
$ quilt import ../0002-wifi-dialog-enable-Cancel-button-if-secrets-are-not-.patch
$ quilt push
$ dch --newversion 1.2.0-0ubuntu0.16.04.4-test "Fix connection to hidden network"
$ debuild -us -uc -b
$ sudo dpkg -i ../*test*deb

You may have to reboot to test it.

Glenn Moloney (g-moloney) wrote :

Hi Frédéric,

Thank you for the clear instructions as from my point of view it's much appreciated!!

Unfortunately I've hit a hurdle with either an existing install or a fresh install of Ubuntu 16.04.1 with all the updates completed...

The first two commands in the terminal worked perfectly fine & saved the file in the home directory.

$ wget -O 0001-wifi-dialog-fix-enabling-of-Connect-button.patch https://bugzilla.gnome.org/attachment.cgi?id=328481
$ wget -O 0002-wifi-dialog-enable-Cancel-button-if-secrets-are-not-.patch https://bugzilla.gnome.org/attachment.cgi?id=328482

However the third command came back with the below response.

$ apt source network-manager-applet
Reading package lists... Done
E: You must put some 'source' URIs in your sources.list

And the forth.

$ cd network-manager-applet-1.2.0/
bash: cd: network-manager-applet-1.2.0/: No such file or directory

If possible are you able to confirm the third & forth commands or possible step that might have been missed.

If not or don't have any time to help I greatly appreciate your assistance & patients to date!!

Cheers Frédéric

Frédéric Danis (fdanis) wrote :

Hello Glenn,

First, you should add "Source code" repositories in "Software Sources", take a look at https://help.ubuntu.com/community/Repositories/Ubuntu

Then you should install all dependencies needed to build the network-manager-applet package:

$ sudo apt update
$ sudo apt build-dep network-manager-applet
$ sudo apt install quilt devscripts

The previous steps should now work.

Glenn Moloney (g-moloney) wrote :

Hi Frédéric,

On the fresh install I've enabled the "Source code" repository, installed the dependencies using the commands from #34 & followed the instructions from #32 & after a reboot the "Connect" button is no longer grayed out woo hoo!!

Mate thank you again for your help as for me it's an important bug for me to have resolved!!

I was hoping this would make it into the release 16.04.2 but after sending Aron a message with no response as yet it's not likely.

Hopefully if one of the developers has some time to apply this patch / fix this bug once & for all in the very near future so no one has to install the extra dependencies to make it work.

Cheers Frédéric.

Glenn Moloney (g-moloney) wrote :

Also confirmed above works on Ubuntu 16.04.2.

Cheers.

arrrghhh (arrrghhh-6) wrote :

Any updates for this on 16.10?

Can I use the above patches to fix the issue?

Thanks.

Glenn Moloney (g-moloney) wrote :

Hi Arrrghh,

Mate have a read comment #28 on this bug. Basically there's no issue on 16.10 only 16.04.

Cheers.

Christopher (cwkeller) wrote :

(16.04): in the meantime the connection is not greyed out, but this does not mean that one can reliably use this to connect. Generally I have to suspend, re-awake and then use 'nmcli c up id *' to connect. A poor man's workaround for a defect which has existed for some time now.

Glenn Moloney (g-moloney) wrote :

I've just done a fresh install today of 16.04.2 which has network manager version 1.2.2. Once the updates are completed the network manager has been upgraded to version 1.2.6. I can confirm that the "Connect" button when trying to connect to a Hidden Wireless network so no longer greyed out & the problem has been resolved! As Sebastien mentioned in comment #24 up & coming updates have been passed through & have resolved the issue.

Because of this I'd say the status of this bug will need to be changed to Fix Released & close this bug.

Cheers.

Christopher (cwkeller) wrote :

As written above this is not my experience. 16.04.1 with network-manager 1.26…16.04.1, network-manager 1.26…16.04.2, and network-manager-pptp* 1.1.93 .

By no means can this issue be considered resolved undr 16.04.1

jpascher (johann-pascher) wrote :

i am on version 16.04.2 and i also can conform that the problem is still present!

Aron Xu (happyaron) on 2017-04-29
Changed in network-manager-applet (Ubuntu):
assignee: Aron Xu (happyaron) → nobody
jpascher (johann-pascher) wrote :

I applied the following fix but it did not help!
--------------------------
Frédéric Danis (fdanis) wrote on 2017-02-12: #34
$ sudo apt update
$ sudo apt build-dep network-manager-applet
$ sudo apt install quilt devscripts
-------------------------

If Wifi is disconnected and connected again no way to connect again.

if i start nmtui in SSH terminal then it show me that there is a WIFI configured correctly. but if i open activate no entry for the wifi is shown to click on. Beside this no automatic reconnect takes place anyway as it does if i do the same with eth0. Command line work around as mentioned above also dont works.

nmcli c up id <WiFiSSID>

"Error: Connection activation failed: No suitable device found found for this connection."

jpascher (johann-pascher) wrote :

root@myboard:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 32:57:92:08:e1:51
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2620 (2.6 KB) TX bytes:0 (0.0 B)

mahmoh (mahmoh) wrote :

I can also confirm that this problem has been resolved for me as of a couple of weeks ago, I've been running 16.04 for a year now with this problem and using the nm-cli work-around until now:

network-manager 1.2.6-0ubuntu0.16.04.1

Glenn Moloney (g-moloney) wrote :

Just to confirm, for me the problem is fixed if you have downloaded the latest ISO version 16.04.2, installed the operating system, then once installed you MUST manually run the Software Updater & do all the updates & reboot. Unfortunately ticking the box during the installation to say do the updates during the install isn't enough!! You'll find then that the Hidden Wireless Network isn't greyed out.

It's just a shame the update wasn't applied before the 16.04.2 ISO release because at the moment if you install & don't do the full updates you will have the problem. It's annoying too because during the installation of the operating system if you've connected to your Wifi then reboot, it will be greyed out because you haven't had the chance to run the software updater ... When that happens to save time I click on the network connections applet & select edit network connections, then under Wifi delete my initial Wifi connection I made during the install, close it & make a new connection to my Wifi & do all the updates via Software Updater.

This will be fixed by the time 16.04.3 is released but that's a while down track which is why I was hoping the patch was done before 16.04.2 ISO was released but it just missed out...

The only thing I don't know is what Christopher rightly mentioned on #43 is if you installed Ubuntu from either ISO version 16.04 or 16.04.1 & you have done all the updates if the problem is fixed.. For me I only install Ubuntu LTE version from .2 onwards because it has the rolling kernel release for newer hardware (HWE) which I prefer personally but if people choose to use the fixed linux kernel version 4.4 which is under either ISO version 16.04 or 16.04.1 then thats fine but someone will need to test.
I've done at least half a dozen machines using the 16.04.2 ISO & using the procedure above it's fine but as mentioned just annoying.. Sorry for the long comment..

Christopher (cwkeller) wrote :

Under 16.04.01 I have not experienced this error for about 10 days now. If it should reoccur will post.
Christopher

Christopher (cwkeller) wrote :

Under 16.04.01 still no further error as of 15. May 2017, so I assume updates have resolved the problem.
Christopher

Leonid Kostrykin (void-evoid) wrote :

I'm on 16.04, I have all latest updates installed, and the "Connect" button is still grayed out.

KennethOnah (onah-kenneth) wrote :

I am on 16.04, fresh install with all the latest updated, and the "Connect" button is grey out when I tried to connect to a hidden network.

Christopher (cwkeller) wrote :

Problem still exists, losing connection nearly once a session, 'nmcli c up id __' works after I suspend and re-awake, otherwise as a rule not (this on Lenovo x61, on Lenovo x200 'nmcli c up id __' always works). Poor man's solution for how many years now?

mahmoh (mahmoh) wrote :

Hi Christopher, have you tried to test and see if either your router or laptop wifi hardware are having problems? Your symptom above doesn't appear to be related to this problem, which I'm no longer seeing from several months ago, and it actually sounds like you may be having hardware issues - just a though to help you. Cheers.

Christopher (cwkeller) wrote :

Hi Mahmoh,
thanks for the input. It is true that the 'greying out' problem I have not had since April/May 2017. I had considered hw problems, both laptops are not the newest, but still for both to have defects? Unfortunately I don't have a second router to see if the problem lies with my FritzBox 3270 (also not the newest), although it might be worth looking into.
Regards, Christopher

Zibri Soft (zibri-) wrote :

2018 and I still have this problem.
4.13.0-37-generic #42-Ubuntu SMP Wed Mar 7 14:13:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

It happens sometimes and the only way is to manually run

nmcli c up id Hotspot

why is ubuntu/netowrk-manager not updated with a fix?

P.S.
It happens always also after a suspend/resume.

Zibri Soft (zibri-) wrote :

I forgot: that was on Ubuntu 17.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.