Ubuntu

Connection Information should display the name/IP of DHCP server

Reported by Oliver Gerlich on 2007-10-14
8
Affects Status Importance Assigned to Milestone
Network Manager Applet
New
Wishlist
network-manager-applet (Ubuntu)
Wishlist
Basilio Kublik

Bug Description

Binary package hint: network-manager-gnome

Wishlist item: when the system gets its IP through DHCP, the "Connection Information" dialog should also show the IP address (or the host name) of the DHCP server that gave the address. This information can help in cases where people have two DHCP servers on their net (so it can be seen exactly where the currently assigned IP address came from).

One way to get the DHCP server address is looking in /var/lib/dhcp3/dhclient.*.leases (pick the file for your currently-used network interface), then looking at the last dhcp-server-identifier entry in that file. During "support" in IRC channel, it's kinda fiddly to post a recipe for getting this information :-) while having it in the Connection Information dialog would make it easy to find and it would be in good company with the other "technical" information there.

Changed in network-manager-applet:
importance: Undecided → Wishlist
Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the current version of the application?, could you please try to reproduce this using the live environment of the Desktop CD of the development release - Hardy Heron.

Thanks in advance

Changed in network-manager-applet:
assignee: nobody → sourcercito
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in network-manager-applet:
status: Incomplete → Invalid

I still experience this problem when I have static configuration in g-s-t. Seemingly then NetworkManager thinks that it doesn't handle this connection and therefore it isn't active. Of course I can dig connection info from g-s-t, but it is two clicks versus approximately five plus entering password.

It is of course matter of integrating NM with g-s-t stuff, but it is still a bug - from user point of view, so I will change status to "New".

Changed in network-manager-applet:
status: Invalid → New
Oliver Gerlich (ogerlich) wrote :

I can confirm that there's apparently still no way to get information about the DHCP server in any GUI tool (I looked in nm-applet and in gnome-nettool).

Alexander Sack (asac) wrote :

please file this bug upstream against network-manager in bugzilla.gnome.org and give us the bug id. THanks!

Changed in network-manager-applet:
status: New → Triaged
Changed in network-manager-applet:
status: Unknown → New
Changed in network-manager-applet:
importance: Unknown → Wishlist
Thomas Hood (jdthood) wrote :

Marking invalid here since this sort of wish needs to be filed upstream. It has been filed upstream, so the wish doesn't need to be tracked here.

Changed in network-manager-applet (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.