gnome-flashback pptp vpn does not connect

Bug #1440009 reported by David Burrows on 2015-04-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Dmitry Shachnev

Bug Description

After some trial and error I have found that 3.14.0-3ubuntu8 and subsequent versions of gnome-flashback has introduced an error where connections to a PPTP vpn fail with the following error:

NetworkManager[5971]: <error> [1428023479.735160] [vpn-manager/nm-vpn-connection.c:1778] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

Downgrading to 3.14.0-3ubuntu7 resolves the issue.

I have reproduced this error by installing vivid into a virtualbox VM, and configuring a pptp vpn connection. It works if you use the default unity session, or the gnome one. Downgrading to gnome-flashback 3.14.0-3ubuntu7 resolves the issue.

I'm not going to bother attaching any further information unless asked, as I have narrowed it down to the specific update which has caused the regression and reproduced it on a fresh install.

Link to changelog for convenience: https://launchpad.net/ubuntu/+source/gnome-flashback/3.14.0-3ubuntu8

Related branches

Enabling end-session-dialog we started using org.gnome.Shell dbus name. As expected this is causing problems - in this case nm-applet detects that shell is running and does not register agent. shell_version_changed_cb is never called because gnome-flashback does not export ShellVersion and signal notify::shell-version is never emited.

After short testing looks like this is fixed in upstream 3.16.0 version where I am exporting shell version, but it is set to 0. Needed callback is called, version is too old and nm-applet registers agent.

1. One way could be to patch network-manager-applet. Check XDG_CURRENT_DESKTOP and if it contains GNOME-Flashback then do not create shell watcher.

applet.c:44224 - if (!shell_debug) -> if (!shell_debug && !gnome_flashback)

2. Patch gnome-flashback to export ShellVersion or add network agent based on gnome-shell.

Dmitry Shachnev (mitya57) wrote :

I think that second way will be the simplest for Vivid.

David, can you please test network-manager-applet package that I have just uploaded to ppa:mitya57/gnome-test?

David Burrows (snadge) wrote :

Tested the network-manager-applet packages in the above mentioned ppa:mitya57/gnome-test ppa. Restarted the session, and this seems to have resolved the issue.

Good job! And to think I was going to have a crack at fixing this myself. ;)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-flashback (Ubuntu):
status: New → Confirmed
affects: gnome-flashback (Ubuntu) → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.10.1-0ubuntu3

---------------
network-manager-applet (0.9.10.1-0ubuntu3) vivid; urgency=medium

  * Do not misdetect GNOME Flashback as GNOME Shell (LP: #1440009).
 -- Dmitry Shachnev <email address hidden> Tue, 07 Apr 2015 19:14:35 +0300

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers