Edit Connections...now insensitive by default in network manager's menu

Bug #1424119 reported by Serpico on 2015-02-21
144
This bug affects 27 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Seyeong Kim

Bug Description

[SRU justification]

[Impact]

grayed out on network-manager-applet, can't click

arno@arno-1000H:~$ lsb_release -rd
Description: Ubuntu 12.04.5 LTS
Release: 12.04
arno@arno-1000H:~$ apt-cache policy network-manager-gnome
network-manager-gnome:
  Installé : 0.9.4.1-0ubuntu2.4
  Candidat : 0.9.4.1-0ubuntu2.4
 Table de version :
 *** 0.9.4.1-0ubuntu2.4 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.9.4.1-0ubuntu2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4, the item Edit Connections... at the bottom of the network manager's menu is now insensitive i.e. grayed out, therefore user cannot configure his/her connections as indicated in http://docs.xubuntu.org/1204/internet-networks.html#network-connections

workaround : launch /usr/bin/nm-connection-editor to display the network connections window and have access to the settings.

[Test Case]
after updating network-manager-gnome on laptop, you can always see this problem.

[Regression Potential]

[Other Info]

Serpico (arnaud-abbal) on 2015-02-21
tags: added: precise
Serpico (arnaud-abbal) on 2015-02-21
tags: added: regression-update
tags: removed: regression-update
Seyeong Kim (xtrusia) wrote :

I tested with precise VM.

at first, it's deactivated, but soon(in a minute), it's been activated.

could you please test again? it's deactivated permanantly?

Serpico (arnaud-abbal) wrote :

Hi, thanks for checking.

The machine has been running the entire afternoon yesterday ( several hours ) without any change of behavior ( I checked several

times if I could access to Edit Connections... but couldn't ).

Tested again this morning, 30 minutes after the machine has been started up Edit Connections... is still grayed out.

Is there anything else you want me to test ?

Thanks again.

Guram Savinov (guram-savinov) wrote :

I confirm this bug on my laptop with Ubuntu 12.04.5: hidden menu item to change connections, but nm-connection-editor works.
This happened after restarting my laptop, that I didn't doing for a long time.
Developers: please check applet last updates, maybe it has a bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
bmomjian (bruce-momjian) wrote :

I can confirm that on reboot, the "Edit Connections" menu option is greyed out and unusable, but after 18 hours, it is white and works just fine.

Thanks.
When I uploaded the latest update yesterday (Ubuntu 12.04, user version
with Unity, Dell laptop), the Edit Connections menu item (previously
insensitive) worked. Now today, after re-booting, it has become insensitive
again. As you advise, I will leave the computer on and see what happens. I
will report back.

(\__/)
(='.'=) Best regards, Denham Pole
(")_(")

On Mon, Mar 2, 2015 at 2:13 AM, bmomjian <email address hidden> wrote:

> I can confirm that on reboot, the "Edit Connections" menu option is
> greyed out and unusable, but after 18 hours, it is white and works just
> fine.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1424119
>
> Title:
> Edit Connections...now insensitive by default in network manager's
> menu
>
> Status in network-manager-applet package in Ubuntu:
> Confirmed
>
> Bug description:
> arno@arno-1000H:~$ lsb_release -rd
> Description: Ubuntu 12.04.5 LTS
> Release: 12.04
> arno@arno-1000H:~$ apt-cache policy network-manager-gnome
> network-manager-gnome:
> Installé : 0.9.4.1-0ubuntu2.4
> Candidat : 0.9.4.1-0ubuntu2.4
> Table de version :
> *** 0.9.4.1-0ubuntu2.4 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main
> i386 Packages
> 100 /var/lib/dpkg/status
> 0.9.4.1-0ubuntu2 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
>
>
> Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4, the
> item Edit Connections... at the bottom of the network manager's menu is now
> insensitive i.e. grayed out, therefore user cannot configure his/her
> connections as indicated in
> http://docs.xubuntu.org/1204/internet-networks.html#network-connections
>
> workaround : launch /usr/bin/nm-connection-editor to display the
> network connections window and have access to the settings.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1424119/+subscriptions
>

Kyle Shannon (ksshannon) wrote :

This also appears to disable 'Disconnect' from various networks (I have 2 networks connected, and I need to switch between them). 'Edit Connections' is disable on my machine as well.

Denham Pole (drpole) wrote :

As promised, I report on the situation after 24hrs running the system
(3.5.0-59-generic) - the "Edit connections" menu item of the Network
Manager is still insensitive.

(\__/)
(='.'=) Best regards, Denham Pole
(")_(")

On Tue, Mar 3, 2015 at 3:57 AM, kyle <email address hidden> wrote:

> This also appears to disable 'Disconnect' from various networks (I have
> 2 networks connected, and I need to switch between them). 'Edit
> Connections' is disable on my machine as well.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1424119
>
> Title:
> Edit Connections...now insensitive by default in network manager's
> menu
>
> Status in network-manager-applet package in Ubuntu:
> Confirmed
>
> Bug description:
> arno@arno-1000H:~$ lsb_release -rd
> Description: Ubuntu 12.04.5 LTS
> Release: 12.04
> arno@arno-1000H:~$ apt-cache policy network-manager-gnome
> network-manager-gnome:
> Installé : 0.9.4.1-0ubuntu2.4
> Candidat : 0.9.4.1-0ubuntu2.4
> Table de version :
> *** 0.9.4.1-0ubuntu2.4 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main
> i386 Packages
> 100 /var/lib/dpkg/status
> 0.9.4.1-0ubuntu2 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
>
>
> Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4, the
> item Edit Connections... at the bottom of the network manager's menu is now
> insensitive i.e. grayed out, therefore user cannot configure his/her
> connections as indicated in
> http://docs.xubuntu.org/1204/internet-networks.html#network-connections
>
> workaround : launch /usr/bin/nm-connection-editor to display the
> network connections window and have access to the settings.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1424119/+subscriptions
>

I have the same problem, my initial search found this bug report:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1427800

The easiest temporary fix is to install the old network-manager-gnome 9.4.1-0ubuntu2.3 deb, luckily I don't have my mirrors auto clean. Here is a copy, I just had the i386 version:
http://open-sense.com/temp/network-manager-gnome_0.9.4.1-0ubuntu2.3_i386.deb

I wish they would keep at least one older version kept in the repository pools, but I googled the exact file name and found these for i386 and amd64. I haven't tried them but they should work:
https://launchpad.net/ubuntu/+source/network-manager-applet/0.9.4.1-0ubuntu2.3/+build/4503560/+files/network-manager-gnome_0.9.4.1-0ubuntu2.3_i386.deb
http://launchpadlibrarian.net/137742895/network-manager-gnome_0.9.4.1-0ubuntu2.3_amd64.deb

houstonbofh (leesharp) wrote :

I looked a while and could not find this bug before reporting mine. I would not have at all if Michael Pardee did not point it out. So I will include my report and work around from 142780.

On Ubuntu 12.04 only. (Does not happen on 14.04)

After upgrading the network-manager-gnome packages (includes libnm-gtk0 libnm-gtk-common) from 0.9.4.1-0ubuntu2.3 to 0.9.4.1-0ubuntu2.4 Disconnect, Edit and under VPN Connections Configure VPN and Disconnect VPN are greyed out and unelectable. You can no longer change passwords for VPN or WiFi, or define new static IP configurations.

As 0.9.4.1-0ubuntu2.3 is no longer available in the repos, I had to roll back to 0.9.4.1-0ubuntu2, which meant rolling back Unity Greeter as well. This was initially found on my desktop, but replicated in a VM I had with 0.9.4.1-0ubuntu2.3 still running. Going directly to 0.9.4.1-0ubuntu2.4 still gives the same problem.

This has also been reported on Ubuntu Forums. http://ubuntuforums.org/showthread.php?t=2266443

Pelatan (fcorsiglia) wrote :

I have found how to solve my problem of graying out for Network Manager " Edit Connections" on my Laptop : I place the Laptop on standby mode ( sleep mode), then I re-start it and "Edit Connections" line is sentitive again.....!

Denham Pole (drpole) wrote :

Yes, that works for me too (on a Dell laptop Inspiron-5537).
But interestingly, the WiFi connection doesn't work after waking from the
sleep mode (only the wired Ethernet connection).

This mode is called "Hibernate" in my system.

(\__/)
(='.'=) Best regards, Denham Pole
(")_(")

On Fri, Mar 6, 2015 at 7:11 PM, Pelatan <email address hidden> wrote:

> I have found how to solve my problem of graying out for Network Manager
> " Edit Connections" on my Laptop : I place the Laptop on standby mode (
> sleep mode), then I re-start it and "Edit Connections" line is sentitive
> again.....!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1424119
>
> Title:
> Edit Connections...now insensitive by default in network manager's
> menu
>
> Status in network-manager-applet package in Ubuntu:
> Confirmed
>
> Bug description:
> arno@arno-1000H:~$ lsb_release -rd
> Description: Ubuntu 12.04.5 LTS
> Release: 12.04
> arno@arno-1000H:~$ apt-cache policy network-manager-gnome
> network-manager-gnome:
> Installé : 0.9.4.1-0ubuntu2.4
> Candidat : 0.9.4.1-0ubuntu2.4
> Table de version :
> *** 0.9.4.1-0ubuntu2.4 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main
> i386 Packages
> 100 /var/lib/dpkg/status
> 0.9.4.1-0ubuntu2 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
>
>
> Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4, the
> item Edit Connections... at the bottom of the network manager's menu is now
> insensitive i.e. grayed out, therefore user cannot configure his/her
> connections as indicated in
> http://docs.xubuntu.org/1204/internet-networks.html#network-connections
>
> workaround : launch /usr/bin/nm-connection-editor to display the
> network connections window and have access to the settings.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1424119/+subscriptions
>

Denham Pole (drpole) wrote :

To add to my last message, switching "Networking" off then on again in the
Network Manager, started the WiFi connection.

(\__/)
(='.'=) Best regards, Denham Pole
(")_(")

On Fri, Mar 6, 2015 at 7:32 PM, Denham Pole <email address hidden> wrote:

> Yes, that works for me too (on a Dell laptop Inspiron-5537).
> But interestingly, the WiFi connection doesn't work after waking from the
> sleep mode (only the wired Ethernet connection).
>
> This mode is called "Hibernate" in my system.
>
> (\__/)
> (='.'=) Best regards, Denham Pole
> (")_(")
>
>
>
> On Fri, Mar 6, 2015 at 7:11 PM, Pelatan <email address hidden> wrote:
>
>> I have found how to solve my problem of graying out for Network Manager
>> " Edit Connections" on my Laptop : I place the Laptop on standby mode (
>> sleep mode), then I re-start it and "Edit Connections" line is sentitive
>> again.....!
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1424119
>>
>> Title:
>> Edit Connections...now insensitive by default in network manager's
>> menu
>>
>> Status in network-manager-applet package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> arno@arno-1000H:~$ lsb_release -rd
>> Description: Ubuntu 12.04.5 LTS
>> Release: 12.04
>> arno@arno-1000H:~$ apt-cache policy network-manager-gnome
>> network-manager-gnome:
>> Installé : 0.9.4.1-0ubuntu2.4
>> Candidat : 0.9.4.1-0ubuntu2.4
>> Table de version :
>> *** 0.9.4.1-0ubuntu2.4 0
>> 500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main
>> i386 Packages
>> 100 /var/lib/dpkg/status
>> 0.9.4.1-0ubuntu2 0
>> 500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386
>> Packages
>>
>>
>> Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4, the
>> item Edit Connections... at the bottom of the network manager's menu is now
>> insensitive i.e. grayed out, therefore user cannot configure his/her
>> connections as indicated in
>> http://docs.xubuntu.org/1204/internet-networks.html#network-connections
>>
>> workaround : launch /usr/bin/nm-connection-editor to display the
>> network connections window and have access to the settings.
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1424119/+subscriptions
>>
>
>

klamm2001 (klamm2001) wrote :

If I put my Lenovo L520 on standby the problem goes by, is this a permanent solution or if will return after reboot the machine?

houstonbofh (leesharp) wrote :

I suspect it is some kind of race condition on bootup, and suspend allows it to reset with the race resolved. But on each bootup, you will have to suspend, unsuspend, disable the wifi, re-enable the wifi...

Just roll back the packages. :)

Éric Piel (Delmic) (piel) wrote :

The changelog from 0.9.4.1-0ubuntu2.3 to 0.9.4.1-0ubuntu2.4 shows this new patch, which could be very well the culprit:
 * debian/patches/make_menu_items_insensitive_based_on_permissions.patch:
    - Provide a method to desensitize or hide menu items which are useless given
      the current policykit policy level of the user.

Maybe someone could try to remove it and see if that solves this bug?

Seyeong Kim (xtrusia) wrote :
description: updated
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Seyeong Kim (xtrusia)
status: Confirmed → In Progress
houstonbofh (leesharp) wrote :

Nice description, but it is also presnet in the 64 bit packages.

michael (taconic-research) wrote :

Yes, I too have both the "edit connections" and "disconnect" buttons greyed out.
Upgraded this week to 12.04 LTS, with all updates (levels 1-3) installed.
They were not greyed out before installing the recommended updates.

Must disconnect by un-checking "enable wireless" box.

Acer Aspire E3-111 laptop.

Chris J Arges (arges) wrote :

Sponsored after adding (LP: #1424119) to the bug's changelog.

Changed in network-manager-applet (Ubuntu Precise):
assignee: nobody → Seyeong Kim (xtrusia)
Changed in network-manager-applet (Ubuntu):
assignee: Seyeong Kim (xtrusia) → nobody
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu Precise):
status: New → Confirmed

Hello Serpico, or anyone else affected,

Accepted network-manager-applet into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/0.9.4.1-0ubuntu2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
mikewhatever (mikewhatever) wrote :

Thanks for the fix. Just tested the following from the proposed repo:
network-manager 0.9.4.0-0ubuntu4.4.2
network-manager-gnome 0.9.4.1-0ubuntu2.5

"Edit connctions" is clickable again after reloading (service network-manager stop/start), and also after rebooting.

tags: added: verification-done
removed: verification-needed
Serpico (arnaud-abbal) wrote :

Seems to work for me too.
Thanks for the fix

paz (mozit) wrote :

I would like to thank you and confirm that all is working well now.

Seems to work on my machine (12.04 LTS) too.
Thanks for the fix.

Al (agn9876-w) wrote :

Duplicate Bug #1425493. Works for me. Thanks.

Peter Sin (petersin2) wrote :

Just tested the updates from the proposed repo:
network-manager 0.9.4.0-0ubuntu4.4.2
network-manager-gnome 0.9.4.1-0ubuntu2.5

The menu is working properly again,
and "Edit connctions" is no longer grayed out.

Yes, working fine also for me after the latest update.
Thanks, everyone - good cooperation.
Do I need to unsubscribe, or will the conversation automatically expire?

(\__/)
(='.'=) Best regards, Denham Pole
(")_(")

On Mon, Mar 23, 2015 at 5:36 PM, Peter Sin <email address hidden> wrote:

> Just tested the updates from the proposed repo:
> network-manager 0.9.4.0-0ubuntu4.4.2
> network-manager-gnome 0.9.4.1-0ubuntu2.5
>
> The menu is working properly again,
> and "Edit connctions" is no longer grayed out.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1424119
>
> Title:
> Edit Connections...now insensitive by default in network manager's
> menu
>
> Status in network-manager-applet package in Ubuntu:
> Fix Released
> Status in network-manager-applet source package in Precise:
> Fix Committed
>
> Bug description:
> [SRU justification]
>
> [Impact]
>
> grayed out on network-manager-applet, can't click
>
> arno@arno-1000H:~$ lsb_release -rd
> Description: Ubuntu 12.04.5 LTS
> Release: 12.04
> arno@arno-1000H:~$ apt-cache policy network-manager-gnome
> network-manager-gnome:
> Installé : 0.9.4.1-0ubuntu2.4
> Candidat : 0.9.4.1-0ubuntu2.4
> Table de version :
> *** 0.9.4.1-0ubuntu2.4 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main
> i386 Packages
> 100 /var/lib/dpkg/status
> 0.9.4.1-0ubuntu2 0
> 500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386
> Packages
>
> Might be after upgrade to network-manager-gnome 0.9.4.1-0ubuntu2.4,
> the item Edit Connections... at the bottom of the network manager's
> menu is now insensitive i.e. grayed out, therefore user cannot
> configure his/her connections as indicated in
> http://docs.xubuntu.org/1204/internet-networks.html#network-
> connections
>
> workaround : launch /usr/bin/nm-connection-editor to display the
> network connections window and have access to the settings.
>
> [Test Case]
> after updating network-manager-gnome on laptop, you can always see this
> problem.
>
> [Regression Potential]
>
> [Other Info]
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1424119/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu2.5

---------------
network-manager-applet (0.9.4.1-0ubuntu2.5) precise; urgency=medium

  * Backport foo_client_setup from 0.9.8.8 src/applet.c (LP: #1424119)
 -- Seyeong Kim <email address hidden> Mon, 16 Mar 2015 08:18:00 -0500

Changed in network-manager-applet (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

houstonbofh (leesharp) wrote :

Just to stamp closed to it... I did a regular update via the update manager with no special settings, and received the correct version, and it did fix the problem. So for anyone that pinned the release, just remove the pin and update.

Chris Good (chris-good) wrote :

FYI
After std Precise software updates updated
 libnm-gtk-common to 0.9.4.1-0ubuntu2.5
 network-manager-gnome to 0.9.4.1-0ubuntu2.5
Edit Connections is NOT greyed out when I connect to console using VMware vSphere client 5.5.0,
but it still IS greyed out when I connect to same Ubuntu 12.04 LTS machine, as same user, using Remote Desktop from Windows 7 (with xVNC on Ubuntu).

I'm not sure the above updates fixed the problem in the vSphere client situation. It is possible I have only ever seen this problem when using Remote Desktop. I expected vSphere client and Remote Desktop to be the same.

cogset (jackfog66) wrote :

I still had the bug with network-manager-gnome 0.9.4.1-0ubuntu2.5 in Mint13 (based on Ubuntu 12.04 LTS), I've had to revert to version 0.9.4.1-0ubuntu2.1 to get rid of it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers