[vivid/unity7] networking indicator shows lxc bridges

Bug #1423819 reported by Jonas G. Drange on 2015-02-20
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Just upgraded from trusty to vivid.

How to reproduce:
1. Install LXC or something that creates a bridge

What happens:
The networking menu displays virbr0 and lxcbr0 [1]

What should happen:
The networking menu should not display virbr0 and lxcbr0

[1] http://i.imgur.com/SAnFVYB.png

Michał Sawicz (saviq) on 2015-02-20
Changed in indicator-network:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

that indicator is nm-applet, not i-n

affects: indicator-network → network-manager-applet
Changed in network-manager-applet:
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
affects: network-manager-applet → network-manager-applet (Ubuntu)

This is on purpose, upstream. We'll be making a conscious decision of hiding these virtual devices given that NM isn't supposed to manage them, and showing them might confuse users.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.10.1-0ubuntu2

---------------
network-manager-applet (0.9.10.1-0ubuntu2) vivid; urgency=medium

  * debian/patches/nm-applet-use-indicator.patch: initialize GSList dupes var
    to NULL. Thanks to Patrik Fimml for the patch. (LP: #1046210)
  * debian/patches/rebuild_menu_after_init.patch: use a g_idle_add rather than
    a 30 second timeout, so as to make sure the menu update can't run until
    foo_set_initial_state did. (LP: #1418260)
  * debian/patches/hide_virtual_devices.patch: don't show bridge, bond, team,
    or vlan devices: they were only recently added to NM and nm-applet, and
    given that they are usually not managed, showing them tends to be
    confusing since they are usually the result of underlying software which
    might not expect their state to get changed by NM. (LP: #1423819)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 01 Apr 2015 16:59:35 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers