nm-applet crashed with SIGSEGV in add_menu_item()

Bug #1418260 reported by Blümchen Blau on 2015-02-05
202
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Medium
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Vivid
Medium
Mathieu Trudel-Lapierre

Bug Description

[Impact]
If for any reason ModemManager is unavailable or unable to understand the modem device that pops up as broadband (also, in the case of Desktop-Next), NM-applet may crash due to expecting that there is always a devinfo object from the ModemManager data.

[Test case]
Install, use desktop, with ModemManager disabled.

[Regression potential]
Minimal, this is a patch from upstream which covers a known issue with NM in case ModemManager is unavailable to answer requests; what may happen as a result of devinfo being unavailable but NM continuing without crashing is that icons and pretty device names or signal level might be unavailable.

---

Crash when trying to install the system.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: network-manager-gnome 0.9.10.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-12.13-generic 3.18.4
Uname: Linux 3.18.0-12-generic x86_64
ApportVersion: 2.15.1-0ubuntu4
Architecture: amd64
CasperVersion: 1.350
CurrentDesktop: Unity
Date: Thu Feb 5 00:14:28 2015
ExecutablePath: /usr/bin/nm-applet
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.179.1 dev wlan0 proto static metric 1024
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.179.0/24 dev wlan0 proto kernel scope link src 192.168.179.24
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150203)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nm-applet
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x4327a0: mov 0x18(%r14),%rdi
 PC (0x004327a0) ok
 source "0x18(%r14)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: network-manager-applet
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: nm-applet crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH ACTIVE DEVICE STATE ACTIVE-PATH
 WiiNET 0fb694d1-9615-4328-9737-80258a84ae02 802-11-wireless 1423095224 Do 05 Feb 2015 00:13:44 UTC yes no /org/freedesktop/NetworkManager/Settings/2 yes wlan0 activated /org/freedesktop/NetworkManager/ActiveConnection/0
 Wired connection 1 ee5250e7-00fb-463e-a7a6-9c9259942c9e 802-3-ethernet 1423097919 Do 05 Feb 2015 00:58:39 UTC yes no /org/freedesktop/NetworkManager/Settings/0 no -- -- --
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlan0 wifi connected /org/freedesktop/NetworkManager/Devices/2 WiiNET 0fb694d1-9615-4328-9737-80258a84ae02 /org/freedesktop/NetworkManager/ActiveConnection/0
 eth0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 ttyACM1 gsm unavailable /org/freedesktop/NetworkManager/Devices/4 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Blümchen Blau (bluemchen-blau) wrote :

StacktraceTop:
 add_menu_item (device=0xade1a0, multiple_devices=1, connections=0x0, active=0x0, menu=0xaf47f0, applet=0x93f400) at applet-device-broadband.c:765
 add_device_items (type=type@entry=NM_DEVICE_TYPE_MODEM, all_devices=all_devices@entry=0x902f80, all_connections=all_connections@entry=0xb2b980, menu=menu@entry=0xaf47f0, applet=applet@entry=0x93f400) at applet.c:1677
 nma_menu_add_devices (applet=0x93f400, menu=0xaf47f0) at applet.c:1795
 nma_menu_show_cb (menu=0xaf47f0, applet=0x93f400) at applet.c:2095
 indicator_update_menu (applet=0x93f400) at applet.c:2441

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
summary: - nm-applet crashed with SIGSEGV in g_main_context_dispatch()
+ nm-applet crashed with SIGSEGV in add_menu_item()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.10.1-0ubuntu2

---------------
network-manager-applet (0.9.10.1-0ubuntu2) vivid; urgency=medium

  * debian/patches/nm-applet-use-indicator.patch: initialize GSList dupes var
    to NULL. Thanks to Patrik Fimml for the patch. (LP: #1046210)
  * debian/patches/rebuild_menu_after_init.patch: use a g_idle_add rather than
    a 30 second timeout, so as to make sure the menu update can't run until
    foo_set_initial_state did. (LP: #1418260)
  * debian/patches/hide_virtual_devices.patch: don't show bridge, bond, team,
    or vlan devices: they were only recently added to NM and nm-applet, and
    given that they are usually not managed, showing them tends to be
    confusing since they are usually the result of underlying software which
    might not expect their state to get changed by NM. (LP: #1423819)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 01 Apr 2015 16:59:35 -0400

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released

So, looks like this is still broken, reopening...

Changed in network-manager-applet (Ubuntu):
status: Fix Released → New
information type: Private → Public
Changed in network-manager-applet (Ubuntu):
status: New → Triaged
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in network-manager-applet (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → Medium
Changed in network-manager-applet (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-applet (Ubuntu Vivid):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.10.1-0ubuntu5

---------------
network-manager-applet (0.9.10.1-0ubuntu5) wily; urgency=medium

  * debian/patches/lp1418260_dont_crash_if_mm_isnt_avail.patch: Don't crash
    when ModemManager is not available. (LP: #1418260)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 10 Jul 2015 16:11:48 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released

I have an LTE WWAN; these things are somewhat asynchronous, so the diagnosis doesn't surprise me. It is important to test that when the WWAN _does_ finally become available, it will work, e.g. boot the laptop in an area with no LTE signal, then walk to civilization.

Hello Blümchen, or anyone else affected,

Accepted network-manager-applet into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/0.9.10.1-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
wgroiss (wolfgang-groiss-gmx) wrote :

I had a look at network-manager in proposed-repository:
I can find:
Version »0.9.10.0-4ubuntu15.
And this is the version, i have installed (no problems with this).
But it is not the same, your write above?

You need to look for network-manager-applet, not network-manager.

aptitude search network-manager-applet /vivid-proposed => no package found?

vivid-proposed repository is activated

please follow the steps in comment #11. If you had a space in your command between the name of the package and /, then this could explain why the command did not work.

Sebastien Bacher (seb128) wrote :
tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

I agree with seb128's assessment.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.10.1-0ubuntu4.1

---------------
network-manager-applet (0.9.10.1-0ubuntu4.1) vivid; urgency=medium

  * debian/patches/lp1418260_dont_crash_if_mm_isnt_avail.patch: Don't crash
    when ModemManager is not available. (LP: #1418260)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 10 Jul 2015 16:32:17 -0400

Changed in network-manager-applet (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in network-manager-applet:
status: Confirmed → Fix Released
Kevin Cole (kjcole) wrote :

Still getting the crash (and auto-reporting it).

To post a comment you must log in.