nm-applet icon invisible

Bug #1301158 reported by MichiGreat on 2014-04-02
128
This bug affects 25 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
High
Unassigned

Bug Description

nm-applet's icon is invisible since last session, when it suddenly disappeared. System has been rebooted, but the icon didn't appear again. So i'm currently not able to select a network, turn on/off networks, edit networks and so on.

$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.0

Contains all updates as of 2014/04/01. Running 3.14 kernel.

$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.8.8-0ubuntu5
  Candidate: 0.9.8.8-0ubuntu5

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: network-manager-gnome 0.9.8.8-0ubuntu3
Uname: Linux 3.14.0-031400-generic i686
ApportVersion: 2.14-0ubuntu1
Architecture: i386
CurrentDesktop: XFCE
Date: Wed Apr 2 07:42:58 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nm-applet
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-03-21 (11 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140225)
IpRoute:
 default via 192.168.43.1 dev wlan0 proto static
 192.168.43.0/24 dev wlan0 proto kernel scope link src 192.168.43.14 metric 9
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Bob Vorgabe 8ba5fa89-4c5d-4f06-a3ff-4bdeb457f99b gsm 1396367611 Di 01 Apr 2014 17:53:31 CEST no no /org/freedesktop/NetworkManager/Settings/2
 michigreat-hotspot 1ca2fab0-b64c-4eec-b77c-70c7827d7217 802-11-wireless 1396417354 Mi 02 Apr 2014 07:42:34 CEST yes no /org/freedesktop/NetworkManager/Settings/1
 greatwlan2 d0efc775-adbe-4260-910f-567dc8dd54fc 802-11-wireless 1396382625 Di 01 Apr 2014 22:03:45 CEST yes no /org/freedesktop/NetworkManager/Settings/0
 Kabelnetzwerkverbindung 1 c0551746-459f-40bd-be68-8a8ded54f2bc 802-3-ethernet 1396415555 Mi 02 Apr 2014 07:12:35 CEST yes no /org/freedesktop/NetworkManager/Settings/3
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

MichiGreat (michi20091979) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
bastik (bstk) wrote :

Same here (also XFCE). Upgraded from saucy to trusty on 2014-04-06, everything up to date and working. Booting today (2014-04-10) and the nm-applet icon is not visible. Killing and restarting nm-applet from the command line does not help.

$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.8.8-0ubuntu5
  Candidate: 0.9.8.8-0ubuntu5

som (drsoumalya-blog) wrote :

i am affected too. it was there after the install; but disappeared after booting.
tried nm-applet; did not reappear.
 deleted the indicator plug in form the panel and re-added it. now, its back.
$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.8.8-0ubuntu5
  Candidate: 0.9.8.8-0ubuntu7
  Version table:
     0.9.8.8-0ubuntu7 0

ugmoe2000 (ericpulvino) wrote :

I am also affected running xfce under Ubuntu 14.04.

$ apt-cache policy network-manager
network-manager:
  Installed: 0.9.8.8-0ubuntu7

I have no methods to get it back. When looking at the settings of the "notification area" plugin on panel 1 in XFCE the Network Manager Applet appears to be running but does not show. Toggling Hidden/Not Hidden has no affect.

ugmoe2000 (ericpulvino) wrote :

running "sudo nm-applet &" seems to get it showing in the notification area for me. No change in appearance of Notification Area settings.

Benji (benjim) wrote :

Same here with xfce and 14.04
nm-applet is shown as running process (ps ax), but no icon is shown.
Starting it with sudo (sudo nm-applet) make the icon appear.

Mélodie (meets) wrote :

Hi,

Invisible and visible applet:
Since I installed Ubuntu Trusty from the mini.iso (with all necessary packages to make a desktop environment around Openbox), I have had the same bug: well more or less. Only the icon of the Ethernet/cabled network does *not show*. The wireless icon *does show*, be it in Lxpanel, or in tint2 (I use one or the other, depending on which machine I use), but once the cable is used it *does not show*. It *does not* mean it is not working! There is an empty space where the icon should show and with a left click and a right click on this empty space I can *actually see* the nm-applet menus! And network-manager DOES work.

This hence seems not to be a duplicate of bug #1308348.

There is another bug I am hitting in Trusty, it the Ethernet connection is started on boot only, once booted, if the cable is disconnected and reconnected, it does not reconnect spontaneously. The wireless can be deactivated then reactivated without the system being restarted, while the connection with cable can't. So for this issue also only the Ethernet connection is affected. I have to seek through Bugzilla to see if I find a report about it. (Or could both bugs - icon display, and hot-plug cable connection - be related in a way or other?)

Vita (vitakon911) wrote :

Update packge network-manager-gnome (0.9.8.8-0ubuntu4.1) to 0.9.8.8-0ubuntu4.2 - nm-applet icon invisible :(

Mélodie (meets) wrote :

> Update packge network-manager-gnome (0.9.8.8-0ubuntu4.1) to 0.9.8.8-0ubuntu4.2 - nm-applet icon invisible :(

Here I had already network-manager-gnome 0.9.8.8-0ubuntu4.1 and the Ethernet icon for nm-applet was already invisible. The system is x86_64 (forgot to mention, sorry).

I am now updating to 0.9.8.8-0ubuntu4.2 and will see how it goes: anyway I could not connect with the wired cable, even just after a fresh reboot the network was not available : I had to use "dhclient eth0" with sudo in console to make it work.

My ethernet card is Intel 82577LM Gigabit (The laptop is a thinkpad 410 with Intel i5 M520 and the wireless is Intel, using iwlwifi).

Else than that, the wifi would work perfect!

Mélodie (meets) wrote :

Ok, after update to network-manager-gnome 0.9.8.8-0ubuntu4.2, and even adding new icons (gnome-dust-icon-theme available on the repos for Trusty, as I thought maybe my icon theme might be faulty), or even with the regular gnome icon theme, the icon is still not seen.

The information menu also does not see the connection. However, by what magic, the connection does work, a ping to google.com lets me know it. a "ps -ax | grep network-manager" does not return any network-manager process.

Here is a screenshot, where you can see the empty space right on the left of the desktop switcher: this is where the icon should be.

http://meets.free.fr/images/nm-applet_and_network-manager.png

Mélodie (meets) wrote :

Hi,
Now the icon shows, the wired connection is established at boot time and again when disconnecting and reconnecting the cable to the machine. If I connect the wifi on the fly it still works too, and if I disconnect the wifi right after, it switches interface and IP without problem.

The solution is in the /etc/network/interfaces file.

The attached patch below solved it for me, I hope it can solve it for everyone.

Regards,
Mélodie

Mélodie (meets) wrote :

Hi,

After getting more information about the interfaces file, I now know that it's content is created by the post-install script of the ifupdown program. It would be nice if the developers would investigate what is going on with this ifupdown post-install script (or higher in the chain of events leading to having a bad interfaces file).

Regards,
Mélodie

ladiko (ladiko) wrote :

This happens to me cause i without a desktop/session-manager like lxdg or gdm, but i startx via rungetty. Seems like xfce is launched without dbus-launch support, so i have to add this for nm-applet like this:

sudo sed -i 's/Exec=nm-applet/Exec=dbus-launch nm-applet/g' /etc/xdg/autostart/nm-applet.desktop

The attachment "interfaces.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sdlion (sdlion-01) wrote :

This also affects Mint and I can confirm ladiko's workaround

Description: Linux Mint 17 Qiana
Release: 17

I'm using XMonad with GNOME Fallback (Classic) and the nm-applet doesn't show on the panel.
Killing the process from a terminal and then run it as `dbus-launch nm-applet` makes it show in the panel.

Changed in network-manager-applet (Ubuntu):
importance: Undecided → High
Cédric DUNYACH (cdunyach) wrote :

Hi,
ladiko's trick worked also very well on a Xubuntu that was upgraded since 12.04 (14.04 now)

Thank you, ladiko: this does not solve my problem, but lights it in a new way...

I either have
* no nm-applet but everithing fine (through nm-connection-editor and nmcli) if I use nm-applet in /etc/xdg/autostart/nm-applet.desktop,
* nm-applet but no authentification when editing connections or connecting (need to use `sudo
nm-connection-editor` to add the password to the conection file and `sudo nmcli ...`).

Argh, just when I thought I could get it to work...

Stefan Tauner (stefanct) wrote :

I can confirm that the dbus-launch workaround mentioned in #14 also helps when running mate-desktop in 16.04 xenial upgraded from 12.04+14.04 (manually... so this might not be a real bug there).

Magda Lena (magda-lena) wrote :

Thank you for the dbus-launch idea, here's how it worked for me:

in xfce4 menu Settings / Session and Startup / Application Autostart
Add new
..here you choose a name, e.g. my-nm-applet-kludge, containing command
    dbus-launch nm-applet

Marcin Sochacki (wanted) wrote :

This is an very old bug, but maybe it could help someone. In my case, the .dbus directory in home was owned by root:root and that was actually the blocker.

sudo chown -R user:user ~/.dbus

solved the issue and nm-applet became visible after restart.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers