Ubuntu

"The NetworkManager applet could not find some required resources. It cannot continue." due to unreadable icon file

Reported by Paul Sladen on 2007-07-19
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

Modal dialogue saying:

  "The NetworkManager applet could not find some required resources. It cannot continue."

pops up over everything.

This information is useless; ideally, N-M should not show the dialogue if the user cannot do anything about it. ("what resources?..").

Paul Sladen (sladen) on 2007-07-19
description: updated
Paul Sladen (sladen) wrote :

<ogra> sladen, bug 126987 sounds like the return of the broken icon cache (i think dholbach fixed that once in former releases)
<dholbach> sladen: running it under strace -e open,stat could help to find out what's wrong
<dholbach> but yeah, it could be the icon cache
<ogra> in bug 137760 it reports some detail at least, i wonder why it doesnt do that with other stuff
<dholbach> although it should use dh_icons now - debian/rules looks fine

Haven't seen the message for a couple of weeks, but I'll keep an eye out if/when I do.

Alexander Sack (asac) on 2007-10-07
Changed in network-manager:
importance: Undecided → Medium
status: New → Confirmed

Since the last comment on this bug was in September, before the release of Gutsy:
have you seen this issue in Gutsy (or Hardy)?

Thanks!

Jacqui (jacqui-russell) wrote :

I've had this problem in the beta of Intrepid.

Shaun Crampton (fasaxc) wrote :

I'm currently upgrading to Intrepid beta and I keep seeing this error. Will see if it goes away after the upgrade completes.

Shaun Crampton (fasaxc) wrote :

After reboot, I haven't seen the error but nm-applet didn't start automatically after the reboot: bug 278147.

Chris Fleming (chrisfleming) wrote :

This came up for me during the installation phase. Not sure if this is a bug with the actual upgrade process or with nm-applet.

Either way it makes it look like something has gone wrong during the install.

Alaak (alaak-gmx) wrote :

Also had the same problem during installation and afterwards nm-applet does not start automatically.

Alexander Sack (asac) wrote :

this bug probably was due to missing images during major version upgrades. we triaged that for the 0.6->0.7 update round for hardy->intrepid and fixed this. Here the changelog:

network-manager-applet (0.7~~svn20081015t194645-0ubuntu1) intrepid; urgency=low

  * new upstream snapshot Wed 2008-10-15 19:46:45 +0000 (rev 809)
  * fix LP: #277084 - nm-applet confused by icon name changes during
    hardy-intrepid upgrade; we ship icons used by NM 0.6 in the NM 0.7
    to prevent this behaviour
    - update debian/rules

 -- Alexander Sack < <email address hidden>> Thu, 16 Oct 2008 00:42:34 +0200

Changed in network-manager-applet:
status: Confirmed → Fix Released
submachine0 (submachine0) wrote :

An idea: (I'm on Jaunty) ... this error came up when i installed the "wicd" network manager to use for other window manager sessions. anyway, it's pretty obvious why i received this error... but maybe it will help others in solving their problem.

as a solution to whatever that problem is, a workaround could be installing a different manager such as "wicd".

i am now wondering, however, what if i want to re-enable my previous network manager and drop this one? would it be automatic after removing "wicd" or would i have to do something to enable the default one?

Daniel Asarnow (dasarnow) wrote :

I'm getting this error in Karmic. I should note that the error message window actually pops up several times at once (so that one must click "OK" several times) and that it does not affect network functionality (obviously).

Paul Kishimoto (khaeru) wrote :

Also experiencing this in the Kamic beta. I only see the notice once on my Acer Aspire One. If I later start nm-applet from the command line, i see:

$ nm-applet

** (nm-applet:15287): WARNING **: Icon nm-active-device missing: Unrecognized image file format

...I also note that there has been another minor version change (0.7 to 0.8) since the last time this cropped up; not sure if that is relevant.

# apt-cache policy network-manager
network-manager:
  Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
  Candidate: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
  Version table:
 *** 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Changed in network-manager-applet (Ubuntu):
status: Fix Released → Confirmed
edoceo (edoceo) wrote :
Download full text (3.2 KiB)

I'm also seeing this on a Jaunty to Karmic upgrade.
I've ran the icon-cache update tool, that I read from Google searches, no change.
Once I click the 'OK' on the prompt (I get three prompts) then my network connectivity stops.

If I run `nm-applet` from the command line I see this:
---
** (nm-applet:2246): WARNING **: Icon nm-signal-00 missing: Error opening file: No such file or directory
---
From strace I've learned this:
----
lstat64("/usr/share/icons/elementaryXubuntu/apps/48/nm-signal-00.svg", {st_mode=S_IFLNK|0777, st_size=15, ...}) = 0
stat64("/usr/share/icons/elementaryXubuntu/apps/48/nm-signal-00.svg", 0xbfdcd36c) = -1 ENOENT (No such file or directory)
readlink("/usr/share/icons/elementaryXubuntu/apps/48/nm-signal-00.svg", "nm-signal-0.svg", 256) = 15
open("/usr/share/icons/elementaryXubuntu/apps/48/nm-signal-00.svg", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
** (nm-applet:2632): WARNING **: Icon nm-signal-00 missing: Error opening file: No such file or directory
----
And if I look for those files, I can see their links are broken
----
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ls -alh nm*
lrwxrwxrwx 1 root root 15 2009-10-16 22:13 nm-signal-00.svg -> nm-signal-0.svg
lrwxrwxrwx 1 root root 54 2009-10-16 22:13 nm-signal-0.svg -> ../../status/48/notification-network-wireless-none.svg
lrwxrwxrwx 1 root root 54 2009-10-16 22:13 nm-signal-100.svg -> ../../status/48/notification-network-wireless-full.svg
lrwxrwxrwx 1 root root 53 2009-10-16 22:13 nm-signal-25.svg -> ../../status/48/notification-network-wireless-low.svg
lrwxrwxrwx 1 root root 56 2009-10-16 22:13 nm-signal-50.svg -> ../../status/48/notification-network-wireless-medium.svg
lrwxrwxrwx 1 root root 54 2009-10-16 22:13 nm-signal-75.svg -> ../../status/48/notification-network-wireless-high.svg
----
So then I did this:
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-00.svg ./nm-signal-0.svg
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-00.svg ./nm-signal-00.svg
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-25.svg ./nm-signal-25.svg
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-50.svg ./nm-signal-50.svg
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-75.svg ./nm-signal-75.svg
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ln -s ../../status/48/nm-signal-100.svg ./nm-signal-100.svg
----
To get this:
root@fluorine:/usr/share/icons/elementaryXubuntu/apps/48# ls -alh nm-*
lrwxrwxrwx 1 root root 32 2009-10-21 09:03 nm-signal-00.svg -> ../../status/48/nm-signal-00.svg
lrwxrwxrwx 1 root root 32 2009-10-21 09:03 nm-signal-0.svg -> ../../status/48/nm-signal-00.svg
lrwxrwxrwx 1 root root 33 2009-10-21 09:03 nm-signal-100.svg -> ../../status/48/nm-signal-100.svg
lrwxrwxrwx 1 root root 32 2009-10-21 09:03 nm-signal-25.svg -> ../../status/48/nm-signal-25.svg
lrwxrwxrwx 1 root root 32 2009-10-21 09:03 nm-signal-50.svg -> ../../status/48/nm-signal-50.svg
lrwxrwxrwx 1 root root 32 2009-10-21 09:03 nm-signal-75.svg -> ../../status/48/nm-sig...

Read more...

Paul Kishimoto (khaeru) wrote :

In my case, it turned out that the *one* icon giving an error (nm-active-device) was in fact a corrupted PNG file on my system; that is, eog and other programs could not open it. This must have been due to a filesystem error or an interrupted upgrade.

Since other people seem to be experiencing the error, I leave it Confirmed.

Khaled Khalil (khaled-khalil) wrote :

i had the same issue when i set the icon them to "Elementary Xubuntu".
so i reinstalled "xubuntu-artwork" package and everything went right.
i hope that may help if anyone still gets the issue.

Alan Pope ㋛ (popey) wrote :

This hit me on an upgrade from 9.10 to 10.04. mpt requested I file a bug, but this one seems close enough. See related bug 281524

Alan Pope ㋛ (popey) wrote :

Amusingly I got this on a clean boot of Ubuntu 10.10 64 bit live cd before unity started.

Thomas Hood (jdthood) on 2012-08-08
tags: added: intrepid maverick
tags: added: lucid
summary: - The NetworkManager applet could not find some required resources. It
- cannot continue.
+ "The NetworkManager applet could not find some required resources. It
+ cannot continue." due to unreadable icon file
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers