nm-applet is no longer launched at startup on non gnome-shell sessions

Bug #1267100 reported by Matthieu Baerts on 2014-01-08
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

Hello and thank you for maintaining nm-applet packages!

With the latest version (0.9.8.4-1ubuntu1), nm-applet is no longer launched at startup on non Gnome-Shell sessions (e.g. on Cairo-Dock session).
It seems this is because this patch is no longer applied: git_dont_autostart_under_GNOME.patch

I'm proposing a new version (please see the branch linked to this bug report) which re-adds this patch.

Note that this patch should no longer be needed with the next 0.9.8.8 version: https://git.gnome.org/browse/network-manager-applet/commit/?id=e192e83c1aa136512a9d4f026f81677799af8127

Related branches

Matthieu Baerts (matttbe) wrote :

Note: I just re-sync my BZR branch with the trunk (lp:ubuntu/network-manager-applet).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Eugene San (eugenesan) wrote :

Looks like gnome-flashback(fallback) and unity-greeter are affected also.

Eugene San (eugenesan) wrote :

Using referenced branch, indeed solves the problem.
I've uploaded fixed package to my PPA: https://launchpad.net/~eugenesan/+archive/ppa/+sourcepub/3896688/+listing-archive-extra

Norbert (nrbrtx) wrote :

All updates (including proposed) are installed on clean install of Ubuntu 14.04 - nm-applet does not auto-load in GNOME FlashBack sessions (Compiz and Metacity).
If I try to load it manually from terminal with 'nm-applet' it is loaded and showed.

Norbert (nrbrtx) wrote :

unity-greeter show pop-up about my wired connection (informs me that it is connected), but there is no nm-applet here too.

Matthieu Baerts (matttbe) wrote :

@Norbert: I just uploaded a new version of this package with a patch to fix this bug.
You can find it on my ppa (ppa:matttbe/ppa) => https://launchpad.net/~matttbe/+archive/ppa/+sourcepub/3932130/+listing-archive-extra
Feel free to test it and check if it fixes this bug ;-)

Norbert (nrbrtx) wrote :

@Matthieu Baerts (matttbe) , thank you very much!!!
I added your ppa and tested GNOME FlashBack sessions (Compiz and Metacity) - nm-applet is auto-loaded in them, it's great!

I booted my Ubuntu 12.04.4 machines - they do not have nm-applet in lightdm/unity-greeter, so this is not an issue.
So bug #1267100 is fixed.

Alkis Georgopoulos (alkisg) wrote :

I manually applied the patch and nm-applet now works fine.
Please commit/release it. :)

Alkis Georgopoulos (alkisg) wrote :

I think there's another bug involved here.

nm-applet is now always launched in my gnome-fallback session, nice.
But I don't always see it in the systray, it's intermittent.
E.g. I reboot with autologin enabled, and I don't see the applet.
The nm-applet process is there though.
Then I logoff / logon, and I do see the applet.

So people might not see the applet after applying *this* patch, because of the *other* bug involved, and they may have trouble verifying that it indeed fixes this issue.

Matthieu Baerts (matttbe) wrote :

If you've this bug, it should not be due to this patch because with it, this application should be launched at startup except if you're using KDE or GNOME with Gnome-Shell.
If the conditions are not respected, it's maybe due to something else (maybe Gnome-Session?)

It actually seems to me like nm-applet ought to run even on GNOME Shell sessions, as to provide the GSM PIN/PUK dialogs. I think I'd rather use the upstream patch to redo that code altogether.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.8.8-0ubuntu1

---------------
network-manager-applet (0.9.8.8-0ubuntu1) trusty; urgency=medium

  * New upstream release. (LP: #1276082)
    - nm-applet: change logging to use g_debug
    - applet: redo the gnome-shell interaction code (LP: #1267100)
    - editor: do not gtk_widget_destroy() dialog on "close" signal
    - nma-bt-device: fix creation of BT settings when creating connection
  * debian/patches/nm-applet-use-indicator.patch: refreshed
  * debian/patches/lp460144_correctly_update_notification.patch: refreshed.
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 05 Mar 2014 14:14:30 -0500

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers