Can't create AP hotspots in ubuntu 13.10 / network-manager

Bug #1260326 reported by f3a97 on 2013-12-12
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Invalid
Wishlist
gnome-control-center
Confirmed
Medium
network-manager-applet (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

Today I have upgraded to Ubuntu 13.10 with the hope that network-manager was finally able to create AP hotspots without complex configurations. This would enable the end user to finally connect phones and tablets to wifi hotspots created with Ubuntu.

Too bad I found out that the Network tool still creates hotspots with ad-hoc networks.

Good news is that with a simple change I managed to create a working AP hotspot and connect my android devices! The only change that is required is to:

1) set mode=ap to the hotspot connection file (created by the Network tool)
2) start the hotspot with the nmcli tool: nmcli con up id your-connection-name (credits to: https://bugs.launchpad.net/ubuntu/+source/wpa/+bug/1209511)

It is clear then that this is not an hardware or driver issue, so why AP hotspots are still not created by default?

Thanks for the great work.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: network-manager 0.9.8.0-0ubuntu22
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
Date: Thu Dec 12 14:23:17 2013
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2012-11-19 (387 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
IpRoute:
 default via 10.64.64.64 dev ppp0 proto static
 10.42.0.0/24 dev wlan1 proto kernel scope link src 10.42.0.1 metric 9
 10.64.64.64 dev ppp0 proto kernel scope link src 10.214.172.154
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to saucy on 2013-12-12 (0 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 ttyUSB4 gsm connected /org/freedesktop/NetworkManager/Devices/6
 wlan1 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/5
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless disconnected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.0 connected enabled enabled enabled enabled enabled

f3a97 (f3a97) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Dirk Willrodt (dwillrodt) wrote :

thank You for that explanation of a work around!

Reassigning to nm-applet, it only needs to support setting the connection in mode=ap, which NM already understands.

affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager-applet:
status: New → Invalid
Changed in network-manager-applet:
importance: Medium → Undecided
status: Invalid → New
status: New → Confirmed
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager-applet:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in network-manager-applet:
importance: Unknown → Wishlist
status: Unknown → New

The attachment "Patch attached to upstream bug report" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in network-manager-applet:
status: New → Invalid
Changed in gnome-control-center:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.