nm-applet crashed with SIGSEGV in gtk_status_icon_set_visible()

Bug #1230148 reported by Chris Glass on 2013-09-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Robert Ancell

Bug Description

After logging back in from a mir test session (installed unity-system-compositor, reboot, play with mir a bit, remove mir from lightdm startup, reboot).

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: network-manager-gnome 0.9.8.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Sun Sep 22 11:22:01 2013
ExecutablePath: /usr/bin/nm-applet
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-07-23 (63 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
IpRoute:
 default via 192.168.1.254 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.64 metric 9
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nm-applet
SegvAnalysis:
 Segfault happened at: 0x7f4e8813aa4c <gtk_status_icon_set_visible+28>: cmp %rax,(%rdx)
 PC (0x7f4e8813aa4c) ok
 source "%rax" ok
 destination "(%rdx)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: network-manager-applet
StacktraceTop:
 gtk_status_icon_set_visible () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libappindicator3.so.1
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
Title: nm-applet crashed with SIGSEGV in gtk_status_icon_set_visible()
UpgradeStatus: Upgraded to saucy on 2013-07-27 (59 days ago)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.0 connected enabled enabled enabled enabled disabled

Chris Glass (tribaal) wrote :

This crash has the same stack trace characteristics as bug #1189309. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 gtk_status_icon_set_visible (status_icon=0x1c86120, visible=visible@entry=0) at /build/buildd/gtk+3.0-3.8.4/./gtk/gtkstatusicon.c:2057
 indicator_unfallback (indicator=0x1c979e0, status_icon=<optimized out>) at applet.c:3749
 app_indicator_dispose (object=0x1c979e0) at ../../../src/app-indicator.c:646
 g_object_unref (_object=0x1c979e0) at /build/buildd/glib2.0-2.37.93/./gobject/gobject.c:3160
 finalize (object=0x1b520c0) at applet.c:4134

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
information type: Private → Public
Robert Ancell (robert-ancell) wrote :

The bug was libappindicator calling unfallback() when the applet is being unrefed. This would cause it to access the status_icon which had been unreffed in the previous step.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.8.0-1ubuntu5

---------------
network-manager-applet (0.9.8.0-1ubuntu5) saucy; urgency=low

  * debian/patches/nm-applet-use-indicator.patch:
    - Fix crash when nm-applet quits (LP: #1230148)
 -- Robert Ancell <email address hidden> Wed, 16 Oct 2013 16:35:33 +1300

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers