nm-applet crashed with SIGSEGV in gtk_status_icon_set_visible()

Bug #1189309 reported by Tim on 2013-06-10
596
This bug affects 107 people
Affects Status Importance Assigned to Milestone
libappindicator
Invalid
High
Unassigned
network-manager-applet (Ubuntu)
Medium
Unassigned

Bug Description

crashed on login.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: network-manager-gnome 0.9.8.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-4.9-generic 3.9.4
Uname: Linux 3.9.0-4-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Mon Jun 10 12:34:25 2013
ExecutablePath: /usr/bin/nm-applet
ExecutableTimestamp: 1362762982
InstallationDate: Installed on 2012-09-23 (260 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=false
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nm-applet
ProcCwd: /home/darkness
RfKill:

SegvAnalysis:
 Segfault happened at: 0x7fe676a5f87c <gtk_status_icon_set_visible+28>: cmp %rax,(%rdx)
 PC (0x7fe676a5f87c) ok
 source "%rax" ok
 destination "(%rdx)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: network-manager-applet
StacktraceTop:
 gtk_status_icon_set_visible (status_icon=0x265c300, visible=0) at /build/buildd/gtk+3.0-3.8.2/./gtk/gtkstatusicon.c:2057
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libappindicator3.so.1
 g_object_unref (_object=0x25999b0) at /build/buildd/glib2.0-2.37.1/./gobject/gobject.c:3152
 ?? ()
Title: nm-applet crashed with SIGSEGV in gtk_status_icon_set_visible()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0.14 vlan unmanaged /org/freedesktop/NetworkManager/Devices/2
 test vlan unmanaged /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unmanaged /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.0 connected enabled enabled disabled enabled disabled

Tim (darkxst) wrote :

StacktraceTop:
 gtk_status_icon_set_visible (status_icon=0x265c300, visible=visible@entry=0) at /build/buildd/gtk+3.0-3.8.2/./gtk/gtkstatusicon.c:2057
 indicator_unfallback (indicator=0x25999b0, status_icon=<optimized out>) at applet.c:3749
 app_indicator_dispose (object=0x25999b0) at ../../../src/app-indicator.c:646
 g_object_unref (_object=0x25999b0) at /build/buildd/glib2.0-2.37.1/./gobject/gobject.c:3152
 finalize (object=0x2604020) at applet.c:4134

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I actually think this is happening on logout, given that I saw a .crash file in my /var/crash/ directory when I was not logged in to a desktop session. Well either that or it happens with the nm-applet that appears in lightdm.

C de-Avillez (hggdh2) on 2013-07-13
information type: Private → Public
Cavsfan (cavsfan) wrote :

I just logged into Unity after logging out of Gnome Fallback and immediately got this and other errors.

Ted Gould (ted) on 2013-07-23
affects: network-manager-applet (Ubuntu) → libappindicator (Ubuntu)
Changed in libappindicator:
status: New → Confirmed
importance: Undecided → High
tags: added: bugpattern-needed
jd (ltshalalabob) wrote :

i installed kde plasma and while signing in(ive been using gnome with saucy) it crashed and sending it back to unity desktop with a series of 5-6 other crashes

Arne Meyer (am-v) wrote :

It happened after todazs update right after restart and login.
It seems to happen while updating, because I got some messages with warnings and errors from gnome panel during apdate.

Also happened after start of Gnome desktop Ubuntu 13.10

kernel 3.10.0-6-generic

Tim (darkxst) wrote :

nm-applet is no longer used under gnome-shell, so it shouldnt be autostarted anymore. cherrypicked git patch that updates the autostart desktop file

Dimitri John Ledkov (xnox) wrote :

Re patch in #11, I'm not sure if this will not regress on gnome-panel and derivative GNOME-like sessions, which are not GNOME-Shell based.

Tim (darkxst) wrote :

I guess could use the following instead if you prefer?

AutostartCondition=GNOME3 unless-session gnome

Tim (darkxst) wrote :

I guess could use the following instead?

AutostartCondition=GNOME3 unless-session gnome

Tim (darkxst) wrote :

Changed to use AutostartCondition

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

Kenneth Wrede (kennethwrede) wrote :

xubuntu 13.10 with a Custom kernel 3.4.0-60.

Darren Lachambre (dlachambre) wrote :

I had just rebooted after installing the lastest updates for 13.10 beta1. This and a bunch of other errors popped up at login.

Adam Conrad (adconrad) on 2013-09-10
affects: libappindicator (Ubuntu) → network-manager-applet (Ubuntu)
Changed in libappindicator:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.8.0-1ubuntu3

---------------
network-manager-applet (0.9.8.0-1ubuntu3) saucy; urgency=low

  * debian/patches/git_dont_autostart_under_GNOME.patch (LP: #1189309)
 -- Tim <email address hidden> Mon, 02 Sep 2013 14:03:33 +1000

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1189309

tags: added: package-qa-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers