nm-applet crashed with SIGABRT in g_assertion_message()

Bug #1159063 reported by dino99 on 2013-03-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

got that crash several times when im loging into unity on RR i386

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: network-manager-gnome 0.9.8.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu2
Architecture: i386
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CrashCounter: 1
Date: Sat Mar 23 07:16:48 2013
ExecutablePath: /usr/bin/nm-applet
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.3 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 eth1 no wireless extensions.
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nm-applet
RfKill:

Signal: 6
SourcePackage: network-manager-applet
StacktraceTop:
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
 gtk_widget_unregister_window () from /usr/lib/i386-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgdk-3.so.0
Title: nm-applet crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: Debian-exim adm admin audio avahi avahi-autoipd backup bin cdrom clamav colord couchdb crontab daemon debian-tor dialout dip disk fax floppy fuse games gnats haldaemon i2c irc klog kmem libuuid lightdm list lp lpadmin mail man messagebus mlocate mysql mythtv netdev news ntp operator pcscd plugdev polkituser powerdev proxy pulse pulse-access root rtkit sambashare saned sasl scanner shadow src ssh ssl-cert staff sudo sys syslog tape tty users utempter utmp uucp vboxusers video voice whoopsie winbindd_priv www-data
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Connexion filaire 2 57464c22-9292-42a1-a5cb-ea9285c8ccc2 802-3-ethernet 1364013741 sam. 23 mars 2013 05:42:21 CET yes no /org/freedesktop/NetworkManager/Settings/1
 Connexion filaire 1 9f3205aa-b315-4c77-8ef6-1e0bde2bebdc 802-3-ethernet 1364019441 sam. 23 mars 2013 07:17:21 CET yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth1 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.0 connected enabled enabled enabled enabled disabled

dino99 (9d9) wrote :
information type: Private → Public

StacktraceTop:
 g_test_trap_assertions (domain=0x30 <Address 0x30 out of bounds>, file=0xb6d89000 "|\376\017", line=-1227321344, func=0xb6cef90c <g_strtod+188> "\371\377\211D$\b\215\203\251\310\371\377\211D$\004\215\203\316", assertion_flags=13173646672545275950, pattern=0x133 <Address 0x133 out of bounds>) at /build/buildd/glib2.0-2.35.8/./glib/gtestutils.c:2384
 ?? ()
 ?? ()
 ?? () from /tmp/apport_sandbox_eRv9uC/lib/i386-linux-gnu/libglib-2.0.so.0

Changed in network-manager-applet (Ubuntu):
status: New → Invalid
Download full text (4.6 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

gnome-control-center version 1:3.7.91-0ubuntu1~raring3 required, but 1:3.6.3-0ubuntu16 is available
libgail-3-0 version 3.7.12-1ubuntu1~build1 required, but 3.6.4-0ubuntu6 is available
nautilus-data version 1:3.7.90-0ubuntu1~raring2 required, but 1:3.6.3-0ubuntu11 is available
libsmbclient version 2:3.6.9-1ubuntu2~raring3 required, but 2:3.6.9-1ubuntu1 is available
libgtk-3-0 version 3.7.12-1ubuntu1~build1 required, but 3.6.4-0ubuntu6 is available
libgoa-1.0-common version 3.7.92-0ubuntu1~raring2 required, but 3.6.2-1ubuntu1 is available
gnome-control-center-data version 1:3.7.91-0ubuntu1~raring3 required, but 1:3.6.3-0ubuntu16 is available
gsettings-desktop-schemas version 3.7.92-0ubuntu1~raring3 required, but 3.6.1-0ubuntu1 is available
gcr version 3.7.5-0ubuntu1~raring1 required, but 3.6.2-0ubuntu1 is available
libpango1.0-0 version 1.33.8-0ubuntu1~raring0 required, but 1.32.5-0ubuntu1 is available
libgck-1-0 version 3.7.5-0ubuntu1~raring1 required, but 3.6.2-0ubuntu1 is available
libqtwebkit4 version 2.3.0-0ubuntu1 required, but 2.3-0ubuntu8 is available
libgnome-control-center1 version 1:3.7.91-0ubuntu1~raring3 required, but 1:3.6.3-0ubuntu16 is available
libgtk-3-common version 3.7.12-1ubuntu1~build1 required, but 3.6.4-0ubuntu6 is available
outdated debug symbol package for libcolord-gtk1: package version 0.1.24-0ubuntu1 dbgsym version 0.1.21-1ubuntu2
libfontconfig1 version 2.10.91-0ubuntu1~raring1 required, but 2.10.2-0ubuntu2 is available
libglib2.0-0 version 2.35.9-2ubuntu1 required, but 2.35.8-0ubuntu1 is available
libgcr-3-1 version 3.7.5-0ubuntu1~raring1 required, but 3.6.2-0ubuntu1 is available
gnome-icon-theme-symbolic version 3.7.5-0ubuntu1~raring0 required, but 3.6.2-0ubuntu1 is available
libpam-gnome-keyring version 3.7.5-0ubuntu1~raring1 required, but 3.6.3-0ubuntu2 is available
libgnome-keyring-common version 3.7.5-0ubuntu1~raring1 required, but 3.6.0-1 is available
fontconfig-config version 2.10.91-0ubuntu1~raring1 required, but 2.10.2-0ubuntu2 is available
libglib2.0-data version 2.35.9-2ubuntu1 required, but 2.35.8-0ubuntu1 is available
libp11-kit-gnome-keyring version 3.7.5-0ubuntu1~raring1 required, but 3.6.3-0ubuntu2 is available
libsoup-gnome2.4-1 version 2.41.90-0ubuntu1~raring1 required, but 2.40.3-0ubuntu1 is available
fontconfig version 2.10.91-0ubuntu1~raring1 required, but 2.10.2-0ubuntu2 is available
gnome-session-bin version 3.7.92-0ubuntu1~raring1 required, but 3.6.2-0ubuntu5 is available
gnome-icon-theme version 3.7.91-0ubuntu1~raring1 required, but 3.6.2-0ubuntu1 is available
gnome-online-accounts version 3.7.92-0ubuntu1~raring2 required, but 3.6.2-1ubuntu1 is available
outdated debug symbol package for gnome-online-accounts: package version 3.6.2-1ubuntu1 dbgsym version 3.6.0-0ubuntu1
libgnome-keyring0 version 3.7.5-0ubuntu1~raring1 required, but 3.6.0-1 is available
libwbclient0 version 2:3.6.9-1ubuntu2~raring3 required, but 2:...

Read more...

tags: removed: need-i386-retrace
dino99 (9d9) on 2013-03-23
Changed in network-manager-applet (Ubuntu):
status: Invalid → New
dino99 (9d9) wrote :

That Apport retracing service needs to accept higher installed version (coming from a ppa, here gnome3-team) . It clearly does not care about the added tag "third-party-package"; tag automatically added by itself. So to be able to fill usefull bug report to ppa maintainer, apport have to be a bit more clever.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2015-02-15
Changed in network-manager-applet (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers