Network manager says disconnected but is connected and working

Bug #105234 reported by denzilla74
290
This bug affects 10 people
Affects Status Importance Assigned to Milestone
network-manager (Baltix)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Medium
sciuro
Nominated for Feisty by Marco Rodrigues

Bug Description

Binary package hint: network-manager

Since a recent update today sometime, network manager says I'm disconnected, but I have full access to the net and the connection is working fine. I can unplug/plug the cable and it will reconnect and show the correct status, until I restart.

Revision history for this message
Bradley Nampel (bnampel) wrote :

I can confirm this behavior.on a fully up-to-date Feisty install.

Changed in network-manager:
status: Unconfirmed → Confirmed
Revision history for this message
James Hall (james-hall-01) wrote :

Thanks for your bug report. This particular bug has already been reported and is a duplicate of bug 82927 and is being marked as such. Please feel free to report any other bugs you may find.

Revision history for this message
Brian Murray (brian-murray) wrote :

I don't believe there is sufficient evidence to indicate that this is a duplicate of bug 82927 and I am unmarking it as a duplicate.

Revision history for this message
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the full output of 'lspci -vv' and '/var/log/daemon.log' when you are experiencing the problem? Thanks in advance.

Changed in network-manager:
assignee: nobody → brian-murray
status: Confirmed → Needs Info
Revision history for this message
Bart Verstraete (bartverstraete) wrote :

Got the same thing, my regular network don't shows up, it says that I am disconnected. But it still works. And my Access points shows up but they got a signal strength of 0 and are grey.
My daemon.log is attached.

Revision history for this message
Bart Verstraete (bartverstraete) wrote :

My lspci -vv

Revision history for this message
Dan Bishop (danbishop) wrote :

I can also confirm this, the network manager applet now says "No network devices have been found"

Revision history for this message
Dan Bishop (danbishop) wrote :

My daemon.log

Revision history for this message
Guido Conaldi (guido-conaldi) wrote :

Can confirm on my Feisty 32bit up-to-date. It started misbehaving yesterday.

Revision history for this message
Guido Conaldi (guido-conaldi) wrote :
Revision history for this message
Andrew (at-macmillan) wrote :

I am having the same problem after an update done today.

Revision history for this message
Andrew (at-macmillan) wrote :
Revision history for this message
Harryc (harryc56) wrote :

Same problem on a fully up top date Feisty install.

Revision history for this message
Harryc (harryc56) wrote :
Revision history for this message
Felix Heinonen (fheinonen) wrote :

Same problem here.

Revision history for this message
Felix Heinonen (fheinonen) wrote :
Revision history for this message
wlx (wangliangxu) wrote :

same problem here.

Revision history for this message
Matthew Nuzum (newz) wrote :

Just updated today (April 11) and this problem started happening. Attached is lspci -vv. Daemon log will be attached next.

Revision history for this message
Matthew Nuzum (newz) wrote :
Revision history for this message
Mackenzie Morgan (maco.m) wrote :

lspci

Revision history for this message
Mackenzie Morgan (maco.m) wrote :

Mine connects on wireless, claims to be disconnected, and works just fine. It still shows the lists of networks and all. And wireless still works fine. It just says my wired connection is disconnected while it's fully functional (like now). When the sky2 driver goes *death* (because it's a yicky driver), NM doesn't switch to "disconnected" so I'll be looking at it going "it says I'm connected why isn't $WEBSITE loading?" though now I've come to realize that that means my driver crapped out as usual and just unload/reload the module. When I unload, it, *then* it says I'm disconnected and goes and grabs a [man-in-the-middle attack ad-hoc with the same SSID as the school one] wireless network.

Revision history for this message
Mackenzie Morgan (maco.m) wrote :

Ah! I meant "mine connects on wired" on boot and claims to be disconnected. Sorry, like I said, wireless works fine (or at least it wasn't telling me I'm disconnected from wireless this morning when I updated it).

Revision history for this message
Rob Dian (robdian) wrote :

Same here. Showing as "no network connection" but everything works fine.

Revision history for this message
Rob Dian (robdian) wrote :

lspci

Revision history for this message
Daniel Botelho (botelho-daniel) wrote :

Hello! I've the same problem.. Today I'v updated the network-manger from the "Update Manger" and know it's not working properly.
Well actually it's working, but after I've done the update now it says "No network connection"(when move mouse over it) and if I right click in it, it says "No Network devices found".
If I execute the command "ifconfig" on the console it's working nicely and I can still use the internet, but basically I can't use the GUI.

Revision history for this message
mountain (nik-kufstein) wrote :

Same problem, but also when i disable the wireless network the whole system hangs and stops responding.

output off my daemon.log

Apr 11 18:55:50 TUX NetworkManager: <information>^IDeactivating device rausb0.

So it is disabling the wireless but the system hangs and isnt responding.

I noticed this behaviour on older versions off the network manager also.
Older versions deactivated my lo interface the 127.0.0.1 localhost, but this version crashes the system.

Revision history for this message
Mackenzie Morgan (maco.m) wrote : Re: [Bug 105234] Re: Netowrk manager says disconnected but is connected and working

Others are having it say no network devices found when they right click. While mine is saying it's disconnected when it's actually connected and working, it does drop down the "enable wired / enable wireless" thing when I right click.

Revision history for this message
lizardmenke (lizardmenke) wrote : Re: Netowrk manager says disconnected but is connected and working

Same here :after yesterday's update NM says it's not connected but everything works fine (wired connection)

Revision history for this message
yostral (y-o) wrote :

Same problem here too.
On startup it says non connection, but the connection is ok. I have to select a connection (wired or wifi) to have the "normal" behaviour back.

Revision history for this message
Soul-Sing (soulzing) wrote :
Changed in network-manager:
status: Needs Info → Confirmed
Revision history for this message
denzilla74 (denzilla74-deactivatedaccount) wrote :

Just got a network manager update and problem remains. Here are the logs you requested:

Revision history for this message
xtknight (xt-knight) wrote :

This seems to fix it. Not sure if it's a hack or not but even if it is I can't see the side effects.

Revision history for this message
Wenzhuo Zhang (wenzhuo) wrote :

I am afraid 0.6.4-6ubuntu6 does not fix the problem on my laptop. I have restarted Gnome.

Revision history for this message
Christoph Donges (cdonges) wrote :

Same issue for me too. Shows I am disconnected with a wired connection even though I am.

Changed in network-manager:
importance: Undecided → Medium
assignee: brian-murray → nobody
Revision history for this message
os2mac (os2mac) wrote :

I have reported a similar bug to Knetworkmanager for kubuntu Bug #105352. Mine is a wireless connection.

1 comments hidden view all 143 comments
Revision history for this message
James (chiisu81) wrote :

Same as Wenzhuo Zhang stated, latest update still shows this problem

Revision history for this message
os2mac (os2mac) wrote :

are we sure this is a network-manager thing and not a GUI thing.. My bug appears in Knetworkmanager but if I run Kwifimanager it works just fine.

Revision history for this message
Dee (dee24) wrote :

Oh, I'm getting the same issue here... hmm, I wonder what the root of this problem could be.

Revision history for this message
Chris Malton (chrism-cjsoftuk) wrote :

Just updated to 0.6.4-ubuntu5, same problem exists!

The funny thing is, I have a network connection monitor applet showing I am connected!

Changed in network-manager:
assignee: nobody → keybuk
status: Confirmed → In Progress
Changed in network-manager:
status: In Progress → Fix Committed
Changed in network-manager:
status: Fix Committed → In Progress
Tollef Fog Heen (tfheen)
Changed in network-manager:
importance: Medium → Critical
Changed in network-manager:
status: In Progress → Fix Released
63 comments hidden view all 143 comments
Revision history for this message
Soul-Sing (soulzing) wrote :

that network-manager (baltix) status new, is this bug uptodate? or fixed with the other network-manager fix-released?

Revision history for this message
PresuntoRJ (fabio-tleitao) wrote : Re: [Bug 105234] Re: Network manager says disconnected but is connected and working

solved both manually and by regular updates.

the bug does not seem to propagate to newer versions.

2007/6/26, leoquant <email address hidden>:
>
> that network-manager (baltix) status new, is this bug uptodate? or fixed
> with the other network-manager fix-released?
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--

Fábio Leitão, RCDD

Revision history for this message
douglas ewing (ewingdouglas) wrote :

I concur with all above

On 27/06/07, PresuntoRJ <email address hidden> wrote:
>
> solved both manually and by regular updates.
>
> the bug does not seem to propagate to newer versions.
>
>
> 2007/6/26, leoquant <email address hidden>:
> >
> > that network-manager (baltix) status new, is this bug uptodate? or fixed
> > with the other network-manager fix-released?
> >
> > --
> > Network manager says disconnected but is connected and working
> > https://bugs.launchpad.net/bugs/105234
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
>
> --
>
> Fábio Leitão, RCDD
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Regards

Douglas

Revision history for this message
Alexander Sack (asac) wrote :

i guess baltix target was an accident ... invalid.

Changed in network-manager:
status: New → Invalid
Revision history for this message
Mikael (fitmik) wrote :

THIS BUG HAS BEEN FIXED A LONG TIME AGO NOW.

end of discussion.

2007/6/27, Alexander Sack <email address hidden>:
>
> i guess baltix target was an accident ... invalid.
>
> ** Changed in: network-manager (Baltix)
> Status: New => Invalid
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mikael FITOUSSI

Revision history for this message
Sebastien Wains (sebastienw-deactivatedaccount) wrote :

I installed Gutsy this morning and have the problem (the system is up to date).

I'm on a wired connection, using DHCP (fixed IP bound to MAC address).

$ lsb_release -src
7.10
gutsy

$ uname -a
Linux m201 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

$ dpkg -l network-manager
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nom Version Description
+++-======================-======================-============================================================
ii network-manager 0.6.5-0ubuntu9 network management framework daemon

Revision history for this message
Brian Murray (brian-murray) wrote :

Sebastien it would be helpful if you could open a new bug report about your specific issue and included the full output of 'sudo lspci -vvn', 'dmesg', '/var/log/daemon.log', 'sudo ethtool eth0' (where eth0 is the wired interface), and '/etc/network/interfaces'. Feel free to assign the bug report to me. Thanks in advance.

Revision history for this message
Luka Renko (lure) wrote :

Similar issue in bug 126494

Revision history for this message
Sebastien Wains (sebastienw-deactivatedaccount) wrote :

Requested info attached in bug report 126494

Revision history for this message
PresuntoRJ (fabio-tleitao) wrote : Invitation to connect on LinkedIn

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Fabio

Learn more:
https://www.linkedin.com/e/isd/411796717/qYmszuv5/

------------------------------------------

What is LinkedIn and why should you join?
http://learn.linkedin.com/what-is-linkedin/

------
(c) 2008, LinkedIn Corporation

Revision history for this message
John Vivirito (gnomefreak) wrote :

This is seen in Jaunty I will post additional information. reassigned to nobody in case Scott doesnt feel like working on it.

Changed in network-manager:
assignee: scott → nobody
milestone: ubuntu-7.04 → none
status: Fix Released → Incomplete
Revision history for this message
John Vivirito (gnomefreak) wrote :

here is a screenshot

Revision history for this message
John Vivirito (gnomefreak) wrote :

Output from sudo lspci -vvn and dmesg

Revision history for this message
John Vivirito (gnomefreak) wrote :

Here is /etc/network/interfaces

Revision history for this message
John Vivirito (gnomefreak) wrote :

Here is /var/log/daemon.log

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Changing to Confirmed since this bug has been confirmed for Intrepid and Jaunty.

Changed in network-manager:
status: Incomplete → Confirmed
Revision history for this message
Alexander Sack (asac) wrote :

this isnt critical. its a problem displaying connect status if you have unmanaged devices. I agree however, that the applet can be confusing, hence medium

Changed in network-manager:
importance: Critical → Medium
Changed in network-manager-applet:
status: Confirmed → Triaged
Revision history for this message
Andrea Marin (amarin) wrote :

Hi all,

i have the same problem in my new fresh upgrade from 8.04 to 8.10
I have upgrade not from a CD, but online with update manager new release.

How can i help to resolve this?

Thanks for all your job.

Revision history for this message
Daniele (daniele-levorato) wrote :

Me too. Just upgraded from 7.10 to 8.04 and from 8.04 to 8.10.
Wired connection not detected. The applet says something (in italian) like it's an unmanaged device.
But connection is still working as it was configured in 7.10 ...

Revision history for this message
ubu-for (ubu-for) wrote :

I have the same problem with Jaunty Beta!

Revision history for this message
Ebrahim (emakda) wrote :

I am having the same problem after an update done today. Network Applet shows disconnected:(.

Revision history for this message
Ari (ari-reads) wrote :

I've been experiencing this problem for many months in my two ubuntu desktops. In the beginning I had unmanaged devices in /etc/network/interfaces; however I deleted all the manually configured stuff there, and networkmanager applet is still broken. I have wireless, and it doesn't show up.

I'm wondering if there a way to safely "reset" /etc/network/interfaces (or whatever config files the applet is looking at)

Revision history for this message
Christoph Donges (cdonges) wrote : Re: [Bug 105234] Re: Network manager says disconnected but is connected and working

unsubscribe

On Wed, Apr 1, 2009 at 2:01 PM, Ari <email address hidden> wrote:

> I've been experiencing this problem for many months in my two ubuntu
> desktops. In the beginning I had unmanaged devices in
> /etc/network/interfaces; however I deleted all the manually configured
> stuff there, and networkmanager applet is still broken. I have wireless,
> and it doesn't show up.
>
> I'm wondering if there a way to safely "reset" /etc/network/interfaces
> (or whatever config files the applet is looking at)
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
zeddock (zeddock) wrote :

Problem is appearing in Jaunty too.
zeddock

On Wed, Apr 1, 2009 at 12:12 AM, Christoph Donges <email address hidden> wrote:

> unsubscribe
>
> On Wed, Apr 1, 2009 at 2:01 PM, Ari <email address hidden> wrote:
>
> > I've been experiencing this problem for many months in my two ubuntu
> > desktops. In the beginning I had unmanaged devices in
> > /etc/network/interfaces; however I deleted all the manually configured
> > stuff there, and networkmanager applet is still broken. I have wireless,
> > and it doesn't show up.
> >
> > I'm wondering if there a way to safely "reset" /etc/network/interfaces
> > (or whatever config files the applet is looking at)
> >
> > --
> > Network manager says disconnected but is connected and working
> > https://bugs.launchpad.net/bugs/105234
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
Mikael (fitmik) wrote :

Im still having this problem in 9.04 too. And on 2 different computers: one based on the nforce4 chip and another "new" asus p5qpro.
Both use pppoe to connect to the internet.
Weird to see that has not been fixed. I have this bug since 2 years now!
Its not really important (only cosmetic) but its something (the disconnect icon) that you see 24/7 when you use your computer!

Revision history for this message
Detlef Lechner (detlef-lechner) wrote :

I have got the same error after dist-upgrading from 8.04.2 via 8.10 to 9.04.

Revision history for this message
Detlef Lechner (detlef-lechner) wrote :

My nm-applet icon is shown with a red square having a diagonal cross in it. Hovering over it the tooltip "No network connection" appears. After issuing the command 'sudo dhclient eth0' I have LAN access via eth0 but the nm-applet's look remains the same.
(If I de-assert System >Preferences > Network Manager and reboot, there will appear no nm-applet. But if I issue the command 'sudo dhclient eth0' I will have LAN access via eth0.)
Right-click in the nm-applet > Edit Connections... > Network Connections > Wired allows me to add an entry 'eth0' with the parameters 'MAC address=00:04:0E:6A:0C:C6' MTU=automatic, Address=164.168.178.24, Netmask=255.255.255.0 Gateway=0.0.0.0, 'DNS Servers=192.168.178.1' but this entry shows always a 'never' state report.

Revision history for this message
Detlef Lechner (detlef-lechner) wrote :
Revision history for this message
sciuro (sciurognathi) wrote :

Network Manager functionality is changed!
Read about it in /usr/share/doc/network-manager/README.Debian.

In short, if interface is (properly or not) configured in /etc/network/interfaces file, Network Manager will not manage it. If there are no other interfaces for NM to manage, NM thinks that there are no network connections.
You may try to comment out any configuration of eth0 in interfaces file, so network manager picks it up for management.

There is also solution to put NM in managed mode as mentioned in README.Debian.

Changed in network-manager-applet (Ubuntu):
assignee: nobody → sciuro (sciurognathi)
status: Triaged → Invalid
Revision history for this message
jerryb (gerald-britton) wrote :

If what you say is true, then there is indeed no bug in Network
Manager. Rather, there is a serious design flaw. In no circumstance
should NM report that there are no active network connections when
indeed said connections are active and healty.

On Sun, Jun 7, 2009 at 6:17 AM, sciuro<email address hidden> wrote:
> Network Manager functionality is changed!
> Read about it in /usr/share/doc/network-manager/README.Debian.
>
> In short, if interface is (properly or not) configured in /etc/network/interfaces file, Network Manager will not manage it. If there are no other interfaces for NM to manage, NM thinks that there are no network connections.
> You may try to comment out any configuration of eth0 in interfaces file, so network manager picks it up for management.
>
> There is also solution to put NM in managed mode as mentioned in
> README.Debian.
>
> ** Changed in: network-manager-applet (Ubuntu)
>       Status: Triaged => Invalid
>
> ** Changed in: network-manager-applet (Ubuntu)
>     Assignee: (unassigned) => sciuro (sciurognathi)
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Gerald Britton

Revision history for this message
jerryb (gerald-britton) wrote :

The fact that NM is changed is interesting. The experience that it now reports no active network connections when indeed such connections exist and are active, means that the change is very much for the worse and reflects a serious design flaw.

I know that it is popular to wave the "functioning as designed!" flag, but when the design is so obviously incorrect, that is mere sophistry.

Fix it!

Changed in network-manager-applet (Ubuntu):
status: Invalid → New
Revision history for this message
memartin (memartin) wrote :

I find it a disgrace that the bug is around for years now and is still present in Lucid beta.

When I plug my network in, the icon changes to the "working" state, hover says something like connecting. It sets up the connection (local DHCP) to work perfectly, yet the icon shows the plug and socket as separate (unplugged), while the hover says "connected". See the attached image. I second the opinion that there must be flaw hidden in that picture.

BTW: Interface eth0 is NOT at all configured in /etc/network/interfaces.

Thanks for having another look at it.

Revision history for this message
Nizar Kerkeni (nizarus) wrote :

@memartin : according to the screen shot your are using kubuntu, right ?

Revision history for this message
Christoph Donges (cdonges) wrote :

unsubscribe

On Sat, Apr 17, 2010 at 4:30 AM, Nizar Kerkeni <email address hidden> wrote:
> @memartin : according to the screen shot your are using kubuntu, right ?
>
> --
> Network manager says disconnected but is connected and working
> https://bugs.launchpad.net/bugs/105234
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
memartin (memartin) wrote :

@nizar: Yes, that's right. Sorry for not making that clear in the post. I'm using Kubuntu Lucid beta on an IBM Thinkpad T42.
I've seen a few posts regarding Kubuntu here and thought it would be safe to share my voice. Of course, if the bug was in the NM Plasma-applet, this would be the wrong place to complain...

Revision history for this message
Brian Murray (brian-murray) wrote :

network-manager-applet displays the connectivity state of network-manager's managed interfaces not every interface. So the title "network manager says disconnected but is connected and working" is actually misleading. The interface is connected and working but not from network-manager's point of view since it is not managing the interface.

Additionally, in Lucid now network-manager applet displays nothing now for non-managed interfaces so is less misleading. You can check to see whether or not an interface is managed by network-manager by using the command line too nm-tool. You'll see "State: unmanaged" for unmanaged interfaces.

Changed in network-manager-applet (Ubuntu):
status: New → Won't Fix
Revision history for this message
memartin (memartin) wrote :

@Brian: Here's my output of nm-too (as user)l:

----
NetworkManager Tool

State: connected

** (process:4950): WARNING **: <WARN> get_one_connection(): error: invalid connection: 'NMSettingGsm' / '(null)' invalid: 3

** (process:4950): WARNING **: <WARN> get_one_connection(): error: invalid connection: 'NMSettingWireless' / 'mac-address' invalid: 1

- Device: eth0 [Auto eth0] ----------------------------------------------------
  Type: Wired
  Driver: e1000
  State: connected
  Default: yes
  HW Address: 00:11:25:80:CE:04

  Capabilities:
    Carrier Detect: yes
    Speed: 100 Mb/s

  Wired Properties
    Carrier: on

  IPv4 Settings:
    Address: 10.1.44.69
    Prefix: 24 (255.255.255.0)
    Gateway: 10.1.44.254

    DNS: 10.1.44.254

- Device: eth1 -----------------------------------------------------------------
  Type: 802.11 WiFi
  Driver: airo
  State: disconnected
  Default: no
  HW Address: 00:0E:9B:8C:B5:91

  Capabilities:

  Wireless Properties
    WEP Encryption: yes

  Wireless Access Points
   <snipped>

----

While nm-tool reports the wired LAN as connected, the plasma applet shows no change to what I reported previously. The icon shows disconnected state, mouse hover over the icon says "connected". This is with Kubuntu Lucid beta with all recent upgrades.

I understand that from your point of view everything is "working as expected". Yet, what I (and supposedly other users) see in their GUI is flawed.

Is there a possibility for you to push the bug to a more appropriate project where you would assume the error to come from? Or I'd gladly contribute to a bug elsewhere if someone could help me find it.

TIA, Martin

Revision history for this message
FiReSTaRT (dlyh) wrote :

Just to make a note that it's still happening with stable Lucid64. Worked fine for a while, but now it's broken. Sometimes, rebooting helps, but these days even that's not a guaranteed fix.

Revision history for this message
Brian Murray (brian-murray) wrote :

@memartin your bug, which should be a new one by the way, either needs to be reported about plasma-widget-networkmanagement or network-manager-kde depending on which one you have installed.

Displaying first 40 and last 40 comments. View all 143 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers