FFE: Behavior when policy limits access to nm-applet functions is inconsistent / should hide disallowed actions

Bug #1043929 reported by Mathieu Trudel-Lapierre on 2012-08-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

TL;DR: two things to be added:
- Fix the inconsistencies, make sure all the locked-down functions are insensitive when disallowed;
- Add support to hide rather than desensitize disallowed functions.

The UI behavior is inconsistent in the applet; basically, if some functions are disallowed from the UI, some items will appear insensitive in the menu, while others will be accessible and fail due to permissions. All disallowed functions should be triggering a case where the menu items are insensitive.

Also, there ought to be a way to hide these items from the menu when desired, to avoid confusing users. Not by default, because default settings don't actually currently lock any of the applet functions, but the possiblity should be allowed.

Attaching the diff that actually implements these changes...

Stéphane Graber (stgraber) wrote :

Approved, if you want this in beta1 and before the UI freeze, make sure to upload before 21:00 UTC today.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.6.2-0ubuntu2

---------------
network-manager-applet (0.9.6.2-0ubuntu2) quantal; urgency=low

  * debian/patches/position_dialogs_to_center_of_the_screen.patch: make sure
    created dialogs (like password requests) are properly centered on the
    screen. (LP: #1043934)
  * debian/patches/make_menu_items_invisible_based_on_permissions.patch,
    debian/patches/hide_policy_items_env_var.patch: items that are disallowed
    by the effective PolicyKit policy for a user should be consistently showing
    as such: they should either be insensitive (greyed), or hidden altogether.
    (LP: #1043929)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 30 Aug 2012 14:27:42 -0400

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
Ritesh Khadgaray (khadgaray) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers