[hardy] RTL8185L driver not working

Bug #176507 reported by Shawn vega
32
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
network-config (Ubuntu)
Undecided
Unassigned

Bug Description

i have ubuntu hardy 8.04 and a gatway mx3414 with a RTL8185L wireless card and Ubuntu will not load the driver for it

Revision history for this message
Shawn vega (svega85-gmail) wrote :

after latest updates my wireless is not in the network manager at all it won't even let me select wether or not to enable wireless. and when i go to the network settings everything is greyed out, so i cant change anything also my wireless card isn't there either.

Revision history for this message
Shawn vega (svega85-gmail) wrote :

I don't think it's loading the driver
from lshw:
*-network UNCLAIMED
             description: Ethernet controller
             product: RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller
             vendor: Realtek Semiconductor Co., Ltd.
             physical id: 9
             bus info: pci@0000:06:09.0
             version: 20
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: latency=64 maxlatency=64 mingnt=32

description: updated
Revision history for this message
Shawn vega (svega85-gmail) wrote : Re: [hardy] RTL8185L driver not autodetected

06:09.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller [10ec:8185] (rev 20)
 Subsystem: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller [10ec:8185]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 64 (8000ns min, 16000ns max), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at 6000 [size=256]
 Region 1: Memory at b3400000 (32-bit, non-prefetchable) [size=512]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Revision history for this message
brett (brett-hosking) wrote :

Reading on the internet this works on Fedora 9... I think the driver has been added within kernel 2.6.25.

Can we include this driver in the Ubuntu Hardy kernel?

Revision history for this message
jonathanjackson (jjacks30) wrote :

Has there been any new progression regarding this issue? I am having the same problem.

Revision history for this message
Shawn vega (svega85-gmail) wrote :

well i just ended up installing the windoze drivers with ndiswrapper

Revision history for this message
jonathanjackson (jjacks30) wrote :

I will go ahead and look into the nidswrapper. Did you end up using the XP driver or the newer Vista driver?

Thanks much,

Jonathan

Revision history for this message
Shawn vega (svega85-gmail) wrote :

this is the one i used this XP one that's attached. not sure where i got it from. that's why i'm attaching it.

Revision history for this message
jonathanjackson (jjacks30) wrote :

That worked wonderfully!! Thanks so very much!

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Guys,

Sorry this may have been getting overlooked since beginning with the Hardy development cycle kernel bugs should be reported against the "linux" package. This obviously is not known by everyone so sorry for any confusion and the delayed response.

It does appear the upstream kernel has the rtl8180 driver which also supports rtl8185 cards. The kernel team is actively pulling together the Intrepid Ibex 8.10 kernel which will contain this newer driver. It should be available to test in the near future. I'll try to update you when I see it is available. You could also attempt to build the upstream kernel if you're ambitious. I'm not positive if the kernel team will backport the driver to Hardy but I will reassign this bug report to them for their consideration. Thanks.

Changed in linux-source-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Ah, or better yet, try the 2.6.25 package one of the ubuntu kernel devs has available under their PPA:

https://launchpad.net/~timg-tpi/+archive

Thanks.

Revision history for this message
Shawn vega (svega85-gmail) wrote :

so will the next kernel released on hardy have the fix?

Revision history for this message
Emilio (emilio-moretti) wrote :

I've got the same problem on the 64 bit version, and it's worse, because on the 32bit version this bug can be avoided using ndiswrapper and the oficial realtek drivers for winxp, but it doesn't work on 64 bit systems because of another bug on ndiwrapper.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Shawn,

It would be good to get confirmation that the driver that exists upstream actually works for you. If you can test the Intrepid kernel which is already rebased with the upstream 2.6.25 kernel and contains the driver of interest that would be great:

http://ppa.launchpad.net/kernel-ppa/ubuntu/pool/main/l/linux/

It's up to the kernel team if they will backport for the Hardy 8.04.1 release. However, I doubt they'll do that without confirmation that the upstream driver works. At the very least, you'll have an option of running the Intrepid kernel which will provide support for you card (assuming the upstream driver works). Hope that helps. Thanks.

Revision history for this message
Shawn vega (svega85-gmail) wrote :

I installed linux-image-2.6.25-1-386_2.6.25-1.2ubuntu2_i386.deb linux-headers-2.6.25-1_2.6.25-1.2ubuntu2_all.deb, then restarted but it still doesn't work
uname -a Linux shawn-laptop 2.6.25-1-386 #1 Fri May 2 19:36:55 UTC 2008 i686 GNU/Linux
lshw *-network UNCLAIMED
             description: Ethernet controller
             product: RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller
             vendor: Realtek Semiconductor Co., Ltd.
             physical id: 9
             bus info: pci@0000:06:09.0
             version: 20
             width: 32 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: latency=64 maxlatency=64 mingnt=32

Revision history for this message
dukenukeme (slobodaninator) wrote :

Hi , patched RTL8185L Linux driver for kernel 2.6.22
this version from Realtek http://tinyurl.com/5dyy9b

ftp://210.51.181.211/cn/wlan/rtl8185_linux_26[1].1027.0823.2007.tar.gz

According to this patch (just changes in line numbers)
http://trac.aircrack-ng.org/attachment/ticket/378/rtl8187_2.6.22_to_2.6.24.patch

Needs to be unpacked and also to unpack
rtl8185.tar.gz
stack.tar.gz
before applying the patch

Note about rtl8187 patch,not shure is this corect in line 402
402 sg_set_page(&sg, virt_to_page(pos), len + 2, offset_in_page(pos));
and change'd it to len + 4 for rtl8185 please test it.

Tested on 32bit 2.6.24 kernel (slackware) and looks like it is working
More tests nedeed . Not tryed wpa_supplicant yet.

Revision history for this message
shclim (shclim) wrote :

Can we get the RTL8185L driver into Ubuntu 8.04.1? It looks as though many other new Wifi drivers will be included....

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Anyone care to test with the latest Alpha release for the upcoming Intrepid Ibex 8.10? http://www.ubuntu.com/testing . It is based off a 2.6.26 kernel. If you still experience issues, can you attach the following debugging information:

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies .

Also, I'm removing the linux-source-2.6.24 task since beginning with the Hardy development cycle kernel bugs should be reported against the 'linux' source package which this bug already is. Thanks.

Changed in linux-source-2.6.24:
status: New → Invalid
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

If on Hardy - care to actually try installing the linux-backport-modules package and see if that helps. It contains the rtl8180 driver (which also supports rtl8185). Thanks.

Changed in linux:
status: Triaged → Incomplete
Revision history for this message
Shawn vega (svega85-gmail) wrote :

someone else please test this i can nolonger help as i don't own that computer or wireless card anymore.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Maik Wagner (mtwagner) wrote :

I have been trying to get a "Logilink WL0002" to work. AFAIK it is also based on the 8185L chipset. It is an internal PCI-card.

I downloaded the Intrepid Beta last night and write this from the Intrepid-Beta Live-CD environment. From a fresh boot into the live CD environment "sudo lshw" gives me:

[snip]
           *-network:2
                description: Wireless interface
                product: RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 9
                bus info: pci@0000:02:09.0
                logical name: wmaster0
                version: 20
                serial: 00:0e:2e:e8:36:d5
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list logical ethernet physical wireless
                configuration: broadcast=yes driver=rtl8180 latency=64 maxlatency=64 mingnt=32 module=rtl8180 multicast=yes wireless=IEEE 802.11bg
[/snip]

Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Bryan Wu (cooloney) wrote :

I think this issue should be already fixed since Intrepid kernel. So i will set the status to "fixed in release". If some one found similar issue on Jaunty, please fire new bug.

Thanks
-Bryan

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in network-config (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.