should find fastest ubuntu mirror not debian

Bug #55671 reported by Andrius
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netselect (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

should find fastest ubuntu mirror not debian

Revision history for this message
Vassilis Pandis (pandisv) wrote :

Confirming this .... it requires significant changes to the netselect-apt script.

Changed in netselect:
status: Unconfirmed → Confirmed
Revision history for this message
Sebastian Heinlein (glatzor) wrote :

I work on a python script that uses the abstraction of the sources.list available in aptsources from update-manager.

Revision history for this message
Sebastian Heinlein (glatzor) wrote :

A prototype for a replacement of netselect-apt.

Open issues:
 * works only on edgy (update-manager needs a fix in feisty)
 * relies on update-managers hardcoded list of mirrors, to identify Ubuntu servers in the sources.list. So some recently added mirrors could not be detected.
 * no dry run option
 * needs testing ...

Changed in netselect:
status: Confirmed → In Progress
Revision history for this message
Martin Heitzer (martin-heitzer) wrote :

Isn't this bug fixed by the package software-properties-gtk?

Revision history for this message
DanWei (danielweigl) wrote :

netselect-apt still searches debian mirrors. If this bug/feature is solved by an other programm, remove netselect-apt from ubuntu to prevent users messing up the sources.conf.

But a commandline tool would be fine - i dont like to use synaptic for that.

Daniel

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

Agreeing with DanWei that this needs to be fixed, maybe before its second birthday.

Marked https://bugs.launchpad.net/ubuntu/+source/netselect/+bug/157938 as a duplicate of this bug.

Revision history for this message
Andrius (andrius-andrius) wrote :

yah, now soon will be two years when this completely broken and shameless package is in ubuntu repository which can completely break whole ubuntu.. Is that hard to put ubuntu mirror list and modify url in package?

Revision history for this message
Andrius (andrius-andrius) wrote :

Please consider making integrated product of apt/aptitude/netselect/axel for downloading packages in most efficient and fastest way. The download list can be based on dependancy tree, so some packages can be installed while other are still being downloaded.

http://unix.freshmeat.net/projects/apt-axel/

Revision history for this message
ironstorm (ironstorm-gmail) wrote :

If this is not going to be fixed I think we'd better off having it excluded from Ubuntu... Since it in no way serves its purpose or helps Ubuntu users.

Revision history for this message
Luis F. Lopez (luis.lopez) wrote :

This package should not be inherited from upstream. A new package should be created specifically for ubuntu

Revision history for this message
Martin Pitt (pitti) wrote :

2008-10-13 08:02:36 INFO Removing candidates:
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid amd64
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid hppa
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid i386
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid ia64
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid lpia
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid powerpc
2008-10-13 08:02:36 INFO netselect 0.3.ds1-12 in intrepid sparc
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid amd64
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid hppa
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid i386
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid ia64
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid lpia
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid powerpc
2008-10-13 08:02:36 INFO netselect-apt 0.3.ds1-12 in intrepid sparc
2008-10-13 08:02:36 INFO Removed-by: Martin Pitt
2008-10-13 08:02:36 INFO Comment: Debian specific, never worked for Ubuntu, LP #55671, LP #275280
2008-10-13 08:02:37 INFO 15 packages successfully removed.

Changed in netselect:
status: In Progress → Fix Released
Revision history for this message
Eugene van der Merwe (eugene-snowball) wrote :

Just wondering if there was ever an alternative published for netselect-apt that exists in Debian. I am looking for a command line alternative and this seems like a really good utility. Some other people asked this on the mailing list and got now answer:
https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-October/006088.html

Revision history for this message
Hsin-Yi, Chen (hychen) (ossug-hychen) wrote :

You can try this script I wrote,

https://launchpad.net/getfastmirror

user@hsot$ sudo cp /etc/apt/source.lsit /etc/apt/source.list.old
user@host$ sudo getfastmirror > /etc/apt/source.list

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments