please restore netselect package: it's _not_ debian-specific

Bug #337377 reported by Zed Lopez on 2009-03-03
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
Nominated for Lucid by Zed Lopez
netselect (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Zed Lopez

Bug Description

Binary package hint: netselect

As described here:

https://bugs.launchpad.net/ubuntu/+source/netselect/+bug/275280

the netselect package was removed in intrepid. The justification is mistaken: while the netselect-apt package that depends upon netselect is debian-specific and is better off omitted (if not entirely rewritten), netselect itself is a general tool with nothing debian-specific about it.

The problems that omitting it were meant to fix can be fixed entirely by continuing to omit netselect-apt while putting netselect back in.

Luke Faraone (lfaraone) on 2009-11-12
Changed in netselect (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Steven Armstrong (sa+launchpad) wrote :

You are excluding a generic sysadmin tool from the distribution just because of a stupid misunderstanding.

Could someone please fix this asap?

Now I have to go fiddle with debian packages on our ubuntu installations just because someone had no clue what he was doing :-/

Antonis Kanouras (akanouras) wrote :

Hello, this tool can be used for many purposes other than "selecting the fastest Debian mirror".

For example: Just now I had a big list of IPv6 tunnel brokers and wanted to find which one of them had the least latency for me.

Please restore it and disable the "netselect-apt" part of it, which obviously isn't useful to Ubuntu by default without an Ubuntu mirror list.

Lastly, you may take the following as a rant: Just because a mirror is in the same country, it doesn't necessarily mean it's the fastest or most frequently updated. Right now I'm using nl.archive.ubuntu.com even though I'm in Greece, as NTUA's mirror broke down once again a few days ago, and before that, Otenet (my ISP) stopped updating theirs a few months ago as well.

Cheers,
Antonio

Axel Beckert (xtaran) wrote :

It would be even better if the netselect-apt package would be modified to use Ubuntu's list of mirrors instead of Debian's one. Then the netselect-apt package would be also useful in Ubuntu.

Rolf Leggewie (r0lf) wrote :

I hope this will come back to Ubuntu soon. In the meantime I have uploaded the latest Debian release to my stable PPA for your convenience.

https://launchpad.net/~r0lf/+archive/ubuntu/stable

affects: netselect (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Wishlist → Medium
borninbronx (daniele-segato) wrote :

10 years now and this package is still out of Ubuntu for no reason whatsoever.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers