Update to netplan.io 0.98 release

Bug #1840832 reported by Mathieu Trudel-Lapierre on 2019-08-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netplan.io (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]
This release contains both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these improvements.
The notable ones are:

    - Added new "feature flags" to identify new features
    - Added support for "use-domains" for DHCP overrides
    - Added support for setting IPv6 MTU Bytes (LP: #1671951)
    - Added a DBus interface to query and run 'netplan apply' via other apps
    - Various build system fixes
    - Improved validation for bonding modes
    - Added support for "hash:" for hashed 802.1x passwords (LP: #1819831)
    - Tolerate devices without a /sys path (LP: #1810043)
    - Fix incorrect separator for networkd with ARP IP targets (LP: #1829264)

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/NetplanUpdates

Netplan contains an extensive integration test suite that is ran using
the SRU package for each releases. This test suite's results are available here:
http://autopkgtest.ubuntu.com/packages/n/netplan.io

A successful run is required before the proposed netplan package
can be let into -updates.

The netplan team will be in charge of attaching the artifacts and console
output of the appropriate run to the bug. Netplan team members will not
mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

= Per-release, per-arch test artifacts =

tbd

[Discussion]
This addresses in priority an important issue with integration of netplan with openvswitch; where devices are hard to bring up to hand over to openvswitch: behavior was changed such that as soon as a device is listed in netplan config (even without an IP), it gets brought online by the networkd renderer. This is consistent with the idea of having only configured interfaces touched by netplan; if the name of the itnerface appears in netplan YAML, it gets configured (albeit without IP).

[Changelog]
9ea105b Drop NETPLAN_VERSION not in spec for feature flags
2f282a0 Fix typo in doc
402390f Really fix test_bond_arp_targets_many_lp1829264: can't read() the same thing twice
d0b93e3 Fix order of parameters for arp_ip_targets bug test; assertIn wants expected, output
61eb382 Add feature flags for new use-domains and ipv6 mtubytes features
1662819 Make the DBus 'NoSuchCommand' test less dependent on versions of DBus
b1de740 Add test for DBus Info method
ed17088 Drop -renderer check in info tests, fails because we don't list renderers
c13ef8d Make more small fixes to Makefile to cleanup doubled-up slashes
97f5a50 Drop netplan-features flags for NM and networkd renderers for now
d60072a Drop dead files for C Python module version info
8ba9afe io.netplan.Netplan.service.in: add assumed apparmor label
f39f2be Add a 'netplan info' command (feature-flags spec)
5d22e9d Add support for UseDomains override to DHCP
76bbf79 Bonding mode validation
d068d9d document ipv6-mtu
d93b6c1 write IPv6MTUBytes to the .network file
8878a6f support for parsing ipv6-mtu on all netdev types
67872af .gitignore: ignore the dbus generated svc unit file
0231f99 tests/dbus: add tests for apply in a snap using dbus
147a4bf cli/apply: use dbus if inside a snap
0c8e5fe make output more deterministic and fix tests
95305a1 doc: clarify that bonding parameters up/down-delay only apply to miimon monitoring
178ab45 Makefile: add tests/generator/*.py to PYCODE
5c0d66c Honor LDFLAGS when linking the generator
be2a3a1 Stylistic change.
b5faf4a Add tests for the new hash: password support.
2f159b9 fix indentation
d9767fb Support hashed passwords for 802.1x
495263a tests: rework dbus test to work with older python versions
2d60fae add dbus based "netplan apply" interface
7a1127f Tolerate devices without a /sys path
ee94ec1 Fix incorrect separator for networkd with ARP IP targets (LP: #1829264)

tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.98-0ubuntu1

---------------
netplan.io (0.98-0ubuntu1) eoan; urgency=medium

  * New upstream release: 0.98 (LP: #1840832)
    - Added new "feature flags" to identify new features
    - Added support for "use-domains" for DHCP overrides
    - Added support for setting IPv6 MTU Bytes (LP: #1671951)
    - Added a DBus interface to query and run 'netplan apply' via other apps
    - Various build system fixes
    - Improved validation for bonding modes
    - Added support for "hash:" for hashed 802.1x passwords (LP: #1819831)
    - Tolerate devices without a /sys path (LP: #1810043)
    - Fix incorrect separator for networkd with ARP IP targets (LP: #1829264)
  * debian/control: Add Build-Depends on libsystemd-dev for DBus feature, and
    on dbus-x11 for dbus-launch used in tests.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 21 Aug 2019 14:49:16 -0400

Changed in netplan.io (Ubuntu):
status: New → Fix Released
Roy Belio (rtk217) wrote :

This version is very crucial and important to out latest product which relies on the use-domains configuration option.
Since this fix is already released can you give a schedule as to when it will be available in Bionic updates?

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.98-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Mathieu, or anyone else affected,

Accepted netplan.io into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.98-0ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers