Backport netplan.io 0.40 to bionic

Bug #1793309 reported by Mathieu Trudel-Lapierre on 2018-09-19
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
netplan.io (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
All users of Ubuntu with network configurations using netplan.yaml.

[Test case]
1) Configure network via netplan.yaml for the feature one wants to verify.

Individual bugs have been opened for separate bugs fixed / features added.

1) Run autopkgtests for regressions in the various features.
2) Validate that autopkgtests are not regressing (no failures) or that any failures that exist are due to well known factors that couldn't otherwise be accounted for (ie. delay in interface bringup due to testing infrastructure).

[Regression potential]
Please see the individual bugs for test cases / regression potential on a per-bugfix / per-feature case.

New software versions are always a potential risk factor in supported Ubuntu releases. This should be seen as a hardware enablement fixes, where support for various common networking scenarios were added (anonymous bridges, optional addresses, link-local addressing for ipv4 and ipv6). New issues should be investigated on a case by case basis as this is a backport from the current devel series, for what is reproducible on the devel series and what might be an actual failure in netplan's generation of configuration files vs. issues in the networking backends.

---

Let's backport netplan.io 0.40 to bionic; as per policy for netplan.io releases.

Given that it's a core component of the networking story, and new features, bugfixes, etc. are regularly added in the development release, this should be updated all the way "down" to the current supported LTS as well.

The following changes happened in netplan.io since the last upload in 18.04 (new features marked with an asterisk, everything else bugfix):

0bf20a4 tests/generate.py: use random.sample() instead of random.choices() to better support older pythons.
41a32a6 releasing package netplan.io version 0.40
00675ae Finish updating changelog for release.
163a00c Fix integration tests
4879eae doc: add optional-addresses documentation
* 7e7d7f4 Add parsing for optional-addresses parameter
65ab77d remove duplication of link handlers
ad14292 Update changelog for new bugfix release
269827f Fix typo in NM on-link route error check
8096e4b NetworkManager: error on unrenderable route
1985d47 networkd: route source is PreferredSource= not From=
78d75c8 Don't render dns-search for ipv4 when no addresses configured
d40cd2f Route type is "prohibit", not "prohibited"
ecc04b1 Set permissive umask on networkd .network and .netdev files
5017b88 lint: fix invalid spacing
38b5e28 tests: add error test for missing 'to' for a link scope route
b4f4c63 Fix support for link-scope routes
cba85e3 Merge pull request #38 from daxtens/grat_arp
81a0aa5 Merge pull request #41 from daxtens/replug-doc-fix
0e795ff Merge pull request #45 from jsoref/spelling
e60d7de Merge pull request #44 from jsoref/github-markdown-make-checks
59b37b4 spelling: unsupported
72ec3ae spelling: successfully
f43d72c spelling: referring
0c629da spelling: occurred
2a89fd9 spelling: nonexistent
757be45 spelling: definitions
f238980 spelling: advertisement
1586703 Use markdown for make check verbs
* 28c9970 Update man pages for deletion of replug code
a11942b Spell Gratuitous ARP correctly and make it work
08c3439 releasing package netplan.io version 0.39
b9f1f98 * New upstream release: - Allow link-local addresses to be configured. (LP: #1771704) - Forces bridges with no addresses to be brought online. (LP: #1736975)
0e92dd5 doc: update doc for anonymous bridge and isolated (no iface members)
e4bd458 integration: add test for isolated (no address) bridge bringup
* 978e20f Always configure virtual interfaces even if they don't have a carrier
* 30c3295 Make link-local addresses configurable
839e28b releasing package netplan.io version 0.38
392f7cf tests: cleanup for the eth_and_bridge autopkg test
* 32d7c32 Better handle renaming: shouldn't rename unless there is an explicit 'set-name' key in config.
d694291 Skip possible renderer: entry for a device type
9b03382 Be better at checking for matching driver/mac in apply
3690087 Update PR template: any schema changes must be documented in doc/netplan.md
c39d891 Add PR template
3e43e29 Add TODO file
35a1fbb Add python3-netifaces to Depends, Build-Depends.
* 77ab99d Detect and apply interface naming changes on 'netplan apply'
f73bf3d Fix incorrect terminal reset in 'netplan try' on Ctrl-C. (LP: #1768798)
808b8cd Add bug tag for mtu doc update
a652679 Update changelog
27d71fe Be verbose when validate_docs test passes
fe555b8 try: only instanciate ConfigManager as needed, to ensure proper cleanup
51a6b1b debian/control: Add iproute2 to Depends.
f47bb3b Merge pull request #25 from slashdd/ip-leases
05f6149 Merge pull request #23 from raharper/fix/tempdir-cleanup
452eed4 Merge pull request #24 from teward/one-nic-multiple-ip-gateways
6c5f402 Merge pull request #27 from daxtens/validate-docs
c0ed9ba Merge pull request #28 from daxtens/manpages
d7d9d79 Merge pull request #30 from slashdd/lp1771440
998bd1a Merge pull request #32 from daxtens/master
8b79e0d tests: use late rules files
f2c15ce networkd: write .rules files to run as late as possible, so 99-netplan-.
2e35e28 Clean up after new .rules files
fd6824c Merge pull request #31 from daxtens/rules
b0c51bf Generate udev rules files to rename devices
d158eb9 tests/generate: rename assert_udev to assert_nm_udev
e8b05dd Fix double slash in yaml path file
7afef6a releasing package netplan.io version 0.37.1
60b8def Update changelog
b96b14f tests: various small fixes
940c2e3 ip leases: Add error handling when interface is not configured in netplan or not set to DHCP.
168c83e releasing package netplan.io version 0.37
8191dc9 Update changelog for release.
7e9ad0f docs: create man pages for netplan apply, generate and try
49e319e tests: add script to validate that all YAML keys are documented
9b2ca91 docs: "optional" cleanups
53a5703 docs: parser recognises "mark", not "fwmark"
158de36 docs: document "mtu" option
66e78ed Create static_singlenic_multiip_multigateway.yaml
abff9c9 Add example: One-NIC, multiple IPs/gateways
d6748fa Defer creation of ConfigManager tmpdir until needed

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in netplan.io (Ubuntu):
status: New → Confirmed
description: updated

netplan.io 0.40 landed in cosmic.

Changed in netplan.io (Ubuntu):
status: Confirmed → Fix Released

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.40~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Ryan Harper (raharper) wrote :
tags: added: regression-proposed
Łukasz Zemczak (sil2100) wrote :

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.40.1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: removed: regression-proposed

Autopkgtests are passing now for 0.40.1~18.04.1; and the individual bugs for features / bugfixes have all been verified. Marking verification-done.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.40.1~18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done-bionic

Verification done for bionic with netplan.io 0.40.1~18.04.2:

Autopkgtests are all passing (and passed first run); and invidividual bugs for this backport are all verification-done.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.40.1~18.04.2

---------------
netplan.io (0.40.1~18.04.2) bionic; urgency=medium

  * Fix typo breaking rename on 'netplan apply'. (LP: #1770082)

netplan.io (0.40.1~18.04.1) bionic; urgency=medium

  * Backport netplan 0.40.1 to 18.04. (LP: #1793309)

netplan.io (0.40.1) cosmic; urgency=medium

  * tests/generate.py: use random.sample() instead of random.choices() to
    better support older pythons.
  * Deal gracefully with empty files on 'netplan apply' (LP: #1795343)

netplan.io (0.40) cosmic; urgency=medium

  * New upstream release:
    - networkd: route source is PreferredSource= not From=
    - Improve NetworkManager error reporting on unrenderable routes.
    - Don't render ipv4 dns-search unless we have an ipv4 address.
      (LP: #1786726)
    - Set permissive umask on networkd .network, .link and .netdev files
      (LP: #1736965, LP: #1768560)
    - Fix support for link-scope routes. (LP: #1747455)
    - Update man pages for deletion of replug code.
    - Spell Gratuitous ARP correctly and make it work. (LP: #1756701)
    - Many typo fixes for documentation. (LP: #1783940)
    - Various build system fixes.
    - Fix integration tests:
      - iproute2 output changes for link-scope routes
      - fix stability of networkd igmp-resend test
      - fix manual_addresses test now that networkd lists ~. domain
    - Deduplicate code for parsing interface options
    - Add support for optional-addresses.

netplan.io (0.39) cosmic; urgency=medium

  * New upstream release:
    - Allow link-local addresses to be configured. (LP: #1771704)
    - Forces bridges with no addresses to be brought online. (LP: #1736975)

netplan.io (0.38) cosmic; urgency=medium

  * New upstream release:
    - Write udev .rules files to /run/udev/rules.d to enforce interface
      renaming. (LP: #1770082)
    - Don't traceback for 'netplan ip leases' when iface is not managed or
      doesn't DHCP (LP: #1768823)
    - Fix duplicate "/" path separator in error messages (LP: #1771440)
    - Fix incorrect terminal reset in 'netplan try' on Ctrl-C. (LP: #1768798)
    - Updated doc entries: mtu, fix fwmark->mark, cleanup optional.
      (LP: #1768783)
    - Added documentation validation at build.
    - Added configuration example for multi-ip interfaces.
  * tests/integration.py: fix test_eth_and_bridge autopkg test harder.
  * debian/control:
    - Add iproute2 to Depends.
    - Add python3-netifaces to Depends, Build-Depends.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 22 Oct 2018 15:02:30 -0400

Changed in netplan.io (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for netplan.io has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Steve Langasek (vorlon) on 2018-11-08
Changed in netplan.io (Ubuntu Bionic):
status: Fix Released → Fix Committed
Gert van Dijk (gertvdijk) wrote :

This change seems to be reverted somehow!?

Briefly saw 0.40.x, installed the update, now the latest in repositories is 0.36.3:

  $ apt policy netplan.io
  netplan.io:
    Installed: 0.40.1~18.04.2
    Candidate: 0.40.1~18.04.2
    Version table:
  *** 0.40.1~18.04.2 100
          100 /var/lib/dpkg/status
      0.36.3 500
          500 http://nl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
      0.36.1 500
          500 http://nl.archive.ubuntu.com/ubuntu bionic/main amd64 Package

Schuk (tszukala) wrote :

Ive also noted the revert and have now my servers complaining about that. Should we wait for 0.40.2 or should we manually downgrade to 0.36.3?

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.40.1~18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done-bionic

Resetting the tags to verification-done as per the discussion in https://bugs.launchpad.net/netplan/+bug/1770082/comments/95.

The SRU had been rolled back due to a regression that needed to be fixed, but we still consider the previous verification to be valid.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.40.1~18.04.3

---------------
netplan.io (0.40.1~18.04.3) bionic; urgency=medium

  * Fix idempotency in renaming: bond members should be exempt from rename, as
    they may all share a single MAC for the bond device. (LP: #1802322)
  * tests/integration.py: add test designed to catch the above regression.

netplan.io (0.40.1~18.04.2) bionic; urgency=medium

  * Fix typo breaking rename on 'netplan apply'. (LP: #1770082)

netplan.io (0.40.1~18.04.1) bionic; urgency=medium

  * Backport netplan 0.40.1 to 18.04. (LP: #1793309)

netplan.io (0.40.1) cosmic; urgency=medium

  * tests/generate.py: use random.sample() instead of random.choices() to
    better support older pythons.
  * Deal gracefully with empty files on 'netplan apply' (LP: #1795343)

netplan.io (0.40) cosmic; urgency=medium

  * New upstream release:
    - networkd: route source is PreferredSource= not From=
    - Improve NetworkManager error reporting on unrenderable routes.
    - Don't render ipv4 dns-search unless we have an ipv4 address.
      (LP: #1786726)
    - Set permissive umask on networkd .network, .link and .netdev files
      (LP: #1736965, LP: #1768560)
    - Fix support for link-scope routes. (LP: #1747455)
    - Update man pages for deletion of replug code.
    - Spell Gratuitous ARP correctly and make it work. (LP: #1756701)
    - Many typo fixes for documentation. (LP: #1783940)
    - Various build system fixes.
    - Fix integration tests:
      - iproute2 output changes for link-scope routes
      - fix stability of networkd igmp-resend test
      - fix manual_addresses test now that networkd lists ~. domain
    - Deduplicate code for parsing interface options
    - Add support for optional-addresses.

netplan.io (0.39) cosmic; urgency=medium

  * New upstream release:
    - Allow link-local addresses to be configured. (LP: #1771704)
    - Forces bridges with no addresses to be brought online. (LP: #1736975)

netplan.io (0.38) cosmic; urgency=medium

  * New upstream release:
    - Write udev .rules files to /run/udev/rules.d to enforce interface
      renaming. (LP: #1770082)
    - Don't traceback for 'netplan ip leases' when iface is not managed or
      doesn't DHCP (LP: #1768823)
    - Fix duplicate "/" path separator in error messages (LP: #1771440)
    - Fix incorrect terminal reset in 'netplan try' on Ctrl-C. (LP: #1768798)
    - Updated doc entries: mtu, fix fwmark->mark, cleanup optional.
      (LP: #1768783)
    - Added documentation validation at build.
    - Added configuration example for multi-ip interfaces.
  * tests/integration.py: fix test_eth_and_bridge autopkg test harder.
  * debian/control:
    - Add iproute2 to Depends.
    - Add python3-netifaces to Depends, Build-Depends.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 21 Nov 2018 14:42:59 -0500

Changed in netplan.io (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers