NFS-based remote root hangs when running 'netplan apply'

Bug #1769682 reported by Mathieu Trudel-Lapierre on 2018-05-07
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
netplan.io (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
nplan (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Netboot users with a remote filesystem over NFS (possibly over other networked filesystems).

[Test cases]
1) Boot a system with its root filesystem over NFS.
2) Run 'sudo netplan apply'
3) Validate that the system remains responsive and keeps connectivity over the same IP address as it had.

[Regression potential]
This SRU changes network properties, and enforces that networkd does not release and re-request an IP address from DHCP when it is restarted. Environments relying on the IP release/renew behavior may find themselves staying on the previous IP address, which might negatively impact connectivity. Changes in connectivity on a system running netplan should be investigated as a potential regression from this SRU. Other regression possibilities would include failure to get a new IP address over time (usually seen as losing connectivity) or possible IP conflicts on a network.

---

With a system booted on the network, with its remote root fs on NFS:

Running 'netplan apply' restarts systemd-networkd, which releases the IP received from DHCP. With no IP (and and IP potentially changing), the NFS server can't be reached so the system hangs.

'netplan apply' or restarting systemd-networkd should not affect teh system, it should continue working normally despite "changing" network states, as long as the effective IP remains the same.

description: updated
Changed in nplan (Ubuntu):
status: New → Invalid
Changed in nplan (Ubuntu Bionic):
status: New → Invalid
Changed in netplan.io (Ubuntu Xenial):
status: New → Invalid
Changed in netplan.io (Ubuntu Artful):
status: New → Invalid

Hello Mathieu, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.36.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in netplan.io (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Mathieu, or anyone else affected,

Accepted nplan into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~17.10.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed-artful
Brian Murray (brian-murray) wrote :

Hello Mathieu, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.37.1

---------------
netplan.io (0.37.1) cosmic; urgency=medium

  * tests/integration.py: fix autopkgtests to be less flaky, especially given
    changes in systemd-networkd's behavior regarding Router Advertisements.

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 11 May 2018 09:58:19 -0400

Changed in netplan.io (Ubuntu):
status: New → Fix Released

This is fixed in cosmic; there a new version of initramfs-tools (0.130ubuntu6).

Changed in initramfs-tools (Ubuntu):
status: New → Fix Released

Verification-doen for xenial: nplan 0.32~16.04.5

Verified that booting a NFS-based remote root system works correctly when /run/netplan/ens3.yaml is written; 'critical: true' is recognized as a valid option in the YAML.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu Artful):
status: New → Confirmed
Changed in initramfs-tools (Ubuntu Bionic):
status: New → Confirmed
Changed in initramfs-tools (Ubuntu Xenial):
status: New → Confirmed

Verification-done for bionic with netplan.io 0.36.2:

Verified that critical: true is now recognized as a valid option and the NFS connectivity is maintained when running 'netplan apply' when it is set in config.

Verification-done for artful with nplan 0.32~17.10.4:

Verified behavior for 'critical: true'; when set the IPs are correcly not released on systemd-networkd restart, which maintains connectivity to the server.

tags: added: verification-done-artful verification-done-bionic
removed: verification-needed verification-needed-artful verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.32~17.10.4

---------------
nplan (0.32~17.10.4) artful; urgency=medium

  * bond/bridge: Support suffixes for time-based values so things like
    "mii-monitor-interval" can support milliseconds. (LP: #1745597)
  * debian/postinst: Write breadcrumbs on disk in /etc/network/interfaces to
    denote the migration to using netplan. (LP: #1756742)
  * DHCPv4: add a "dhcp-identifier: mac" field that can be set to fix interop
    with Windows Server-based DHCP servers which don't support RFC 4361.
    (LP: #1738998)
  * IPv6: accept-ra should default to being unset, so that the kernel default
    can be used. (LP: #1732002)
  * doc/netplan.md: Clarify the behavior for time-based values for bonds
    and bridges. (LP: #1756587)
  * critical: provide a way to set "CriticalConnection=true" on a networkd
    connection, especially for remote-fs scenarios. (LP: #1769682)
  * networkd: don't wipe out /run/netplan on generate: we do want to keep any
    YAML configurations in that directory, we just need to remove generated
    wpasupplicant configs. (LP: #1764869)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 May 2018 11:04:30 -0400

Changed in nplan (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nplan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.32~16.04.5

---------------
nplan (0.32~16.04.5) xenial; urgency=medium

  * bond/bridge: Support suffixes for time-based values so things like
    "mii-monitor-interval" can support milliseconds. (LP: #1745597)
  * Do not attempt to rebind driver 'qeth'. (LP: #1756322)
  * Allow setting ClientIdentifier=mac for networkd-renderered devices
    (LP: #1738998)
  * IPv6: accept-ra should default to being unset, so that the kernel default
    can be used. (LP: #1732002)
  * doc/netplan.md: Clarify the behavior for time-based values for bonds
    and bridges. (LP: #1756587)
  * critical: provide a way to set "CriticalConnection=true" on a networkd
    connection, especially for remote-fs scenarios. (LP: #1769682)
  * networkd: don't wipe out /run/netplan on generate: we do want to keep any
    YAML configurations in that directory, we just need to remove generated
    wpasupplicant configs. (LP: #1764869)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 May 2018 10:36:24 -0400

Changed in nplan (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.36.2

---------------
netplan.io (0.36.2) bionic; urgency=medium

  * doc/netplan.md: Clarify the behavior for time-based values for bonds
    and bridges. (LP: #1756587)
  * critical: provide a way to set "CriticalConnection=true" on a networkd
    connection, especially for remote-fs scenarios. (LP: #1769682)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 May 2018 15:33:48 -0400

Changed in netplan.io (Ubuntu Bionic):
status: Fix Committed → Fix Released
tags: removed: verification-done-artful verification-done-bionic verification-done-xenial

Hello Mathieu, or anyone else affected,

Accepted initramfs-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.130ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
Frank Steinberg (steinberg-9) wrote :

Today, I can confirm that with netplan.io 0.36.2 and initramfs-tools 0.130ubuntu3.2 the bug (initially supplied by me as duplicate #1767359) is fixed.

I simply added the -proposed repo, ran apt update&upgrade, reactivated a minimal netplan config, and rebooted the virtual machine which uses an nfsroot filesystem. It booted straight, and I could confirm from syslog that systemd-network took the DHCP client role, as configured by my netplan config.

Thanks a lot for your efforts!

Łukasz Zemczak (sil2100) wrote :

Hello Mathieu, or anyone else affected,

Accepted initramfs-tools into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.125ubuntu12.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed-artful
Changed in initramfs-tools (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Mathieu, or anyone else affected,

Accepted initramfs-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.122ubuntu8.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Verification-done for xenial with initramfs-tools/0.122ubuntu8.12:

critical: true is correctly written into /run/netplan/$interface.yaml; which makes networkd not bring down the interface when restarting, which avoids crashing the system.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

What are the plans for getting this fixed in bionic? Since I see an upload for this bug in bionic-proposed but it was released along with the fix for another bug that seems to be marked as verification-failed. I would prefer not to release xenial before bionic, if possible.

We need to clarify whether the other bug really is a verification-failed. I don't think it actually fails, it's just an incomplete fix given that there's existing config that we can't easily change post-install.

Changed in initramfs-tools (Ubuntu Artful):
status: Fix Committed → Won't Fix
Łukasz Zemczak (sil2100) wrote :

In case the other fix is not really a verification-failed but simply an incomplete fix as you say, let's mark it as verification-done. But we'll also need someone to verify this bugfix here for bionic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers