d-i install without network does not continue after failing network setup

Bug #870212 reported by C de-Avillez on 2011-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netcfg (Ubuntu)
High
Colin Watson

Bug Description

Oneiric release candidate 2011-10-06; happens on both AMD64 and i386; also if we select "Rescue a broken system" with no network.

Doing a no-network install, debian-installer fails (as expected) to find a network; on accepting Continue, we are thrown back in to the D-I installer steps, postitioned on "Configure the network". Selecting "Configure the clock also fails; selecting "Detect disks" allows installation to proceed.

WORKAROUND:

select "Detect disks" on the "Ubuntu Installer main menu".

C de-Avillez (hggdh2) wrote :
tags: added: iso-testing
Dave Walker (davewalker) on 2011-10-07
tags: added: server-o-ro
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
summary: - no network d-i install does not continue after failing network setup
+ d-i install without network does not continue after failing network
+ setup
Colin Watson (cjwatson) on 2011-10-07
affects: debian-installer (Ubuntu) → netcfg (Ubuntu)
Changed in netcfg (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Medium → High
Colin Watson (cjwatson) wrote :

Ew. Segfaults in the installer are nasty and if I don't fix this for 11.10 I think I'll regret it.

tags: added: regression-release
Changed in netcfg (Ubuntu):
milestone: none → ubuntu-11.10
status: New → Triaged
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

Looks like this was introduced very recently, in netcfg 1.68ubuntu6.

Colin Watson (cjwatson) on 2011-10-07
Changed in netcfg (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.68ubuntu7

---------------
netcfg (1.68ubuntu7) oneiric; urgency=low

  * Fix crash when there are no network interfaces (LP: #870212).
 -- Colin Watson <email address hidden> Sat, 08 Oct 2011 00:42:42 +0100

Changed in netcfg (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers