does not honor netcfg/choose_interface in preseed

Bug #855921 reported by Monty Taylor on 2011-09-21
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
netcfg (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
orchestra (Ubuntu)
High
Dustin Kirkland 
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
High
Dustin Kirkland 

Bug Description

if you pxeboot an image and hand it a preseed file, and in that preseed file you have:

  d-i netcfg/choose_interface select eth0

it doesn't work and it pops up a menu and asks you what interface you want as your default interface.

If, however, you pass netcfg/choose_interface=eth0 to the kernel as a boot option - it works as expected and does not display a menu option for this value.

In a room full of headless machines being booted by cobbler, displaying menus is bad, as is not having those machines be able to find dhcp.

Changed in debian-installer (Ubuntu):
importance: Undecided → High
Monty Taylor (mordred) on 2011-09-21
description: updated
Dustin Kirkland  (kirkland) wrote :

Okay, so this one might be a little tricky...

Our preseed is coming in over http (via the url=http://... parameter in the kernel command line). That necessitates a network up.

I think what we'll need to do is to force the orchestra configuration to default the choose_interface to eth0, and document that this needs to be tweaked for any systems where that's not the case.

Changed in debian-installer (Ubuntu Oneiric):
importance: High → Undecided
Changed in orchestra (Ubuntu Maverick):
status: New → Won't Fix
Changed in orchestra (Ubuntu Natty):
status: New → Won't Fix
Changed in orchestra (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Andres Rodriguez (andreserl)
Dustin Kirkland  (kirkland) wrote :

I'll leave Colin to comment on and validate/invalidated the debian-installer side.

Changed in orchestra (Ubuntu Oneiric):
assignee: Andres Rodriguez (andreserl) → Dustin Kirkland (kirkland)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package orchestra - 2.16-0ubuntu1

---------------
orchestra (2.16-0ubuntu1) oneiric; urgency=low

  [ Dustin Kirkland ]
  * debian/ubuntu-orchestra-logging-server.dirs, logging-
    server/etc/rsyslog.d/99-orchestra.conf:
    - fix logging directories, use Year-Month-Day, add an rsyslog subdir
  * logging-server/etc/rsyslog.d/99-orchestra.conf:
    - enable udp syslog for Ubuntu installation logging
  * provisioning-server/usr/sbin/orchestra-import-isos:
    - add installation syslogging config to kopts
  * provisioning-server/etc/orchestra/import_isos, provisioning-
    server/usr/sbin/orchestra-import-isos: LP: #855921
    - default to choosing eth0 interface, allow overrides; required
      for orchestra to work with multiple NIC systems

  [ Andres Rodriguez ]
  * Only install ubuntu-orchestra-client when deploying oneiric or above.
    Manually grab packages for lucid, maverick, natty. (LP: #855956)
    - orchestra_client_package: Snippet added.
    - juju.preseed: Modified preseed to use new snippet
 -- Andres Rodriguez <email address hidden> Tue, 27 Sep 2011 10:42:54 -0400

Changed in orchestra (Ubuntu Oneiric):
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2011-10-23
affects: debian-installer (Ubuntu) → netcfg (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in netcfg (Ubuntu Maverick):
status: New → Confirmed
Changed in netcfg (Ubuntu Natty):
status: New → Confirmed
Changed in netcfg (Ubuntu Oneiric):
status: New → Confirmed
Changed in netcfg (Ubuntu):
status: New → Confirmed
Michael Warren (mike-ef) wrote :

Was this bug supposed to be resolved in Precise? I am able to reproduce it in 12.04-server.

Asher Newcomer (ashern) wrote :

+1 I am also encountering this bug in 12.04 server

Stuart (sjbertram) wrote :

I'm still having to set up the kopts for this to work, rather than specifying in the preseed on 12.04.

Michael DeHaan (mdehaan) wrote :

me also also

ooshlablu (ooshlablu) wrote :

Hey Guys,
I just ran into this issue as well, but I don't think its a preseed issue. Instead it seems like an unavoidable misordering of operations. In order to get the preseed file, the installer needs to have an ip address, which it does not have right out of the gate, even though one is required in order to pxe boot in the first place. If you look at the order in which the installer runs things, it does network configuration a few steps before actually fetching the preseed file. I'm not sure what to do about that, just offering my observations.

Mark Shirley (maspwr) wrote :

We ran into this issue on 13.10 as well.

Max Bowsher (maxb) wrote :

ooshlablu is correct. You cannot preseed network settings in a preseed file which the installer is loading from a network location, because the network needs to be configured before the preseed can be fetched.

The solution here is to pass the appropriate options on the kernel command line.

You can either preseed the interface value directly, or you can pass the BOOTIF option on the kernel command line, which netcfg will use.

If using pxelinux, the relevant option is "IPAPPEND 2". http://www.syslinux.org/wiki/index.php/SYSLINUX#SYSAPPEND_bitmask

I'll set this bug to status Invalid now, as it's actually a support request on how to set up automated PXE, rather than an actual bug.

Changed in netcfg (Ubuntu):
status: Confirmed → Invalid
Changed in netcfg (Ubuntu Maverick):
status: Confirmed → Invalid
Changed in netcfg (Ubuntu Natty):
status: Confirmed → Invalid
Changed in netcfg (Ubuntu Oneiric):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers