add vlan support

Bug #1567687 reported by Dimitri John Ledkov on 2016-04-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
netcfg (Debian)
New
Unknown
netcfg (Ubuntu)
High
Dimitri John Ledkov
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * xenial 16.04.0 has vlan support in netcfg, however it was failing to propagate vlan settings to the installed system. This change fixes the logic to copy the settings through to the installed system correctly, when using ifupdown (the default case)

[Test Case]

 * Install system with vlan configuration, e.g. boot with netcfg/vlan_id=123
 * Make sure installed system has vlan_id configured in /etc/networking/interfaces and networking comes up as expected

[Regression Potential]

 * Medium, netcfg postinst is changed affecting all installations

[Other Info]

 * vlan_id question is of medium priority, therefore if navigating the installer interractively, one should lower the debconf priority before configuring networking.

description: updated
Changed in netcfg (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → In Progress
importance: Undecided → High
summary: - add vlan support
+ [FFe] add vlan support
tags: added: s390x
Changed in netcfg (Debian):
importance: Undecided → Unknown
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.135ubuntu6

---------------
netcfg (1.135ubuntu6) yakkety; urgency=medium

  * With vlan connection type, finish-install.d would decide to purge
    network configuration and writeout loopback interfaces only, due to
    the assumption that !wired, must be wireless. Write out loopback only
    config with wireless only connection type. With this change vlan
    settings propagate through to the system, after additional
    network-manager changes were added. LP: #1567687

 -- Dimitri John Ledkov <email address hidden> Thu, 12 May 2016 12:26:10 +0100

Changed in netcfg (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu456

---------------
debian-installer (20101020ubuntu456) yakkety; urgency=medium

  * Cherry-pick fix from Debian git for dosfstools 4.0 regression.

debian-installer (20101020ubuntu455) yakkety; urgency=medium

  * Rebuild to include updated netcfg package. LP: #1572607, LP: #1567687

 -- Adam Conrad <email address hidden> Fri, 13 May 2016 11:15:51 -0600

Changed in debian-installer (Ubuntu):
status: New → Fix Released
summary: - [FFe] add vlan support
+ add vlan support
description: updated

Hello Dimitri, or anyone else affected,

Accepted netcfg into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netcfg/1.135ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in netcfg (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Dimitri, or anyone else affected,

Accepted debian-installer into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu451.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Xenial):
status: New → Fix Committed
Dimitri John Ledkov (xnox) wrote :

vlan installation works correctly with xenial-proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcfg - 1.135ubuntu4.1

---------------
netcfg (1.135ubuntu4.1) xenial; urgency=medium

  * With vlan connection type, finish-install.d would decide to purge
    network configuration and writeout loopback interfaces only, due to
    the assumption that !wired, must be wireless. Write out loopback only
    config with wireless only connection type. With this change vlan
    settings propagate through to the system, after additional
    network-manager changes were added. LP: #1567687

  * When DHCP is disabled via preseed, do not ask the DHCP question on
    s390x by propagating the seen flags from preseed-only keys to the
    interactive question. This is a side-effect / regression from
    1.135ubuntu3. LP: #1572607

 -- Dimitri John Ledkov <email address hidden> Thu, 19 May 2016 11:34:16 +0100

Changed in netcfg (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for netcfg has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu451.1

---------------
debian-installer (20101020ubuntu451.1) xenial; urgency=medium

  * Rebuild with updated netcfg package:
    - fix propagation of netcfg/vlan_id settings LP: #1567687
    - fix disabling dhcp via preseed on s390x LP: #1572607

 -- Dimitri John Ledkov <email address hidden> Fri, 20 May 2016 05:42:25 +0100

Changed in debian-installer (Ubuntu Xenial):
status: Fix Committed → Fix Released
Ryan Beisner (1chb1n) on 2016-08-15
tags: added: uosci
Changed in netcfg (Debian):
status: Fix Committed → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.