Installation of Network put a wrong DNS, crashing the Installation

Bug #128165 reported by Marcelo Atie on 2007-07-25
14
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
netcfg (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

The network installation's on Ubuntu Alternate put a wrong DNS,
then, in the installation, the system delay many time to resolve many hosts.
(approximately 45 minutes and 33 seconds.)
The delay happen when the installation checks if exist a newest version of the packages.

This seems to occur on the Automatic and Manual installation of Network even so no one LAN cable was plugged in.

On the Manual Installation, this simply auto complete the DNS with the IP of Gateway. BUT THIS IS WRONG ! and will make the installation delay.

On Automatic Installation, the DNS putted has wrong too.

Automatic thinks is very good, but they never should do something wrong.

PS: sorry for the bad English.

Marcelo Atie (marceloatie) wrote :

the full syslog

Marcelo Atie (marceloatie) wrote :

I found other person reporting the same bug
Bug #121038

My installation stopped in 85% too

Excuse me, i think that isn't the same problem because i have an error when i tried to install the s.o. not packages of internet.When i have this problem i didn't activated the net.Another difference is that you use an alpha of gutsy,and i used feisty.Other thing, you say that you use ubuntu 7.04, but if you see you are downloading packages of the 7.10 version,are you upgrading,perhaps..??

br??where are you from??brasil??

Marcelo Atie (marceloatie) wrote :

frieser,

This is the same problem, If you press CTRL+ALT+F2 (i think) when installing you will see the output of installation, with all that is happening. In the main screen of installation you won't see that the installation is trying a download.

I DIDN'T ACTIVATED THE NET - This is the problem !

Yes, this a report of alpha of gutsy, but it occurred in feisty too.

I didn't say that i use ubuntu 7.04. I said that I installed Ubuntu 7.04 by Desktop CD, because my ubuntu 7.04 alternate (like your CD) crashes.

Yes, I'm from Brazil.

and in attachment is a picture of the main screen in installation when it try to use internet, but don't is showed.

frieser (fiti-pol) wrote :

Sorry marcelo, i was wrong. Yes it's the same problem and maybe is the net connection.I didn't see the output of installation when it crashed.This is a big problem because any whithout a internet connection don't be able to install ubuntu with alternate method.I need the alternate installation because from the live cd's installation i have many problems with the resolution of the screen and with network manager.Do you tried to configure internet connection in the alternate installation or you didn't have it?

I hope that somebody rapair this bug.

Another time, Sorry!!

Marcelo Atie (marceloatie) wrote :

Solved !

This problem has occurring because the automatic detection of LAN is wrong.

To install the Ubuntu alternate you need CANCEL the automatic detection of LAN and configure manually your lan, and PUT YOUR *NAME SERVER* (DNS) IN BLANK. so the installation will continue very well.

OR ...

well, the installation don't stop really, it only try to resolve the names of repositories. And this step may to delay for 45 minutes and 33 seconds.

Marcelo Atie (marceloatie) wrote :

The best solution to implement in Ubuntu is change the automatic detection of LAN to put the DNS in blank, and change the manual configuration of LAN to not auto complete the DNS server.

Changed in debian-installer:
status: New → Fix Committed
frieser (fiti-pol) wrote :

Great!!

Thanks and congratulations! I will try this afternoon.Thanks, because i hadn't time to investigate it.Good job.

Changed in debian-installer:
status: Fix Committed → Confirmed
Marcelo Atie (marceloatie) wrote :

In the auto configuration of network (the step "Configure the Network with DHCP"), to every put the resolv.conf in blank, we can simply comment the "make_resolv_conf" at the script dhclient-script on http://launchpadlibrarian.net/8534296/netcfg_1.39ubuntu2.tar.gz

But if the netcfg detect correctly the DNS of someone, it may don't be the best way to fix it.

PS1: It never worked right with me !

PS2: Very thanks to the incentive of frieser, if you succed in you installation, please, post here.

Changed in debian-installer:
status: New → Confirmed
Marcelo Atie (marceloatie) wrote :

The manual configuration of Network seems to be in netcfg-common.c

description: updated
description: updated
description: updated
description: updated
frieser (fiti-pol) wrote :

Sorry by the long time without post, but i had work.

I have looked the file dhclient-script, and yes i can guest that if you comment the module "make_resolv_conf" you fix the problem but i think as you that isn't the best fix.I tried to install whitout put the nameserver(as you said) and it finished correctly. Please, i demand you to post all your advances of yours investigations for try to fix this problem.Thanks and good luck!

description: updated
Evan (ev) on 2007-08-15
Changed in debian-installer:
assignee: nobody → evand
Colin Watson (cjwatson) wrote :

I don't think any of this is the right option. The problem is that apt has a long timeout for each Packages file it downloads, and it applies that timeout in sequence each time. This was supposed to have been fixed ages ago so that it would be much less painful ...

Marcelo Atie (marceloatie) wrote :

Colin Watson, maybe if we decrease the timeout of apt, then some users gonna have problems downloading packages,
Will be good, a simple script to test the connection before try downloading packages, what do you think ?

Marcelo Atie (marceloatie) wrote :

After the automatic configuration of network, Ubuntu should test the Internet or we need change the timeout of apt.

A Sample:
when trying download packages from security.ubuntu.com, and Ubuntu see that security.ubuntu.com was unreachable, why Ubuntu try download other packages from the same domain ?
if the user has a bad network configuration like me, it will spend many hours,

i hope that a day someone fix this bug to make Ubuntu work in a bad system as well as in a good system.

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in debian-installer:
status: Confirmed → Incomplete

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

This bug don't affect-me more, i think we should hold it on invalid still i
try it with Ubuntu 9.04 or someone give us a feedback

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Evan (ev) on 2009-02-02
Changed in debian-installer:
assignee: evand → nobody

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Wir haben Ihre Anfrage erhalten und an die entsprechende Stelle weitergeleitet.

Sie werden noch eine Antwort erhalten.

AAS Computer System
Iperbit.Net
A. Stomeo

Thank you for taking the time to report this bug and helping to make Ubuntu better. I noticed that the package version your bugging is updated in Lucid. Please update via http://releases.ubuntu.com/lucid/ repost a detailed error report, and update the bug status. Thanks!

Changed in netcfg (Ubuntu):
status: Confirmed → Incomplete
Colin Watson (cjwatson) on 2010-09-16
Changed in netcfg (Ubuntu):
assignee: Ubuntu Installer Team (ubuntu-installer) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for netcfg (Ubuntu) because there has been no activity for 60 days.]

Changed in netcfg (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for debian-installer (Ubuntu) because there has been no activity for 60 days.]

Changed in debian-installer (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers