netcat alternative command line incompatible in lynx

Bug #515091 reported by halfdog
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
netcat (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: netcat

Lucid lynx ended up with both netcat.traditional and netcat.openbsd installed. It seems that this occured during today's update:

The following NEW packages will be installed:
  iso-codes librasqal2 linux-image-2.6.32-12-generic netcat-openbsd
  xserver-xorg-input-wacom
The following packages will be upgraded:
...

Having both packages installed should not be a problem, but the since the new default (via etc/alternatives) is netcat.openbsd, some scripts don't work due to changed command line syntax:

Start nc.traditional in listening mode, bound to port 1024:

nc -vnlp 1024

Start nc.openbsd in listening mode, bound to port 1024:

nc -vnl 1024

Since I did not find a command line that works with both, this might be annoying.

(It seems that the dependency on netcat.openbsd is from ubuntu-minimal package, perhaps this might also be a bug)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers